summaryrefslogtreecommitdiff
path: root/dev-perl/File-Copy-Link
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/File-Copy-Link
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/File-Copy-Link')
-rw-r--r--dev-perl/File-Copy-Link/File-Copy-Link-0.140.0.ebuild30
-rw-r--r--dev-perl/File-Copy-Link/Manifest3
-rw-r--r--dev-perl/File-Copy-Link/metadata.xml24
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/File-Copy-Link/File-Copy-Link-0.140.0.ebuild b/dev-perl/File-Copy-Link/File-Copy-Link-0.140.0.ebuild
new file mode 100644
index 000000000000..5f5e376ee2e6
--- /dev/null
+++ b/dev-perl/File-Copy-Link/File-Copy-Link-0.140.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RMBARKER
+DIST_VERSION=0.140
+inherit perl-module
+
+DESCRIPTION="Perl extension for replacing a link by a copy of the linked file"
+
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/File-Copy-Link/Manifest b/dev-perl/File-Copy-Link/Manifest
new file mode 100644
index 000000000000..bc5583db96da
--- /dev/null
+++ b/dev-perl/File-Copy-Link/Manifest
@@ -0,0 +1,3 @@
+DIST File-Copy-Link-0.140.tar.gz 11157 BLAKE2B 4f751ffef556ac7cedb57bf8189f4e57a1e64210327c9bd28401f52c63437a88418fc41f5c1f8624b7b3bb66496eced9a36a3ed3cc320e614a6b6cb9dfb28548 SHA512 d937d8353c4be3070591c7e28ea177e587326936cea6d84d895d0fd951e663e506c5680f0d8acad756972db7c70147b31078a2e2595bcab4bb56879b97f3c8b1
+EBUILD File-Copy-Link-0.140.0.ebuild 543 BLAKE2B 7f3f163e4d2285e0369f8e11f6feb799345ba140550978d7cde53f831a46fbbab159df00a23affbd5e31c10871d2571154f32632b36044ee280ea5ceddc3f587 SHA512 20c35446e3ef5ac5989ea94f86819771d152ecdf6835101f360a8128d4f62a6be841d9d039c292b5e6faadbdca2f4664a3426f9dc30f5d0b5479c8a7ba1e6b93
+MISC metadata.xml 1172 BLAKE2B c22400c6068f74c08ec59ab7607acd517478c1335dd6d1e30186490ed8be88b576009250c99891bd3104b944369e6dc6ac6cbca75aa072542128815ab9359310 SHA512 b1e74608a35c3c6b511186c1ef837bc515a682fdd9ddffcf4c76f5430f16616a1943c823ce9772c988eb12c150129c29241526969085e61b92db9c1ebf39889d
diff --git a/dev-perl/File-Copy-Link/metadata.xml b/dev-perl/File-Copy-Link/metadata.xml
new file mode 100644
index 000000000000..10aebea1c024
--- /dev/null
+++ b/dev-perl/File-Copy-Link/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>c.affolter@purplehaze.ch</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>The Quota module provides access to file system quotas. The quotactl system call or ioctl is used to query or set quotas on the local host, or queries are submitted via RPC to a remote host. Mount tables can be parsed with getmntent and paths can be translated to device files (or whatever the actual quotactl implementations needs as argument) of the according file system.</longdescription>
+ <upstream>
+ <remote-id type="cpan">File-Copy-Link</remote-id>
+ <remote-id type="cpan-module">File::Copy::Link</remote-id>
+ <remote-id type="cpan-module">File::Spec::Link</remote-id>
+ </upstream>
+</pkgmetadata>