summaryrefslogtreecommitdiff
path: root/dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild')
-rw-r--r--dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild b/dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild
new file mode 100644
index 000000000000..6805867d3038
--- /dev/null
+++ b/dev-perl/FFI-CheckLib/FFI-CheckLib-0.280.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=0.28
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Check that a library is available for FFI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-1.302.15
+ >=dev-perl/Test2-Suite-0.0.60
+ )
+"
+
+PERL_RM_FILES=(
+ "t/ci.t"
+)