summaryrefslogtreecommitdiff
path: root/dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild')
-rw-r--r--dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild b/dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild
new file mode 100644
index 000000000000..387822ced163
--- /dev/null
+++ b/dev-perl/FFI-CheckLib/FFI-CheckLib-0.270.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=0.27
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Check that a library is available for FFI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-1.302.15
+ >=dev-perl/Test2-Suite-0.0.60
+ )
+"
+PERL_RM_FILES=(
+ "t/ci.t"
+)