summaryrefslogtreecommitdiff
path: root/dev-perl/Exporter-Tiny
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Exporter-Tiny
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Exporter-Tiny')
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-0.42.0.ebuild23
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild23
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild25
-rw-r--r--dev-perl/Exporter-Tiny/Manifest7
-rw-r--r--dev-perl/Exporter-Tiny/metadata.xml14
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-0.42.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-0.42.0.ebuild
new file mode 100644
index 000000000000..0cb88b9b8fe8
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-0.42.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=TOBYINK
+MODULE_VERSION=0.042
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild
new file mode 100644
index 000000000000..16a934a4e773
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-0.44.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.044
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild
new file mode 100644
index 000000000000..5e58a6f190de
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.000000
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
diff --git a/dev-perl/Exporter-Tiny/Manifest b/dev-perl/Exporter-Tiny/Manifest
new file mode 100644
index 000000000000..fe5a770002c3
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Manifest
@@ -0,0 +1,7 @@
+DIST Exporter-Tiny-0.042.tar.gz 32173 BLAKE2B 535f72d3540094794f5c05cdbff98109f19be8d69989c16be4e80145edc8fe95dfcee26b2ff733970123983ad0751cc6d8c2267472cadd81d52c1344c1aef028 SHA512 b69b722842b4a907fa434a1a798df6f983bae74d7b82e925a1db684cb166f2ef02a72cce176173af035321dc27ad35b49e1fb1ee57c0e2ca6596d84da140c06f
+DIST Exporter-Tiny-0.044.tar.gz 29636 BLAKE2B ccdbf5ed853276076aa9276109fd9ebabfb539adcb7afcee6e0603a69b68bbbc9aca9c8cd46d4186e001a47287d80bc8f79f9ed916b263fc486a238e9fea80ac SHA512 49f8df450c1e21b56df3ef0f15ef138f21429a2a4c3c0e8809b25c57dc42ae4d28e3db125676ca5d293517d36a81b41fcfe2b3f4a4d37530b5de5f92bd05d03a
+DIST Exporter-Tiny-1.000000.tar.gz 29844 BLAKE2B c3d1a6621e402b42f9a95a1048b8d590d4109f8c9457d51d0202739aa8dac332978f417e611ea4f25debc34f5ed15cea78d6ae250d32199c42c402f48cd1946b SHA512 02e72b3d1ec09fb5b7da5638893a12098d3300cfc36ff417c8d5cd8a4ef54891d675310612130e118e0e6a88d615cc18cdc888ab7333f2fc1007632c82d4c349
+EBUILD Exporter-Tiny-0.42.0.ebuild 618 BLAKE2B e3f9827f40f4717dae6ddb931acbbd0a425d4191377ac37a3ae3ea6827544b3f46bf7871aca5aa4589a80af3b76a30031319753e592cc57c07686d784f21f953 SHA512 852a1efb581011412e9699c64051d37eb77730b6fad5c2d9843083ce5706eea26f86d428618ad8dac9eba2ca9be62a8655614330e81eb3473b21a335cc45ae3d
+EBUILD Exporter-Tiny-0.44.0.ebuild 653 BLAKE2B cff7e8873b4a4ea120134185b3e97fbc974f915d2f37ce64f7b5fdbe82e70f4b4f641f7c81a79e520532732d9d4c893364fab4c1bc199c3c41de9e3038d2d4ff SHA512 ec0b49f20bba74f8c3a05dc4c06f2c018c427d776002de93372deaf7fe8c9bc508b4ffc589bd11d716a84facd0cc6fc345001a9ae1398adf1971523128be3279
+EBUILD Exporter-Tiny-1.0.0.ebuild 681 BLAKE2B dc80c3df4d60a7462610898c593c9eee636a9a770f132d7e294ade540536046513ce960236da6be2877a967d06f4ae177ce9e2fc123a4e735595401224e150b5 SHA512 78621cad506055d01472c867b3a06886e2f4dbd259ff87532be16b3805253d29b19bfbbf9d025415d5226adc4e52aa55b0982370bd33ddae6d308837757bdbdf
+MISC metadata.xml 526 BLAKE2B ff3d85e25fb9fc01e22051e32193d99818a9ea73ed6ac8385ec4cb4a2734cb63e46c78c4c8467fdeacae7a66931fe608638080ca1eb5e615b926c4d35c9c494b SHA512 92bf9ce5fa1f9e099d8984eb0be24cfeb9596c50ce420f9d1c9e2ff62ed51ca2a7b23d95ae685ebd2657e5b607910d02492f0c93c6d0b926187ede4a35356679
diff --git a/dev-perl/Exporter-Tiny/metadata.xml b/dev-perl/Exporter-Tiny/metadata.xml
new file mode 100644
index 000000000000..0dac48b7a502
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tobyink/p5-exporter-tiny</remote-id>
+ <remote-id type="cpan">Exporter-Tiny</remote-id>
+ <remote-id type="cpan-module">Exporter::Shiny</remote-id>
+ <remote-id type="cpan-module">Exporter::Tiny</remote-id>
+ </upstream>
+</pkgmetadata>