summaryrefslogtreecommitdiff
path: root/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 13:19:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 13:19:15 +0100
commitb02a2ac044a27eeef2c52b57308a8591b07448fa (patch)
tree7400c59c9e5d0f3d0d502a7eff9e3e0d4ccc166d /dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild
parente4cd098fab4f141df4d2fd24dfdc9b5f223c694b (diff)
gentoo auto-resync : 21:06:2023 - 13:19:15
Diffstat (limited to 'dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild')
-rw-r--r--dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild
new file mode 100644
index 000000000000..37eed0e35bac
--- /dev/null
+++ b/dev-perl/Exporter-Tiny/Exporter-Tiny-1.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.006002
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="An exporter with the features of Sub::Exporter but only core dependencies"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+
+PERL_RM_FILES=(
+ inc/Test/Fatal.pm
+ inc/Test/Requires.pm
+ inc/Try/Tiny.pm
+ inc/archaic/Test/Builder.pm
+ inc/archaic/Test/Builder/IO/Scalar.pm
+ inc/archaic/Test/Builder/Module.pm
+ inc/archaic/Test/Builder/Tester.pm
+ inc/archaic/Test/Builder/Tester/Color.pm
+ inc/archaic/Test/More.pm
+ inc/archaic/Test/Simple.pm
+ SIGNATURE
+)