summaryrefslogtreecommitdiff
path: root/dev-perl/Exception-Class
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Exception-Class
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Exception-Class')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild29
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild28
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild28
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.430.0.ebuild28
-rw-r--r--dev-perl/Exception-Class/Manifest9
-rw-r--r--dev-perl/Exception-Class/metadata.xml13
6 files changed, 135 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
new file mode 100644
index 000000000000..5f498bb091aa
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.39
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild
new file mode 100644
index 000000000000..02dd5aa64ebd
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.41
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
new file mode 100644
index 000000000000..55fbdb65a493
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.420.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.42
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/Exception-Class/Exception-Class-1.430.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.430.0.ebuild
new file mode 100644
index 000000000000..896dba57c989
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.430.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.43
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/Exception-Class/Manifest b/dev-perl/Exception-Class/Manifest
new file mode 100644
index 000000000000..e62a3517e197
--- /dev/null
+++ b/dev-perl/Exception-Class/Manifest
@@ -0,0 +1,9 @@
+DIST Exception-Class-1.39.tar.gz 38936 BLAKE2B 60a7aac2d8b37342ecd9714070af4d4bcc89794486856017193669ae51094b9b762ba1f92e7f020f1d10321aee10c7d29509805a618371a72cd59f7cf597e047 SHA512 c290a0b87b7a5e288c6c954f7ab834204184edc81089f871f1eb994d1445e3938170c1e87119fd952177dd43a3a228522188282fb0151ae33ba3a55b29a28b50
+DIST Exception-Class-1.41.tar.gz 45432 BLAKE2B d1648c9493ac1802f71070fdbb22e5e544dcfc76b3db1347774a3385d46c315a7039fb7393b9d68ec33ba8c3d0c3cb02af160352d1b28307cae96e9311a81018 SHA512 32fce6b6307a6fffcbb8f1f0b0955f2a6ff3701fb8a8b1350cb60666591871ed2ac537bfe26a002578347f29b8f1c831f43bb8d66f76c798de0e401075e55f79
+DIST Exception-Class-1.42.tar.gz 45718 BLAKE2B 0cd6cee87aaf0f107f724c839cedc3ed686f367c5286f96ab9e8fec6354ca5647ecd67fede44ee8522e77c33917b4f0380b11f4aafdc59f4e695eee2633c8607 SHA512 b13f13882a4ca1bb44219dab1ebc7cd730d3b739e8f540b597fa3aa0adc0ede00e927844d293c584f05cce643c23bac73703318873c526c94668b8f9ff98a643
+DIST Exception-Class-1.43.tar.gz 45601 BLAKE2B d4069f801e4690f2d6347ee98f6570fa08bc3197078eded7a6a538cae9d4c23be56e21ea985951c81b4183ba1955ac6961b24e29136c849d65174f0de217738c SHA512 8416f82032dd39c38c9a4e12d7ae23cd0d66e1cbe9b22bde274972031c6218ed2d90cf9caf052a3d201decf92e715d0bf56a42789f35a7a60b9ea66680fb2668
+EBUILD Exception-Class-1.390.0.ebuild 659 BLAKE2B 6f1d7c3300a505b14208a1f826d41ec6ee0a584451aa418a0abe71465ab3b483cdef2e2594402a9d74fc1afdd9db68d2bbb49be87e9d9f1e5d4cc3ae035111fb SHA512 756d9e20d341d11ca36f9ba64031183bc891605f6c77e1049b05e5b0030ef0d677e943d0423e277c97e90955f9659719aea6296cd69ddbfb475b8c062057243b
+EBUILD Exception-Class-1.410.0.ebuild 665 BLAKE2B d4cdc8e32a7482c519a1e88491c30d25dc03b970558d9beb6273746a6df70ed10067e3d482393d9fae4084306b329d8ba7e392db6a83edb2b8aeca50c83b3131 SHA512 aa64e655bd327743abb7273505a5e24905084b015318abbf573d30a366eeaa0faac9a54bcc231b59541dbcbb512b935f985e0490793ac1b82dbe03d52347596f
+EBUILD Exception-Class-1.420.0.ebuild 672 BLAKE2B 0cd3443e5403eafc860f0ff77071c57f33f76a4fd2d7383992c01fc561a20d03cff685000c64ce68f4bca8a430ebeef592bd66a81cae69c4909050f7b0a8dffb SHA512 d2c8694def3ab248d7800fc4392b5530c36324766d23c910995e4d53b22279a5e3270325dcbf49905fc4744f3df8a6053ae5ad113136a72be6d51defad243175
+EBUILD Exception-Class-1.430.0.ebuild 671 BLAKE2B 4fb48d7e5dd4cbb9a2596998d0e76ab6dfee607f8860c9926b1221d0da6dfdc107b4951965419cf378dddaac4db6a4bf84484a893a9aae80d60bf20c2379dffb SHA512 077be3d9c98ad1bc3003602dae64392f5349151931aac69a4f46b91adae1b6e484fb91addc05438960438598f55e977207b32fb79cc66b66ca47d0b17b11dca2
+MISC metadata.xml 471 BLAKE2B 97ae454f0c53b8f3b7f051c157a0f6d89943964f35150850916606b09144c675511399136a637014b265981fb37fe176b76bf9e8f307c07228f54c6d3f85cfad SHA512 45f0b6b80305cdc7c1af3c62b9442e6464a02fee42908455f3e33de7c981046a7421d097320ed9be07e63c8d66f891fa6a4273d23ad025ef978e4ed20f0918e6
diff --git a/dev-perl/Exception-Class/metadata.xml b/dev-perl/Exception-Class/metadata.xml
new file mode 100644
index 000000000000..77e502647f01
--- /dev/null
+++ b/dev-perl/Exception-Class/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Exception-Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class::Base</remote-id>
+ </upstream>
+</pkgmetadata>