summaryrefslogtreecommitdiff
path: root/dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild')
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild
new file mode 100644
index 000000000000..8eeb957d163e
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250.100.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.2501
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
+"
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}