summaryrefslogtreecommitdiff
path: root/dev-perl/Event/Event-1.270.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/Event/Event-1.270.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/Event/Event-1.270.0.ebuild')
-rw-r--r--dev-perl/Event/Event-1.270.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Event/Event-1.270.0.ebuild b/dev-perl/Event/Event-1.270.0.ebuild
new file mode 100644
index 000000000000..719688225a8d
--- /dev/null
+++ b/dev-perl/Event/Event-1.270.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETJ
+DIST_VERSION=1.27
+inherit perl-module
+
+DESCRIPTION="Fast, generic event loop"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-1.0.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+mydoc="ANNOUNCE INSTALL TODO Tutorial.pdf Tutorial.pdf-errata.txt"