summaryrefslogtreecommitdiff
path: root/dev-perl/Devel-NYTProf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Devel-NYTProf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Devel-NYTProf')
-rw-r--r--dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild37
-rw-r--r--dev-perl/Devel-NYTProf/Manifest4
-rw-r--r--dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch41
-rw-r--r--dev-perl/Devel-NYTProf/metadata.xml24
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild b/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild
new file mode 100644
index 000000000000..ace57f8d8ed5
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=6.04
+DIST_EXAMPLES=("demo/*")
+inherit perl-module
+
+DESCRIPTION="Powerful feature-rich perl source code profiler"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/File-Which-1.90.0
+ virtual/perl-Getopt-Long
+ dev-perl/JSON-MaybeXS
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-XSLoader
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.840.0
+ >=dev-perl/Test-Differences-0.60.0
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-perl526.patch" )
+src_test() {
+ perl_rm_files t/90-pod.t t/91-pod_coverage.t t/92-file_port.t \
+ t/71-moose.t t/72-autodie.t t/68-hashline.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Devel-NYTProf/Manifest b/dev-perl/Devel-NYTProf/Manifest
new file mode 100644
index 000000000000..f9fdc8afd183
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/Manifest
@@ -0,0 +1,4 @@
+AUX Devel-NYTProf-6.40.0-perl526.patch 1403 BLAKE2B 34a5a47059f1777bb50a09d774cc3433879e146dd3523c190b46aa63dc93959c7c16034944438d8d6e7dd40e4fb8d865cbb2eae0575708593a8d48f172a3f757 SHA512 ceb987196321b7e08bd8d1b83cff802ae66fc7a82642e9e0a8b578ecc42af7a859da4cc2028112febfbc74b584e3b75f3307be864cc6eacf6fdf9568e574ce42
+DIST Devel-NYTProf-6.04.tar.gz 461716 BLAKE2B 63bc0e46625eeff091deb8339102585997f14c68e453481ebdf546ad5c9a44491bc874967f7cb17c26d1935dc7b1ac18ea84ee1ebe9e8aef0806478e9e7b8335 SHA512 67b5013f4b3e54db743964f91fd8113fbe672be81026aae3375e9bb5376205d735c91ddbde05784a7df235a8e43ef3db2713e396c13e45726ca594e1e76d051c
+EBUILD Devel-NYTProf-6.40.0.ebuild 797 BLAKE2B e2dbb2262f3aa1100be2e09a1783afb4b6fcf13d1c53eeee1a971a3d223f678c111ee1df79c5738397c1152dbad2f7b856f0cb21bf056524de017f2d25cff5bc SHA512 28eacaea2abadc026bff1b87863efae458db72a7d6d056617a7ac7cd269e44d5a7aa95e859f45fcc19c49dbf9435fce4ba95d58ad36c0c08d3c9e8cf45db5bdc
+MISC metadata.xml 1236 BLAKE2B 4e79df0f41de5a49bab1992f6e8db0212b6befe5c91fe4f09dd70400b7fd8548b6130265b6235bc566e09385b7e92aecd7529aef4c14ebe3ba81ec1c9dfaeb9e SHA512 c113998d635e62bd13406b2c8112485f6b3bb0bf7efcf2f60d50eb176ed82fe4ed85263545c7ad5d680b752c12523ee7e1cf30eb4c9d3e20a6c256f89be75361
diff --git a/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch b/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch
new file mode 100644
index 000000000000..cd81f120dddb
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch
@@ -0,0 +1,41 @@
+From 461055d041e0e08f5fe851461db42ea7121fa39f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 8 Oct 2017 07:44:14 +1300
+Subject: Fix test failures on Perl 5.26 w/ PERL_USE_UNSAFE_INC=0
+
+Perl 5.26+ removes '.' from the default @INC, and this breaks the
+mechanism internally where @INC-prefixes are stripped from fid_fileinfo
+names ( in ::FileInfo.pm ).
+
+This breaks tests due to the sample 'rdt' files expecting single-token
+comparators relative to 't/', instead getting a fully qualified path in
+the "got" side of the test.
+
+This remedies this by ensuring a fully-qualified path to "t/" is in
+@INC for the aforementioned prefix-stripper to pick-up on.
+
+Bug: https://github.com/timbunce/devel-nytprof/issues/108
+Bug: https://bugs.gentoo.org/615734
+Bug: https://github.com/timbunce/devel-nytprof/pull/112
+---
+ t/lib/NYTProfTest.pm | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/t/lib/NYTProfTest.pm b/t/lib/NYTProfTest.pm
+index 9c29627..7fb5381 100644
+--- a/t/lib/NYTProfTest.pm
++++ b/t/lib/NYTProfTest.pm
+@@ -69,6 +69,10 @@ my $text_extn_info = {
+ pf => { order => 50, tests => 2, },
+ };
+
++# having t/* in @INC is necessary for prefix-stripping
++# to reduce test-file names down to the single tokens
++# that are used in the comparison-output files.
++unshift @INC, File::Spec->rel2abs('./t') if -d 't';
+ chdir('t') if -d 't';
+
+ if (-d '../blib') {
+--
+2.14.1
+
diff --git a/dev-perl/Devel-NYTProf/metadata.xml b/dev-perl/Devel-NYTProf/metadata.xml
new file mode 100644
index 000000000000..c4728df9c2ea
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Devel-NYTProf</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Apache</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Constants</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Core</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Data</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::FileHandle</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::FileInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::ReadStream</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Reader</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Run</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::SubCallInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::SubInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Util</remote-id>
+ </upstream>
+</pkgmetadata>