summaryrefslogtreecommitdiff
path: root/dev-perl/Debug-Client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Debug-Client
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Debug-Client')
-rw-r--r--dev-perl/Debug-Client/Debug-Client-0.300.0.ebuild41
-rw-r--r--dev-perl/Debug-Client/Manifest6
-rw-r--r--dev-perl/Debug-Client/files/Debug-Client-0.30-no-dot-inc.patch534
-rw-r--r--dev-perl/Debug-Client/metadata.xml12
4 files changed, 593 insertions, 0 deletions
diff --git a/dev-perl/Debug-Client/Debug-Client-0.300.0.ebuild b/dev-perl/Debug-Client/Debug-Client-0.300.0.ebuild
new file mode 100644
index 000000000000..4aa9d2aeffeb
--- /dev/null
+++ b/dev-perl/Debug-Client/Debug-Client-0.300.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Client side code for perl debugger"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.330.100
+ >=virtual/perl-Exporter-5.700.0
+ >=virtual/perl-IO-Socket-IP-0.290.0
+ >=dev-perl/PadWalker-1.980.0
+ >=virtual/perl-Term-ReadLine-1.140.0
+ >=dev-perl/Term-ReadLine-Gnu-1.200.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=dev-perl/File-HomeDir-1.0.0
+ >=virtual/perl-File-Temp-0.230.400
+ >=virtual/perl-Scalar-List-Utils-1.380.0
+ >=dev-perl/Test-CheckDeps-0.10.0
+ >=dev-perl/Test-Class-0.420.0
+ >=dev-perl/Test-Deep-0.112.0
+ >=virtual/perl-Test-Simple-1.1.3
+ >=dev-perl/Test-Requires-0.70.0
+ >=virtual/perl-parent-0.228.0
+ >=virtual/perl-version-0.990.800
+ >=dev-perl/PadWalker-1.920.0
+ >=dev-perl/Term-ReadLine-Perl-1.30.300
+ )
+"
+PATCHES=( "${FILESDIR}/${PN}-0.30-no-dot-inc.patch" )
diff --git a/dev-perl/Debug-Client/Manifest b/dev-perl/Debug-Client/Manifest
new file mode 100644
index 000000000000..07e5f628b23e
--- /dev/null
+++ b/dev-perl/Debug-Client/Manifest
@@ -0,0 +1,6 @@
+AUX Debug-Client-0.30-no-dot-inc.patch 12287 SHA256 d1de90a01015fa98a26aacb32794954725f7f06f78c41f9b22706935d4a8d345 SHA512 4d7f44e39e31ed22bac33c82806492755d8f163f78272a47eb1503dda74be61a4a5170e1e1fc1e973bddb3c08612ec38866cfbc6701ffc3ed15aee9b48698368 WHIRLPOOL 3a333458e4b7e41fe5645dd3f90d51c451557b3be23bc6f7552d2bab985246ebd4e3dd42722ff99a621e425914ea154c03979530ce74c9a5c8a038913cb5ec0a
+DIST Debug-Client-0.30.tar.gz 41779 SHA256 f5d9013a98e25a97eabcdcd888a3bf65f9ff047dac38d761488192386e2375b2 SHA512 7de7abac46d6a7f7e1785921f69a23b4d92fa3fe03d0609d5354a0d3459c616213e7715237a8a0a1863363ba21e5ebd99c1f9fb8bf4f622b96aec3dd20eedaf9 WHIRLPOOL d8c57a528c65eb15355278f1b46de7dec93641ab69a09dcb00ef96f29a4207c4f0ca8198eeb5bbc9cb3dc3274b95b8a72caea80247a836fe59d232c3b7ca30bb
+EBUILD Debug-Client-0.300.0.ebuild 1036 SHA256 d85988ccf9d41e654701603533a73fe1fb1403803c8f859e435f4aaa3d73e800 SHA512 36aac425f00319c7517afe18a96bcc39dcb10822598ac30146b1be3569bdf9aaa07b9a58a3ca3b07d81ba57ee571ff7867078e64a15d40ea0d03be19ead0a6e4 WHIRLPOOL 3aa0cfba6d261856f21c2dce2f728b8becba3ff234859963cda49f0d098f48976db5a3d1dfacd84439de70107353b67c60fe4035a3c4311cdd3836d00e9d031f
+MISC ChangeLog 2661 SHA256 bef20cedda6a0de85794a17398f455ffe823d0996a7e8b4f333cccded7d1127c SHA512 74299da8ec39b99066f02417d6f82c9be0f446466e4f7fdff6a707ceb61551d010f7e069bdffb63c03c503ec8fa82982680d969f1f735dd49f23be6cbb84e0eb WHIRLPOOL 7d5a2bfafef39c9ae818e9c97a705ae6b2e3ef42b914c2c9cb64d1a027be276ea670f760847e507fd5cb2cc8b1f657303fd67c8700a3ff70d7a3ca7ae775a5e0
+MISC ChangeLog-2015 1616 SHA256 c51586a1dbc2e4cb71d5dec470645681227526ff6fc13ae9367c2351f7b9fc2a SHA512 83d233f68c0e0233976fba86fa681931ed650f6a2a0ad025aea7ebf78d17b069dd2563e675afd8ce9850f8122670dce6ade3eae4db557919c86e916d69c8eef4 WHIRLPOOL 42c84678dfcf07a89ed9877bdb8065a323c21d88f21ec9a5d5579d95610e4933b9d50a0bffacd35b500bfe6aa6f573a4204d40a12dfb8644663611d1ab2634a6
+MISC metadata.xml 396 SHA256 445b3380e645b696694964f94dc2fa1aa87888a7f5f2100a470fc1e577e80e17 SHA512 6593c513627c46c73acfd32f8d74c3610006b290270f7b1b589e10855f0dfbbcdfb16f463e8a6bdfed01c69bbbe577da0966d93d6bb0406ab34ae93fc38ded71 WHIRLPOOL 52ba433f5682130cbf55da7abf9d927dd2896eac360d9c75cdd0aeafbd7e61efc659c5b44ab13ff6d449557807e0b10b78933847eb2487c76ce01734b10c5aa8
diff --git a/dev-perl/Debug-Client/files/Debug-Client-0.30-no-dot-inc.patch b/dev-perl/Debug-Client/files/Debug-Client-0.30-no-dot-inc.patch
new file mode 100644
index 000000000000..4727a9a7a405
--- /dev/null
+++ b/dev-perl/Debug-Client/files/Debug-Client-0.30-no-dot-inc.patch
@@ -0,0 +1,534 @@
+From b49aa99cbf608072dd6969bd859765dbf4be71f5 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sat, 1 Jul 2017 12:21:16 +1200
+Subject: [PATCH] Fix broken loading of local modules under Perl 5.26
+
+Perl 5.26 breaks the implication that:
+
+ use inc::Module::Install;
+ use t::lib::Debugger;
+
+Will load:
+
+ ./inc/Module/Install.pm
+ ./t/lib/Debugger.pm
+
+Respectively, due to '.' ceasing to be in @INC
+
+This fixes:
+- Makefile.PL by re-inserting the '.' ( which is the only
+ thing that works, due to Module::Install shenanigans ).
+- Tests by replacing "use" statements with equivalent "require"
+statements.
+
+Some of the existing code ( eg: use_ok ) was already spurious and not
+very smart, because calling ->import while being outside of BEGIN { }
+has limited usefullness.
+
+But this was left with the semantically equivalent code that retains
+the loading of the relative path.
+
+There are strategies that would be "nicer" than what I've done,
+but they all wind up with you wanting to rename "Debugger.pm" to
+something else, because:
+
+ use lib "t/lib";
+ use Debugger;
+
+Is going to give people a much different impression from either
+
+ use t::lib::Debugger
+
+Or
+
+ BEGIN {
+ require "./t/lib/Debugger.pm";
+ t::lib::Debugger->import();
+ }
+
+This closes https://github.com/PadreIDE/Debug-Client/issues/6
+PR: https://github.com/PadreIDE/Debug-Client/pull/7
+---
+ Changes | 2 ++
+ Makefile.PL | 1 +
+ t/01-compile.t | 2 +-
+ t/08-io.t | 5 ++++-
+ t/10-top_tail.t | 5 ++++-
+ t/10-top_tail_old.t | 6 +++++-
+ t/11-add.t | 5 ++++-
+ t/13-return.t | 5 ++++-
+ t/14-run.t | 5 ++++-
+ t/15-run_to_line.t | 5 ++++-
+ t/16-run_to_sub.t | 5 ++++-
+ t/17-stepin.t | 5 ++++-
+ t/18-stepout.t | 5 ++++-
+ t/19-stepover.t | 5 ++++-
+ t/20-get_value.t | 5 ++++-
+ t/21-toggle_trace.t | 5 ++++-
+ t/22-subnames.t | 5 ++++-
+ t/23-breakpoints.t | 5 ++++-
+ t/24-y_zero.t | 5 ++++-
+ t/25-get_v_vars.t | 5 ++++-
+ t/26-get_x_vars.t | 5 ++++-
+ t/27-get_p_exp.t | 5 ++++-
+ t/28-get_h_var.t | 5 ++++-
+ t/29-options.t | 5 ++++-
+ t/40-test_1415-old.t | 5 ++++-
+ t/40-test_1415.t | 5 ++++-
+ t/99-perldb.t | 5 ++++-
+ t/lib/Test_1415.pm | 5 ++++-
+ t/lib/Top_Tail.pm | 3 ++-
+ 29 files changed, 107 insertions(+), 27 deletions(-)
+
+diff --git a/Changes b/Changes
+index 104d73f..f9b1090 100644
+--- a/Changes
++++ b/Changes
+@@ -1,5 +1,7 @@
+ Changes for Debug::Client
+
++ - Fix build and test failures under Perl 5.26 when '.' is not in @INC (KENTNL, PR #7)
++
+ 0.30 2017-06-19
+ - Merged PR #5 (Fixed test failure due to perl regression fix in 5.21.3), thanks @TBSliver.
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 8702771..74201e3 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install 1.08;
+
+ name 'Debug-Client';
+diff --git a/t/01-compile.t b/t/01-compile.t
+index 73eb289..a6130a5 100644
+--- a/t/01-compile.t
++++ b/t/01-compile.t
+@@ -8,7 +8,7 @@ use Test::More tests => 18;
+
+ BEGIN {
+ use_ok('Debug::Client');
+- use_ok('t::lib::Debugger');
++ require_ok('./t/lib/Debugger.pm');
+
+ use_ok( 'Carp', '1.20' );
+ use_ok( 'IO::Socket::IP', '0.21' );
+diff --git a/t/08-io.t b/t/08-io.t
+index 41c6914..0f90433 100644
+--- a/t/08-io.t
++++ b/t/08-io.t
+@@ -6,7 +6,10 @@ local $OUTPUT_AUTOFLUSH = 1;
+
+ use Test::More tests => 12;
+ use Test::Deep;
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ my ( $dir, $pid ) = start_script('t/eg/05-io.pl');
+ my $path = $dir;
+diff --git a/t/10-top_tail.t b/t/10-top_tail.t
+index 577e7fc..0d11183 100644
+--- a/t/10-top_tail.t
++++ b/t/10-top_tail.t
+@@ -7,7 +7,10 @@ local $OUTPUT_AUTOFLUSH = 1;
+ use FindBin qw($Bin);
+ use lib map "$Bin/$_", 'lib', '../lib';
+
+-use t::lib::Top_Tail;
++BEGIN {
++ require "./t/lib/Top_Tail.pm";
++ t::lib::Top_Tail->import;
++};
+
+ # run all the test methods
+ Test::Class->runtests;
+diff --git a/t/10-top_tail_old.t b/t/10-top_tail_old.t
+index 93802e3..02ab515 100644
+--- a/t/10-top_tail_old.t
++++ b/t/10-top_tail_old.t
+@@ -10,7 +10,11 @@ local $| = 1;
+ use Test::More tests => 5;
+ use Test::Deep;
+ use PadWalker;
+-use t::lib::Debugger;
++
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ ok( start_script('t/eg/14-y_zero.pl'), 'start script' );
+
+diff --git a/t/11-add.t b/t/11-add.t
+index 6000234..86dc166 100644
+--- a/t/11-add.t
++++ b/t/11-add.t
+@@ -9,7 +9,10 @@ local $| = 1;
+
+ use Test::More tests => 10;
+ use Test::Deep;
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ # Testing step_in (s) and show_line (.) on a simple script
+
+diff --git a/t/13-return.t b/t/13-return.t
+index a096b17..9e901b5 100644
+--- a/t/13-return.t
++++ b/t/13-return.t
+@@ -7,7 +7,10 @@ use warnings FATAL => 'all';
+ # Turn on $OUTPUT_AUTOFLUSH
+ local $| = 1;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ my ( $dir, $pid ) = start_script('t/eg/03-return.pl');
+
+diff --git a/t/14-run.t b/t/14-run.t
+index 3c7ed02..9bc9fc0 100644
+--- a/t/14-run.t
++++ b/t/14-run.t
+@@ -7,7 +7,10 @@ use warnings FATAL => 'all';
+ # Turn on $OUTPUT_AUTOFLUSH
+ local $| = 1;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ my ( $dir, $pid ) = start_script('t/eg/02-sub.pl');
+
+diff --git a/t/15-run_to_line.t b/t/15-run_to_line.t
+index 95c1f1c..6e38e62 100644
+--- a/t/15-run_to_line.t
++++ b/t/15-run_to_line.t
+@@ -7,7 +7,10 @@ use warnings FATAL => 'all';
+ # Turn on $OUTPUT_AUTOFLUSH
+ local $| = 1;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ my ( $dir, $pid ) = start_script('t/eg/02-sub.pl');
+
+diff --git a/t/16-run_to_sub.t b/t/16-run_to_sub.t
+index 0703c03..6629dc1 100644
+--- a/t/16-run_to_sub.t
++++ b/t/16-run_to_sub.t
+@@ -7,7 +7,10 @@ use warnings FATAL => 'all';
+ # Turn on $OUTPUT_AUTOFLUSH
+ local $| = 1;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ my $pid = start_script('t/eg/02-sub.pl');
+
+diff --git a/t/17-stepin.t b/t/17-stepin.t
+index 3df15cd..3c272d8 100644
+--- a/t/17-stepin.t
++++ b/t/17-stepin.t
+@@ -13,7 +13,10 @@ plan( tests => 4 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/02-sub.pl');
+ my $debugger;
+diff --git a/t/18-stepout.t b/t/18-stepout.t
+index 262d380..ff45ecc 100644
+--- a/t/18-stepout.t
++++ b/t/18-stepout.t
+@@ -13,7 +13,10 @@ plan( tests => 4 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/02-sub.pl');
+ my $debugger;
+diff --git a/t/19-stepover.t b/t/19-stepover.t
+index 244686d..bf1fcea 100644
+--- a/t/19-stepover.t
++++ b/t/19-stepover.t
+@@ -13,7 +13,10 @@ plan( tests => 3 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/02-sub.pl');
+ my $debugger;
+diff --git a/t/20-get_value.t b/t/20-get_value.t
+index ec6cc60..216de3b 100644
+--- a/t/20-get_value.t
++++ b/t/20-get_value.t
+@@ -13,7 +13,10 @@ plan( tests => 6 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/02-sub.pl');
+ my $debugger;
+diff --git a/t/21-toggle_trace.t b/t/21-toggle_trace.t
+index 2f37031..da154e6 100644
+--- a/t/21-toggle_trace.t
++++ b/t/21-toggle_trace.t
+@@ -13,7 +13,10 @@ plan( tests => 2 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/22-subnames.t b/t/22-subnames.t
+index e77b5ac..89b5dac 100644
+--- a/t/22-subnames.t
++++ b/t/22-subnames.t
+@@ -13,7 +13,10 @@ plan( tests => 2 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/23-breakpoints.t b/t/23-breakpoints.t
+index e63d5d8..611f92e 100644
+--- a/t/23-breakpoints.t
++++ b/t/23-breakpoints.t
+@@ -13,7 +13,10 @@ plan( tests => 7 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/03-return.pl');
+ my $debugger;
+diff --git a/t/24-y_zero.t b/t/24-y_zero.t
+index f561c3e..23b03c9 100644
+--- a/t/24-y_zero.t
++++ b/t/24-y_zero.t
+@@ -13,7 +13,10 @@ plan( tests => 3 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/25-get_v_vars.t b/t/25-get_v_vars.t
+index 1b9338a..ce538af 100644
+--- a/t/25-get_v_vars.t
++++ b/t/25-get_v_vars.t
+@@ -13,7 +13,10 @@ plan( tests => 2 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/26-get_x_vars.t b/t/26-get_x_vars.t
+index 5e66430..f478298 100644
+--- a/t/26-get_x_vars.t
++++ b/t/26-get_x_vars.t
+@@ -13,7 +13,10 @@ plan( tests => 2 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/27-get_p_exp.t b/t/27-get_p_exp.t
+index 7b1649a..9432deb 100644
+--- a/t/27-get_p_exp.t
++++ b/t/27-get_p_exp.t
+@@ -13,7 +13,10 @@ plan( tests => 7 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/28-get_h_var.t b/t/28-get_h_var.t
+index b47a6eb..0138d96 100644
+--- a/t/28-get_h_var.t
++++ b/t/28-get_h_var.t
+@@ -13,7 +13,10 @@ plan( tests => 2 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/29-options.t b/t/29-options.t
+index 3b4b1ba..c41b165 100644
+--- a/t/29-options.t
++++ b/t/29-options.t
+@@ -13,7 +13,10 @@ plan( tests => 4 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/14-y_zero.pl');
+ my $debugger;
+diff --git a/t/40-test_1415-old.t b/t/40-test_1415-old.t
+index 22dd789..ce16241 100644
+--- a/t/40-test_1415-old.t
++++ b/t/40-test_1415-old.t
+@@ -13,7 +13,10 @@ plan( tests => 12 );
+
+
+ #Top
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ start_script('t/eg/test_1415.pl');
+ my $debugger;
+diff --git a/t/40-test_1415.t b/t/40-test_1415.t
+index b7269a4..3b78280 100644
+--- a/t/40-test_1415.t
++++ b/t/40-test_1415.t
+@@ -7,7 +7,10 @@ local $OUTPUT_AUTOFLUSH = 1;
+ use FindBin qw($Bin);
+ use lib map "$Bin/$_", 'lib', '../lib';
+
+-use t::lib::Test_1415;
++BEGIN {
++ require "./t/lib/Test_1415.pm";
++ t::lib::Test_1415->import();
++}
+
+ # run all the test methods
+ Test::Class->runtests;
+diff --git a/t/99-perldb.t b/t/99-perldb.t
+index 3cf3d66..2326149 100644
+--- a/t/99-perldb.t
++++ b/t/99-perldb.t
+@@ -9,7 +9,10 @@ local $| = 1;
+
+ use Test::More tests => 1;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ if (rc_file) {
+ diag('');
+diff --git a/t/lib/Test_1415.pm b/t/lib/Test_1415.pm
+index 9712d69..5aa23b4 100644
+--- a/t/lib/Test_1415.pm
++++ b/t/lib/Test_1415.pm
+@@ -7,7 +7,10 @@ use parent qw(Test::Class);
+ use Test::More;
+ use Test::Deep;
+
+-use t::lib::Debugger;
++BEGIN {
++ require "./t/lib/Debugger.pm";
++ t::lib::Debugger->import;
++}
+
+ # setup methods are run before every test method.
+ sub load_debugger : Test(setup) {
+diff --git a/t/lib/Top_Tail.pm b/t/lib/Top_Tail.pm
+index 9fccf24..f5a01b0 100644
+--- a/t/lib/Top_Tail.pm
++++ b/t/lib/Top_Tail.pm
+@@ -11,7 +11,8 @@ use Test::Deep;
+ sub startup : Test(4) {
+ my $self = shift;
+
+- use_ok( 't::lib::Debugger');
++ require_ok('./t/lib/Debugger.pm');
++ t::lib::Debugger->import;
+ ok( start_script('t/eg/14-y_zero.pl'), 'start script' );
+ ok( $self->{debugger} = start_debugger(), 'start debugger' );
+ ok( $self->{debugger}->get, 'get debugger' );
+--
+2.13.1
+
diff --git a/dev-perl/Debug-Client/metadata.xml b/dev-perl/Debug-Client/metadata.xml
new file mode 100644
index 000000000000..12227c69c989
--- /dev/null
+++ b/dev-perl/Debug-Client/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Debug-Client</remote-id>
+ <remote-id type="cpan-module">Debug::Client</remote-id>
+ </upstream>
+</pkgmetadata>