summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime/DateTime-1.520.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/DateTime/DateTime-1.520.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/DateTime/DateTime-1.520.0.ebuild')
-rw-r--r--dev-perl/DateTime/DateTime-1.520.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.520.0.ebuild b/dev-perl/DateTime/DateTime-1.520.0.ebuild
new file mode 100644
index 000000000000..ae06828db4a1
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.520.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.52
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CONFLICTS="
+ !<=dev-perl/DateTime-Format-Mail-0.402.0
+"
+RDEPEND="
+ ${CONFLICTS}
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-1.60.0
+ >=dev-perl/DateTime-TimeZone-2.20.0
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Params-ValidationCompiler-0.260.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Specio-0.180.0
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+ >=dev-perl/namespace-autoclean-0.190.0
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-CPAN-Meta-Requirements
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}