summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild
new file mode 100644
index 000000000000..c39cdc4f4a85
--- /dev/null
+++ b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.790.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.79
+inherit perl-module
+
+DESCRIPTION="Parse and Format DateTimes using Strptime"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-1
+ >=dev-perl/DateTime-Locale-1.300.0
+ >=dev-perl/DateTime-TimeZone-2.90.0
+ virtual/perl-Exporter
+ dev-perl/Params-ValidationCompiler
+ >=dev-perl/Specio-0.330.0
+ dev-perl/Try-Tiny
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Warnings
+ )
+"