summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild
new file mode 100644
index 000000000000..97f030f721f7
--- /dev/null
+++ b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.110.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SCHUBIGER
+DIST_VERSION=1.11
+inherit perl-module
+
+DESCRIPTION="Parse informal natural language date/time strings"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Clone
+ dev-perl/Date-Calc
+ dev-perl/DateTime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ dev-perl/List-MoreUtils
+ >=dev-perl/Params-Validate-1.150.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ virtual/perl-Term-ReadLine
+ dev-perl/boolean
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ dev-perl/Module-Util
+ dev-perl/Test-MockTime
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)