summaryrefslogtreecommitdiff
path: root/dev-perl/Data-FormValidator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Data-FormValidator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Data-FormValidator')
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild67
-rw-r--r--dev-perl/Data-FormValidator/Manifest4
-rw-r--r--dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch34
-rw-r--r--dev-perl/Data-FormValidator/metadata.xml19
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
new file mode 100644
index 000000000000..63b2a572fe9a
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.88
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.170.0
+ >=dev-perl/MIME-Types-1.5.0
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=( "${FILESDIR}/${P}-skip-readme-pod.patch" )
+src_test() {
+ local i;
+ elog "Install the following dependencies for comprehensive tests:"
+ i="$(if has_version '>=dev-perl/CGI-4.350.0'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i >=dev-perl/CGI-4.350.0"
+ elog " - Test interop with CGI.pm as an input source";
+ i="$(if has_version 'dev-perl/CGI-Simple'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/CGI-Simple"
+ elog " - Test interop with CGI::Simple as an input source";
+ i="$(if has_version 'dev-perl/Template-Toolkit'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/Template-Toolkit"
+ elog " - Test Template.pm can format Data::FormValidator objects";
+ elog
+ perl_rm_files t/pod.t
+ local MODULES=(
+ "Data::FormValidator ${DIST_VERSION}"
+ "Data::FormValidator::Constraints ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Dates ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Upload ${DIST_VERSION}"
+ "Data::FormValidator::ConstraintsFactory ${DIST_VERSION}"
+ "Data::FormValidator::Filters ${DIST_VERSION}"
+ "Data::FormValidator::Results ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Manifest b/dev-perl/Data-FormValidator/Manifest
new file mode 100644
index 000000000000..b5adf4848bf1
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Manifest
@@ -0,0 +1,4 @@
+AUX Data-FormValidator-4.880.0-skip-readme-pod.patch 929 BLAKE2B 7b242ff1b4edc37aae285d992506101652546a5b9a12bd14fc14659e3746a3676d2bd49245efc10f00b86c3b8b9ca79bc2d43d5f5570332bdb34fc97656f974d SHA512 379ff29c0269c4b052a2d48b4c084f1d69744a1e61dccd025d649a9d915579c3d81ced95ab2fce42f24ecc6a68e1b96a7a9a81e7583faddd5326c76dbbd897b3
+DIST Data-FormValidator-4.88.tar.gz 99850 BLAKE2B abb72030dd9b6155c83aa95d975643c6ebd4e4b8b15b7cc360d1a2ff81eddc9b210e8bda7408876f27bba9241541f1e3e6289ebb037a50e0a77d5850b281be76 SHA512 f4f9d813a3c9ae3cefdc1795516c955307dbaa23ca464e5a0a31eb4a9f43a3f31da8155b911433d29915d65da5b05d0843b7de45287d977a0c58ba19f3cfc736
+EBUILD Data-FormValidator-4.880.0.ebuild 2119 BLAKE2B 36bd13c8b6686626aa6bfa5861c8d589897488b92a0b8deacb55e2599b58523c1efb3811b15899e2f9153b0796c8ee00402f89777fb7e525a5f01de5e2851dfb SHA512 e30410f07a92aa67cfc16d925b9633863522b3f05b7c719617d9662e754112771bf01094968df973e6b6917c0924cded78639368febb8b25c3c70974bedf808e
+MISC metadata.xml 989 BLAKE2B 0d66c4b6bd1f4670a0a63acef6454cca651ec6e856baa1549083c9ed357a3bb437d2dc5ee318353768adb1ebe52436dd82aad287f60553b1517aa858f117a00b SHA512 39f935d8c1a17b313a288065757f35134e7f8440737397f50abf30ceb6071372ef253ebfd92d3f9996c99cce6374f3458ef4c98f9010aba10f3e791762013de3
diff --git a/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
new file mode 100644
index 000000000000..17cf910684f2
--- /dev/null
+++ b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
@@ -0,0 +1,34 @@
+From f0afbb4d0d21cee2ef0497ca8205e375bf7eb19d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 10 Oct 2017 03:23:55 +1300
+Subject: Prevent installing README.pod to final install
+
+This fixes the final "make install" so that matching regexed files do
+not get copied from blib/ to the OS
+
+Previously, a cruft file could be found in @INC by performing:
+
+ perldoc Data::README
+
+Which would give you the README.pod of Data::FormValidator
+
+This is a left-over artifact from the old days where this mechanism
+was The Way to install .pod/.pm files, and is still heavily used this
+way for .xs files.
+
+Bug: https://github.com/dnmfarrell/Data-FormValidator/pull/7
+---
+ INSTALL.SKIP | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 INSTALL.SKIP
+
+diff --git a/INSTALL.SKIP b/INSTALL.SKIP
+new file mode 100644
+index 0000000..85828ef
+--- /dev/null
++++ b/INSTALL.SKIP
+@@ -0,0 +1 @@
++\bREADME\.pod$
+--
+2.14.1
+
diff --git a/dev-perl/Data-FormValidator/metadata.xml b/dev-perl/Data-FormValidator/metadata.xml
new file mode 100644
index 000000000000..c5e3db9535e7
--- /dev/null
+++ b/dev-perl/Data-FormValidator/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Data-FormValidator</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::Dates</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::RegexpCommon</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::Upload</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::ConstraintsFactory</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Filters</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Results</remote-id>
+ </upstream>
+</pkgmetadata>