summaryrefslogtreecommitdiff
path: root/dev-perl/Data-FormValidator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Data-FormValidator
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Data-FormValidator')
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.810.0-r1.ebuild31
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.850.0.ebuild30
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild32
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.860.0.ebuild30
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild67
-rw-r--r--dev-perl/Data-FormValidator/Manifest14
-rw-r--r--dev-perl/Data-FormValidator/files/4.86-dot-in-inc.patch58
-rw-r--r--dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch34
-rw-r--r--dev-perl/Data-FormValidator/metadata.xml19
9 files changed, 315 insertions, 0 deletions
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.810.0-r1.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.810.0-r1.ebuild
new file mode 100644
index 000000000000..cbb432a7b635
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.810.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MARKSTOS
+MODULE_VERSION=4.81
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.17
+ >=dev-perl/MIME-Types-1.005
+ dev-perl/Regexp-Common
+ >=dev-perl/Perl6-Junction-1.10
+ dev-perl/Email-Valid"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+SRC_TEST=do
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.850.0.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.850.0.ebuild
new file mode 100644
index 000000000000..4a092f1d1b8f
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.850.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.85
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.17
+ >=dev-perl/MIME-Types-1.005
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild
new file mode 100644
index 000000000000..e25c5bbe98a7
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.86
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/4.86-dot-in-inc.patch" )
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.17
+ >=dev-perl/MIME-Types-1.005
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0.ebuild
new file mode 100644
index 000000000000..29504d422030
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.86
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.17
+ >=dev-perl/MIME-Types-1.005
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
new file mode 100644
index 000000000000..55615c0f9af3
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.88
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.170.0
+ >=dev-perl/MIME-Types-1.5.0
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=( "${FILESDIR}/${P}-skip-readme-pod.patch" )
+src_test() {
+ local i;
+ elog "Install the following dependencies for comprehensive tests:"
+ i="$(if has_version '>=dev-perl/CGI-4.350.0'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i >=dev-perl/CGI-4.350.0"
+ elog " - Test interop with CGI.pm as an input source";
+ i="$(if has_version 'dev-perl/CGI-Simple'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/CGI-Simple"
+ elog " - Test interop with CGI::Simple as an input source";
+ i="$(if has_version 'dev-perl/Template-Toolkit'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/Template-Toolkit"
+ elog " - Test Template.pm can format Data::FormValidator objects";
+ elog
+ perl_rm_files t/pod.t
+ local MODULES=(
+ "Data::FormValidator ${DIST_VERSION}"
+ "Data::FormValidator::Constraints ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Dates ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Upload ${DIST_VERSION}"
+ "Data::FormValidator::ConstraintsFactory ${DIST_VERSION}"
+ "Data::FormValidator::Filters ${DIST_VERSION}"
+ "Data::FormValidator::Results ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Manifest b/dev-perl/Data-FormValidator/Manifest
new file mode 100644
index 000000000000..96bc0c2384d2
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Manifest
@@ -0,0 +1,14 @@
+AUX 4.86-dot-in-inc.patch 1730 SHA256 8fd132b25ff0c7754f9e8ec95ecf332a1a5f79ec2297408db6adc652a203c88e SHA512 667bf21b8cd3142cdb6af70c5ca0d0754752fd3f881b6789d1760a6d8fe3135f708df9a0225522d0822f90cb37a8d326f17456ead2a3751e165d101a2805a901 WHIRLPOOL 832efab7e6da7f2475e4ebf2ef4985544b4b310e5a2cb81f45b29361e92db44813fad30abd14d66a96c25ddd541a29ffc5a835ea659990aedbb50c9b55bdc5a0
+AUX Data-FormValidator-4.880.0-skip-readme-pod.patch 929 SHA256 fb670568dcc7bb2135dc06c5c30c9bdfc5e70cce63df9a6c3d751f7e9e4ce750 SHA512 379ff29c0269c4b052a2d48b4c084f1d69744a1e61dccd025d649a9d915579c3d81ced95ab2fce42f24ecc6a68e1b96a7a9a81e7583faddd5326c76dbbd897b3 WHIRLPOOL ff60b84c3a04b624f262cf223da0577787241d6a54204b37b5d4a126602ac83e21fef9f7212abab2b38087fb646d9e5680fbd6a6c4c86a1e5fbb215ed7fa02ee
+DIST Data-FormValidator-4.81.tar.gz 109870 SHA256 f844056231b2eeb4068cafbcab1ddf5d46cb348bd5cfb1d234421c09ee8a0de3 SHA512 c9939686e60bb75e658a95407d616e7907f97e85d049d69abaf7ac89678985c555fe6d4177c773916c57964a45a423582e74d3cf79d75cef87a22f913ef82e23 WHIRLPOOL b730999ccfb945b102ecaf9cddeea2d64035b880ce82187410dbd16a8c7a09412299ea20cd7533d8edc485f7caa213ead21c0046ae9438191e8cd23b8e9d7bb3
+DIST Data-FormValidator-4.85.tar.gz 99367 SHA256 809f15d05434ff5667c3967e71e86308fcfad8fce1057420bd2714300b2a5870 SHA512 6ccd119553f85728d01f57a1fb0a8b24241ea09d951dd761c52594302e687c33cdefbf37c2161ad02fca2363c530b7023185a0b75ba304ade6caed9d7faa77cb WHIRLPOOL d052a1d7b787086a5cc07fa1dfd1100463ad8184225e45f2915966a3b7b308cc08ce2bd860ae28d5ec0bfbb3d126b229fa3f1a2d909254239409b5df6beb6f0b
+DIST Data-FormValidator-4.86.tar.gz 101409 SHA256 004fc21b95574402229f498b9cbdffc5c16a88302338dcc0b3b8091012cdc407 SHA512 ca9e178313dcc15006a0d5557494d50d9328ae4ae9b54428bfd76b3c6169767290f819c70af1928f772ce9a2cd2139eb373e69394af8f03eee0f061525bc76f4 WHIRLPOOL 5698cef0514e84a2004075b66f3eae9d58bcf67a54fec9a040f8045d4e9d31a3b06f4dcc0c0b6b1d079fce1a2d79a126103dd19486dfca0cff3f66f2b3cda3ba
+DIST Data-FormValidator-4.88.tar.gz 99850 SHA256 c1a539f91c92cbcd8a8d83597ec9a7643fcd8ccf5a94e15382c3765289170066 SHA512 f4f9d813a3c9ae3cefdc1795516c955307dbaa23ca464e5a0a31eb4a9f43a3f31da8155b911433d29915d65da5b05d0843b7de45287d977a0c58ba19f3cfc736 WHIRLPOOL 3bd800dc253abd03c19514560234bfc4c840a96e52d2f6dcacb516b41c6690481cf668ad2ce1ae7f8dca5aad426302eecd9e86d37194f009a84c149029428d9a
+EBUILD Data-FormValidator-4.810.0-r1.ebuild 625 SHA256 679ba66e2b915352eabf7776b5136d1f2fd158b5d418fde0833f2840b6c1aa53 SHA512 1afd868b890a256ab903121f9699771c0e0ba641571ae53abfd8906258da9533e637571fb8f4d03905da5d8930324c1de456baf94f8efd9efe79109dd74cdf91 WHIRLPOOL 01851210369e5f4dd6a6a5d9f89232c4eebe3455765d0badef3006f36c52cd41ee4e2c52d602e89aa349db9b27e18bc2e8223f6852ec0df848fc4b7b8ed529f8
+EBUILD Data-FormValidator-4.850.0.ebuild 601 SHA256 6400b26035eb6dabb437b19a819795aa69505cb36a8019f8598d0d266c2c0fe4 SHA512 983a50bbd5affc4cbc3af9c95ae8d646ace18d96c18fef5a27b8c9c3a1090f55ce6a99c7dd1950ddf380efb20e81c1904a0cac3510eedb27ca9cb9b7545f7c38 WHIRLPOOL 4e54162461dc1ee32e99e4141b61beb1a57a16bbb2bbc777e2a7b36abf858de50280320a3b1667dc091064adfc405f63665d4dca9443953d1bfed9d20236f209
+EBUILD Data-FormValidator-4.860.0-r1.ebuild 671 SHA256 f8e56c4400e0512b71ad759e34616a482df5b1981128410d8c91a30e3447971f SHA512 f73298cc76ec94f46e62a12d37603d9d8b6c266570892a6f6ebe2c62e877839b349606ecf32db165980245a5867e5c6e79ffcdcf0ac082fef50b0af93329d134 WHIRLPOOL a24d15d4d8d6cb69c7b1b9ac2462a52fb8620731f6549002bdc765d63573ee0fd7e06fd4fd142d141a09a4d05d836b26bf7b3dfc9b3ada66c16ee04bfe75234e
+EBUILD Data-FormValidator-4.860.0.ebuild 601 SHA256 b3b016ae8da688601da58f7a78c156d696416ee220b8a8bf67b5aca2dc6786db SHA512 ad6ee69777dba9ebeee7ced20fa2fb557809feb5c87e6f97850f87ca16eb7481577a0b1fbf7a4678b298ff79d1d45b0e1b05dce8181dde6a5ae2be20a386c191 WHIRLPOOL 93a0c05b9b96cf49abb9cca8306d87ca466c533ed883f6175f203c511cbfa6224ba16a33d4cfbbe94a7c4ef98fc19c8d913285941ca6eb4fe05684b91be3f526
+EBUILD Data-FormValidator-4.880.0.ebuild 2123 SHA256 7cec6c6ca54da550b706fd1f3fc823192175f3e1118bae289a3a3641e907769c SHA512 be6943c86fee373305afe0db9f483ee158aea728b9e3f3a2a130877343d1a93e9766dbf71e81c137be0a51952a02980d3d13d008a9cc1f2997645b467a4c3dba WHIRLPOOL 5e41a645d1cbac8146a761d96c3f4f555de2a363f744ab95798a15acb1b9b23cb583c1e14f378b91106e5b9752abc0dc13bf1a4bebdaefe04c639a53a5295bca
+MISC ChangeLog 3358 SHA256 bcc9745fc49cbd0097ec2b02e1885b39434a22ab1417b7db74d9c8be7de0c92f SHA512 431fa152d53e9d7485e12eb789a3ce0e2e69a551e241bb2338c01a010cd61dee607eae15f5957c4a8a22edbd7762d4a615af132e65d233246bc23032eee4b140 WHIRLPOOL 94b1a41b12e28eeef3e2547b778f0e87f8824464a939e80adc0ba6edc39a09b9abdefe2a26f2764c3de5986121aa64cbda65c40c01b46a4202c225f6b8fc4195
+MISC ChangeLog-2015 2397 SHA256 e0a208db459f63d93e53af6ea420e293fcc48d462b73c0c09809cd39eb34746d SHA512 c346fa2b9b8b687de59528ddb0b3016061afa92fbee155c107f2137a1e0abd3b161772be8f8ee4747a30017cf183aaeb5093c2e4db3c89b16c2f944d602684bf WHIRLPOOL fcaa66b7002b90849879c41ee08a74e855f52685f98fc34e30088174dc4f0eb1ff8b2b2944d903bb938c02de1684dfac4ad4c518e814a8e4e4fdfa3994e4b2d2
+MISC metadata.xml 989 SHA256 332b5b794c551d243888c445c0fcd03cc86a46cb601e865ffea497f082f77ef2 SHA512 39f935d8c1a17b313a288065757f35134e7f8440737397f50abf30ceb6071372ef253ebfd92d3f9996c99cce6374f3458ef4c98f9010aba10f3e791762013de3 WHIRLPOOL 16b6362c54c917ec38cedb0c264b16afaee88fd0453ca2548dadf4ad6165a2b9176eb2d8e985fd3f9d2c486f9fd14c39b76d0b81297031804cdceb13e6ae8ee1
diff --git a/dev-perl/Data-FormValidator/files/4.86-dot-in-inc.patch b/dev-perl/Data-FormValidator/files/4.86-dot-in-inc.patch
new file mode 100644
index 000000000000..a6fdb276e42d
--- /dev/null
+++ b/dev-perl/Data-FormValidator/files/4.86-dot-in-inc.patch
@@ -0,0 +1,58 @@
+From bfc088aa911062d987c830d5bb56aa4afd0d3735 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 4 Jun 2017 00:40:04 +1200
+Subject: [PATCH] Absolutize filenames during construction
+
+This way, any relative paths become absolute as soon as possible,
+so that if chdir happens between "new" and "load_profiles", the loaded
+file won't magically change.
+
+This also aims to turn the <do "file.pm"> into a <do "/path/to/File.pm">
+as the former no longer reads from "." since Perl 5.25.11, as paths
+with neither leading "./" or leading "/" imply @INC traversal.
+
+This aims to resolve RT#120671
+
+https://rt.cpan.org/Ticket/Display.html?id=120671
+https://bugs.gentoo.org/613378
+---
+ Makefile.PL | 1 +
+ lib/Data/FormValidator.pm | 3 ++-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index a9839a6..cef175a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -19,6 +19,7 @@ WriteMakefile(
+ 'Regexp::Common' => 0.03, # when ::whitespace was added
+ 'Scalar::Util' => 0,
+ 'Email::Valid' => 0,
++ 'File::Spec' => 0,
+ },
+ (eval { ExtUtils::MakeMaker->VERSION(6.46) } ? (META_MERGE => {
+ 'meta-spec' => { version => 2 },
+diff --git a/lib/Data/FormValidator.pm b/lib/Data/FormValidator.pm
+index 7075dc4..bc0709e 100644
+--- a/lib/Data/FormValidator.pm
++++ b/lib/Data/FormValidator.pm
+@@ -24,6 +24,7 @@
+
+ package Data::FormValidator;
+ use Exporter 'import';
++use File::Spec qw();
+ use 5.008;
+
+ use Data::FormValidator::Results;
+@@ -147,7 +148,7 @@ sub new {
+ $profiles = $profiles_or_file;
+ }
+ else {
+- $file = $profiles_or_file;
++ $file = File::Spec->rel2abs( $profiles_or_file );
+ }
+
+
+--
+2.12.2
+
diff --git a/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
new file mode 100644
index 000000000000..17cf910684f2
--- /dev/null
+++ b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
@@ -0,0 +1,34 @@
+From f0afbb4d0d21cee2ef0497ca8205e375bf7eb19d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 10 Oct 2017 03:23:55 +1300
+Subject: Prevent installing README.pod to final install
+
+This fixes the final "make install" so that matching regexed files do
+not get copied from blib/ to the OS
+
+Previously, a cruft file could be found in @INC by performing:
+
+ perldoc Data::README
+
+Which would give you the README.pod of Data::FormValidator
+
+This is a left-over artifact from the old days where this mechanism
+was The Way to install .pod/.pm files, and is still heavily used this
+way for .xs files.
+
+Bug: https://github.com/dnmfarrell/Data-FormValidator/pull/7
+---
+ INSTALL.SKIP | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 INSTALL.SKIP
+
+diff --git a/INSTALL.SKIP b/INSTALL.SKIP
+new file mode 100644
+index 0000000..85828ef
+--- /dev/null
++++ b/INSTALL.SKIP
+@@ -0,0 +1 @@
++\bREADME\.pod$
+--
+2.14.1
+
diff --git a/dev-perl/Data-FormValidator/metadata.xml b/dev-perl/Data-FormValidator/metadata.xml
new file mode 100644
index 000000000000..c5e3db9535e7
--- /dev/null
+++ b/dev-perl/Data-FormValidator/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Data-FormValidator</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::Dates</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::RegexpCommon</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Constraints::Upload</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::ConstraintsFactory</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Filters</remote-id>
+ <remote-id type="cpan-module">Data::FormValidator::Results</remote-id>
+ </upstream>
+</pkgmetadata>