summaryrefslogtreecommitdiff
path: root/dev-perl/DBIx-Simple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/DBIx-Simple
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/DBIx-Simple')
-rw-r--r--dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild34
-rw-r--r--dev-perl/DBIx-Simple/Manifest3
-rw-r--r--dev-perl/DBIx-Simple/metadata.xml13
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild b/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild
new file mode 100644
index 000000000000..663a55b5191a
--- /dev/null
+++ b/dev-perl/DBIx-Simple/DBIx-Simple-1.350.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=JUERD
+DIST_VERSION=1.35
+inherit perl-module
+
+DESCRIPTION="Very complete easy-to-use OO interface to DBI"
+
+# Upstream says "Any OSI approved license from https://opensource.org/licenses/alphabetical"
+LICENSE="|| ( AFL-3.0 AGPL-3 APL-1.0 Apache-2.0 BSD-2 Boost-1.0 CDDL CPAL-1.0
+ EPL-1.0 ECL-2.0 EUPL-1.1 GPL-2 GPL-3 LGPL-2.1 LGPL-3 HPND IBM IPAfont ISC
+ LPPL-1.3c 9base MIT MPL-2.0 NOSA nethack PHP-3 POSTGRESQL PYTHON CNRI
+ QPL-1.0 OFL-1.1 Sleepycat Watcom-1.0 W3C wxWinLL-3 ZLIB libpng
+)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ >=dev-perl/DBI-1.210.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( !minimal? (
+ >=dev-perl/DBD-SQLite-1.0.0
+ ) )
+"
+src_test() {
+ perl_rm_files "t/pod.t"
+ perl-module_src_test
+}
diff --git a/dev-perl/DBIx-Simple/Manifest b/dev-perl/DBIx-Simple/Manifest
new file mode 100644
index 000000000000..61615effe842
--- /dev/null
+++ b/dev-perl/DBIx-Simple/Manifest
@@ -0,0 +1,3 @@
+DIST DBIx-Simple-1.35.tar.gz 19316 BLAKE2B 02318f8f07efa5ce7fc17b537ef54e5cf23e7ed6866cef9fe2c818aed253a48e4199af0bc9db88c8a3d1480160ed204ea3f016c4d6f249a958bfa052720354e3 SHA512 5b7e9c2f489ac32ac5833ff220dbcb7223ebfc02e3d715477c8b243c92b3563a6f2e661247793fd25764c9dd41914426b7d705bb2bcb09656d3cad552d05d301
+EBUILD DBIx-Simple-1.350.0-r1.ebuild 879 BLAKE2B 3250992521a9d2b2ee385b34cdc1a2df264ed827f977149ab749323ed95c1bb98d7e78bc88467dbd24c9c871dc1eb4d77015e2bb0846249e23fae2b764916cb4 SHA512 67867d7db67fba89e40b4e14d4e1a37a8b5c86ddc943ecea9d9567ec2736b70b48fa2a61a4090ca639499bae57136663ec89e65d2ea4c4a821653d6e9eebf531
+MISC metadata.xml 472 BLAKE2B b424b344790b46e092f29cd8d4f2346954f5d834a1d80007d007b1625bf9c69a01c486d4ba5686565a4f428dc118ac5b0d53495c2fb629c68b650a60b991432f SHA512 549ea56c1aa6ebeff531323a59205700c00b3771682a2d69ca369310ab654a0010acfd4fc852393b6ae73b964d8882b7524b93d850ba71c37ebaaae7499738e6
diff --git a/dev-perl/DBIx-Simple/metadata.xml b/dev-perl/DBIx-Simple/metadata.xml
new file mode 100644
index 000000000000..d7965fc6cc14
--- /dev/null
+++ b/dev-perl/DBIx-Simple/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">DBIx-Simple</remote-id>
+ <remote-id type="cpan-module">DBIx::Simple</remote-id>
+ <remote-id type="cpan-module">DBIx::Simple::Result::RowObject</remote-id>
+ </upstream>
+</pkgmetadata>