summaryrefslogtreecommitdiff
path: root/dev-perl/DBIx-SearchBuilder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/DBIx-SearchBuilder
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/DBIx-SearchBuilder')
-rw-r--r--dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild44
-rw-r--r--dev-perl/DBIx-SearchBuilder/Manifest3
-rw-r--r--dev-perl/DBIx-SearchBuilder/files/DBIx-SearchBuilder-1.68-no-dot-inc.patch331
3 files changed, 378 insertions, 0 deletions
diff --git a/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild b/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild
new file mode 100644
index 000000000000..5a0f14dc3717
--- /dev/null
+++ b/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BPS
+DIST_VERSION=1.68
+DIST_EXAMPLES=("ex/*")
+inherit perl-module
+
+DESCRIPTION="Encapsulate SQL queries and rows in simple Perl objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Cache-Simple-TimedExpiry-0.210.0
+ dev-perl/Class-Accessor
+ >=dev-perl/Class-ReturnValue-0.400.0
+ dev-perl/Clone
+ dev-perl/DBI
+ dev-perl/DBIx-DBSchema
+ >=virtual/perl-Encode-1.990.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Want
+ >=dev-perl/capitalization-0.30.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ dev-perl/DBD-SQLite
+ virtual/perl-File-Temp
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.68-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ t/pod.t
+)
diff --git a/dev-perl/DBIx-SearchBuilder/Manifest b/dev-perl/DBIx-SearchBuilder/Manifest
index b2d83b554652..59f78ecf33cd 100644
--- a/dev-perl/DBIx-SearchBuilder/Manifest
+++ b/dev-perl/DBIx-SearchBuilder/Manifest
@@ -1,4 +1,7 @@
AUX DBIx-SearchBuilder-1.66-no-dot-inc.patch 8976 BLAKE2B 6e0a20539b99f2b80040b539b194d6ef6c1c69c4f9eba3bfaba658a8bc07050b869d60d1ca28e78e81a55032361d1595f0f34cd61541977c6e26eac2108a41f5 SHA512 ad733760ccc8b6dadd7238e0b8cd5e3cd34b6921e2483f0a3a6d8596623b4b8132c5d70cf4166e671f57f1950417d8e5c5564f9828c4625796a7e4b3f633d2f8
+AUX DBIx-SearchBuilder-1.68-no-dot-inc.patch 8749 BLAKE2B 34f6e8108a4ec536cde3bc47bedef19126a96bfc50727273b1ad1b0978eb023a266fee29b7de1329a8a9a22ae924a0ef6c36cbb87a5791f657384b04f07b6ffd SHA512 110c6dab6121357f862e56bddf78a33e4b9b510034d79af6fc97d80995373b53c6c809fa26396dfc506a0e192c8532c1da8d8433ffd7ffbe20e45ee87b7ab7e7
DIST DBIx-SearchBuilder-1.67.tar.gz 115193 BLAKE2B 9ad670069826d0cc109e61834d425f5c2fc29d7709f36f73a23820636b8bed3ac45b563df115b8a5448014672a5b68db2183ca7180eee590aff6ed388715dca0 SHA512 8cade12f01da749356a3c1b167f46e0377934e01832548baebfa629e71c3199ce473a63077ee5ac5ed58f805f7cb883bd8d0886d2ecf27f4740eafbb30f91bae
+DIST DBIx-SearchBuilder-1.68.tar.gz 115423 BLAKE2B c7d3b2efb3398d74fa755e3e3a177e413164f7675af912664e1a42a32547f3ab0cd8b5f638397ec0383e463c8c57702e69afd46e94231c3a15930e5c1749fa63 SHA512 5495dcc5ff23c01e4fd917802243a30d94d6a2fdce6f6e761f0eb2df765c9bfa0ba6065bd10b961c61b22483ca2ef08e958fe6aa1dbf20a85cd9aa9d97cf19ee
EBUILD DBIx-SearchBuilder-1.670.0.ebuild 922 BLAKE2B 7628f3419901b0ede983e26097e991d9bbe4f88617627759caa93f136f41fee59b6d7afdd63540d7c2595c7b5c7f277922ee90d9aeede010b7ddbade9b21ed5e SHA512 6e77f852f3d187e35213c81969151d654035fb15f1520eb3eaaf83b457d98d709180f8ba1e4daed3218bbfb5ddd51d938fefed7f05da85fe64182d9547de8317
+EBUILD DBIx-SearchBuilder-1.680.0.ebuild 875 BLAKE2B b60dea0de1d6707147c567f9cdb9c548e6d26e5b96c2996907ddc53d23c3342c63e3f72e8cc2f43bba5476fa171a08b1befb0a97a26c5155198e02eda1fd9784 SHA512 0b27ef4ed705804bc51ce3434cd9528b4ea1d77197903401c459730327a7e74dd786686003078e9d4744467da34eaef5035fa9a3244442e2d5d8865f989c2237
MISC metadata.xml 1594 BLAKE2B c56268fbc1ee494196c0763e6c0f795436d3f2104b43034969c94aacebc4c408b818283203e5b097f7cd6400657c6d5d2630dcaad5a034a0d3743506d676b766 SHA512 da30146de1b578e3362a06b951bcf72a1d4917f33aad4cc678360c62a470edda63ff4d40f6f582c22af47257a6e0e1764579ccc518352ce46465f2465f3fa8a2
diff --git a/dev-perl/DBIx-SearchBuilder/files/DBIx-SearchBuilder-1.68-no-dot-inc.patch b/dev-perl/DBIx-SearchBuilder/files/DBIx-SearchBuilder-1.68-no-dot-inc.patch
new file mode 100644
index 000000000000..512679f1e535
--- /dev/null
+++ b/dev-perl/DBIx-SearchBuilder/files/DBIx-SearchBuilder-1.68-no-dot-inc.patch
@@ -0,0 +1,331 @@
+From 7557bad8ff9ce5d17b15b5bdf81a03f1fde7a248 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 25 Jun 2017 19:16:42 +1200
+Subject: Fix for '.' removal from @INC in Perl 5.26
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121140
+Bug: https://bugs.gentoo.org/615602
+Bug: https://github.com/bestpractical/dbix-searchbuilder/pull/5
+---
+ t/01basics.t | 2 +-
+ t/01nocap_api.t | 2 +-
+ t/01records.t | 2 +-
+ t/01searches.t | 2 +-
+ t/02distinct_values.t | 2 +-
+ t/02null_order.t | 2 +-
+ t/02order_outer.t | 2 +-
+ t/02records_cachable.t | 2 +-
+ t/02records_datetime.t | 2 +-
+ t/02records_dt_interval.t | 2 +-
+ t/02records_integers.t | 2 +-
+ t/02records_object.t | 2 +-
+ t/02searches_function.t | 2 +-
+ t/02searches_joins.t | 2 +-
+ t/03compatibility.t | 2 +-
+ t/03cud_from_select.t | 2 +-
+ t/03rebless.t | 2 +-
+ t/03transactions.t | 2 +-
+ t/03versions.t | 2 +-
+ t/10schema.t | 4 ++--
+ t/11schema_records.t | 2 +-
+ t/20set_edge_cases.t | 2 +-
+ 22 files changed, 23 insertions(+), 23 deletions(-)
+
+diff --git a/t/01basics.t b/t/01basics.t
+index a46ede6..f0c18df 100644
+--- a/t/01basics.t
++++ b/t/01basics.t
+@@ -3,7 +3,7 @@
+ use strict;
+
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 4;
+diff --git a/t/01nocap_api.t b/t/01nocap_api.t
+index 1ea417e..be45395 100644
+--- a/t/01nocap_api.t
++++ b/t/01nocap_api.t
+@@ -3,7 +3,7 @@
+ use strict;
+
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+
+ use vars qw(@SPEC_METHODS @MODULES);
+ my @SPEC_METHODS = qw(AUTOLOAD DESTROY CLONE);
+diff --git a/t/01records.t b/t/01records.t
+index a1f1366..d701e94 100644
+--- a/t/01records.t
++++ b/t/01records.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 66;
+diff --git a/t/01searches.t b/t/01searches.t
+index 83a2001..1276544 100644
+--- a/t/01searches.t
++++ b/t/01searches.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 150;
+diff --git a/t/02distinct_values.t b/t/02distinct_values.t
+index f20328d..826db21 100644
+--- a/t/02distinct_values.t
++++ b/t/02distinct_values.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 9;
+diff --git a/t/02null_order.t b/t/02null_order.t
+index 9feda47..fab111d 100644
+--- a/t/02null_order.t
++++ b/t/02null_order.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 11;
+diff --git a/t/02order_outer.t b/t/02order_outer.t
+index 08a236b..14a39fe 100644
+--- a/t/02order_outer.t
++++ b/t/02order_outer.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 98;
+diff --git a/t/02records_cachable.t b/t/02records_cachable.t
+index cdbb9da..9418990 100644
+--- a/t/02records_cachable.t
++++ b/t/02records_cachable.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 16;
+diff --git a/t/02records_datetime.t b/t/02records_datetime.t
+index f1a0d7a..6882729 100644
+--- a/t/02records_datetime.t
++++ b/t/02records_datetime.t
+@@ -5,7 +5,7 @@ BEGIN { $ENV{'TZ'} = 'Europe/Moscow' };
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 38;
+diff --git a/t/02records_dt_interval.t b/t/02records_dt_interval.t
+index ef1ead3..283746f 100644
+--- a/t/02records_dt_interval.t
++++ b/t/02records_dt_interval.t
+@@ -5,7 +5,7 @@ BEGIN { $ENV{'TZ'} = 'Europe/Moscow' };
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 17;
+diff --git a/t/02records_integers.t b/t/02records_integers.t
+index d13e2ee..95b8504 100644
+--- a/t/02records_integers.t
++++ b/t/02records_integers.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 37;
+diff --git a/t/02records_object.t b/t/02records_object.t
+index 18c724e..34576db 100644
+--- a/t/02records_object.t
++++ b/t/02records_object.t
+@@ -5,7 +5,7 @@ use strict;
+ use warnings;
+ use Test::More;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 11;
+diff --git a/t/02searches_function.t b/t/02searches_function.t
+index 2fd6e7e..c8682de 100644
+--- a/t/02searches_function.t
++++ b/t/02searches_function.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use Test::More;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 18;
+diff --git a/t/02searches_joins.t b/t/02searches_joins.t
+index 1661f2b..cbdc3c9 100644
+--- a/t/02searches_joins.t
++++ b/t/02searches_joins.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use Test::More;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 59;
+diff --git a/t/03compatibility.t b/t/03compatibility.t
+index 14eb382..3939503 100644
+--- a/t/03compatibility.t
++++ b/t/03compatibility.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 2;
+diff --git a/t/03cud_from_select.t b/t/03cud_from_select.t
+index 7f5d21b..2f324b7 100644
+--- a/t/03cud_from_select.t
++++ b/t/03cud_from_select.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use Test::More;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 14;
+diff --git a/t/03rebless.t b/t/03rebless.t
+index 888bb94..467cf00 100644
+--- a/t/03rebless.t
++++ b/t/03rebless.t
+@@ -6,7 +6,7 @@ use warnings;
+ use Test::More;
+ use DBIx::SearchBuilder::Handle;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 4;
+diff --git a/t/03transactions.t b/t/03transactions.t
+index e641c19..ef0f973 100644
+--- a/t/03transactions.t
++++ b/t/03transactions.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 52;
+diff --git a/t/03versions.t b/t/03versions.t
+index 79bb2e9..4acba37 100644
+--- a/t/03versions.t
++++ b/t/03versions.t
+@@ -5,7 +5,7 @@ use warnings;
+ use Test::More;
+ use DBIx::SearchBuilder::Handle;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 6;
+diff --git a/t/10schema.t b/t/10schema.t
+index 2ff5ab6..fcf1a7b 100644
+--- a/t/10schema.t
++++ b/t/10schema.t
+@@ -8,7 +8,7 @@ use constant TESTS_PER_DRIVER => 14;
+ our @AvailableDrivers;
+
+ BEGIN {
+- require("t/utils.pl");
++ require("./t/utils.pl");
+ my $total = 3 + scalar(@AvailableDrivers) * TESTS_PER_DRIVER;
+ if( not eval { require DBIx::DBSchema } ) {
+ plan skip_all => "DBIx::DBSchema not installed";
+@@ -22,7 +22,7 @@ BEGIN {
+ use_ok("DBIx::SearchBuilder::Handle");
+ }
+
+-require_ok("t/testmodels.pl");
++require_ok("./t/testmodels.pl");
+
+ foreach my $d ( @AvailableDrivers ) {
+ SKIP: {
+diff --git a/t/11schema_records.t b/t/11schema_records.t
+index 4fc4dc4..a586cda 100644
+--- a/t/11schema_records.t
++++ b/t/11schema_records.t
+@@ -5,7 +5,7 @@ use strict;
+ use warnings;
+ use Test::More;
+
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 63;
+diff --git a/t/20set_edge_cases.t b/t/20set_edge_cases.t
+index 943f76a..d22b1ee 100644
+--- a/t/20set_edge_cases.t
++++ b/t/20set_edge_cases.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+ use Test::More;
+-BEGIN { require "t/utils.pl" }
++BEGIN { require "./t/utils.pl" }
+ our (@AvailableDrivers);
+
+ use constant TESTS_PER_DRIVER => 20;
+--
+2.27.0
+