summaryrefslogtreecommitdiff
path: root/dev-perl/DBD-mysql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /dev-perl/DBD-mysql
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'dev-perl/DBD-mysql')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.44.0.ebuild64
-rw-r--r--dev-perl/DBD-mysql/Manifest4
-rw-r--r--dev-perl/DBD-mysql/files/DBD-mysql-4.044-amvis-type-conversions.patch56
-rw-r--r--dev-perl/DBD-mysql/files/DBD-mysql-4.044-no-dot-inc.patch151
4 files changed, 275 insertions, 0 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.44.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.44.0.ebuild
new file mode 100644
index 000000000000..48c3cc910c8b
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.44.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CAPTTOFU
+DIST_VERSION=4.044
+inherit eutils perl-module
+
+DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test +ssl"
+
+RDEPEND=">=dev-perl/DBI-1.609.0
+ virtual/libmysqlclient:=
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Data-Dumper
+ test? (
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.900.0
+ virtual/perl-Time-HiRes
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-amvis-type-conversions.patch"
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+ "${FILESDIR}/4.041-mariadb-10.2.patch"
+)
+src_configure() {
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ myconf="${myconf} --$(usex ssl ssl nossl)"
+ perl-module_src_configure
+}
+
+# Parallel testing is broken as 2 tests create the same table
+# and mysql isn't acid compliant and can't limit visibility of tables
+# to a transaction...
+DIST_TEST="do"
+
+src_test() {
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl_rm_files t/pod.t t/manifest.t
+ # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
+ # out why 60leaks.t fails
+ perl-module_src_test
+}
diff --git a/dev-perl/DBD-mysql/Manifest b/dev-perl/DBD-mysql/Manifest
index f5838b27f7e2..61ed8d23548f 100644
--- a/dev-perl/DBD-mysql/Manifest
+++ b/dev-perl/DBD-mysql/Manifest
@@ -2,14 +2,18 @@ AUX 4.041-amvis-type-conversions.patch 1503 BLAKE2B fe4dd5223797fef269693930aaa8
AUX 4.041-mariadb-10.2.patch 1276 BLAKE2B 9e29ec5d423e77afe825adbf5146763edf168ed1050a8022d28c220d3fdeaa6cf631e15191be2da7dabccf41b9bc7ae1a13f4728a0f6790b7d230d0eb37c997c SHA512 1e2b4b98d285c7a0b0cfada98e7e65896b322dcf26985cb1f3bc0ceb1e72e71650b23a8b0600e887df33ed316545f8adc22c4cfd9318485f04195d3825d8ceee
AUX 4.041-no-dot-inc.patch 3470 BLAKE2B 2c8bfe5461699a1d167f9c1ecd77631293685f02eb3b875f2b7d97dff3863b5535ba6a537cdd92725418606b1b718fddec8c2979f51f423a6dc0869910b000f1 SHA512 b7a075b9e63bf80bf78a91fc732fccf2059638961d941b7be0dd73b3669a0a0df7bed3a8e5c12d8d88a9da7c28fb872669de5f3d6b6ac60da5510599a173cb26
AUX 4.042-no-dot-inc.patch 5717 BLAKE2B fd0835e7e6446e135035489d02ae520bfb21e8590daab905bd8433c584ad35135d77fb55a8a37aa720abfb830158f0980e49bf5a4d54b96c28d279a15b99927b SHA512 8b8707cffc9ff711ea0effe9c2eb0ef56fd4b97729e76f3bffe52e780764a4f0d812e1ec00249752363475650dc803b2311c82cc645016d0449be296b8b1bf0b
+AUX DBD-mysql-4.044-amvis-type-conversions.patch 1739 BLAKE2B 25fcf1c74798a2c0aaaeae3788e69e9735533ffeb6ed3455eecc0e3500d961522081745e3e0d6a99bcbe28996555ca0caf935628688446d4ab2e896c5ee92f3f SHA512 3335e80f756b75299dd8f398a6e6f2aa3902ad581f6c46e8a1e5d032b10c586b5b3ad4a237ccd7dae48b2039a72eb3de537dcab193aba294114392ba32c42c29
+AUX DBD-mysql-4.044-no-dot-inc.patch 4927 BLAKE2B dd952d2dac0de6c9d428832083034041058c019d16f29df2e06f107181cc10a1924c1ff954e33d2269cc6d1d6e0b379b3887ad75bc1542afd6dc6714b9876dc0 SHA512 faf3f4fbe551b8dfe65e747dc78f6136c059934c145ffbd5b83781eec044f8d764f1b02cf5f11af542476853c887fa98b09c6b939740e934c57db235b0668a67
AUX DBD-mysql-print_embedded_options.patch 616 BLAKE2B bb8a5512e12e9a2bfe942df81689dfbc9551d94c9354830f49cf905b858a61c3a9f747c56dbb87677f86034b6747168881a09d71980d9633c345545b65cc0d37 SHA512 da7bbc1b65e58128af4c19673827c342de94e811b6ab20ff6844646eb7d6afdff79b61aaa6033ae2ac3d8dce8140f78505961e3da49306b5034a6c3eb5ba8157
DIST DBD-mysql-4.032.tar.gz 146476 BLAKE2B 3ace983522e273cdb18352d2fa87702222594daed6e8d1eda2b037e5b98c31fd2e81bfa57ec71d6f5d836de80cdaf06a3571ae7c84d1ff4822ed6ab4f5d9e8fe SHA512 7e7ebaed07f0540079854294cc3ab4a4554fd0f850dd0927b2485cc985c2c9f5b70a650d971027c883cc4d8450020245656f6ff1f792a56d1a2d4b45402d73d0
DIST DBD-mysql-4.037.tar.gz 146639 BLAKE2B fbecca7302cd6ea0386116a1824a7696f87f681dbfcd88970b1a5eab54639e46471fc07b37bd8c0158b3eca02d05dad159e11027daa5ab46eaa307b530f7c58e SHA512 3bda6ea18d29e32028b7eb93cd06fdbabbadafa66f982556298a68980c42a7b5236872113696e6d2df66a345049d1e63bc90ab358c8631f0cbea187780e514af
DIST DBD-mysql-4.041.tar.gz 150508 BLAKE2B 900ccc4ad9bc5bfb236c66774a6c9529beed3568c3f3626afcbb572fa530a2488ee8e05b1dabd169a775f28d634321dd3e86923e2829e019943a9f3054b1e887 SHA512 8663c58f1dec273869ef5d3ee663d80cb36fa87b1956318fff07a4a801aaecc395510a8f31b7a51b823f7e9d6a73ebf13894c1b7f7b27fdc3f3956e6aba34777
DIST DBD-mysql-4.042.tar.gz 160028 BLAKE2B ef2f9d6508a473c34275ae9d7233863698ab502d837975f08593d2d1ca9761081ffb84bafc5a02c572e2a6b4d54dd7c8312e476e0719733166f8edc030a016de SHA512 fe3c9e1e325f7056da783e0ea33f9a7810f25f3d9cd2c9a4bf4037b20a2148f2291b2f90d44730e63c7902b45e26993a7f9fcf1b3bf8d1bc5d3fca99893a019e
+DIST DBD-mysql-4.044.tar.gz 155006 BLAKE2B 2934224010bb09aaff9a334b25038a4c7d1eb5552f6ad2b73f44aa7e2d8cb3684644773a89f35363c156cf40867a28943320e1b8b7ef4b9d4b8ac0f6b2417b38 SHA512 e3dd9482e8f78c19dc91baba07e39e266f113ce5a014cfe6c5989c96ed0f85723a17ba6a6e00b65a1ed3c62362400bd3779eb63ed282f73587b4757da249af02
EBUILD DBD-mysql-4.32.0-r2.ebuild 1319 BLAKE2B fca837574ca5840669f9d076dddbe0b5293dfb9df05aeb381cd2768de761b1cba5cc3c4f74d248718fe3752453935071653069f9632be06b33f852471d0eb9ca SHA512 e654b62fefeb79914ba77691a9b28777c594fc69f8ff91f77d190f831a79a7b5bd7caaf62d6cc9d6cc3d48a9ae43b96815d3bf87aa62cf9a1a2b3ef6189db776
EBUILD DBD-mysql-4.37.0.ebuild 1973 BLAKE2B 072f8acba91a0512ed7b4f9ecd8c1dc71d14fac7d0b868aca54fcba46f38624456beb1336fe74846feff6d961aad3a4992511cb310211e7f113e95000063de2f SHA512 1b6e44cfff11f8f28e29721fd0c47b3b2b1c6a5bd638a9b219e94dd76ae23814bf86116006b1bebae49266e255cfe9b529b79e54076664a502013a6d057f1696
EBUILD DBD-mysql-4.41.0-r2.ebuild 2093 BLAKE2B 046ff0c8ddec85d2fab3b7ec4d7018c46609b54263846d81b513a770327315ca3bbcc34f2d09308610028cfd3cad85fcf9ea4d92b251cc4576add96bf475e742 SHA512 72f9938a6e98a0a1631eb75d97af59c0ddcb8b7e5436572ab3049967452aac9d6d0339fb7c07e2e7fea58038c2d14f7cd5635767baa43967b480e3e3189fbdbe
EBUILD DBD-mysql-4.41.0.ebuild 1966 BLAKE2B 3bd3a45c3dec31844ade8b79edb2089dc20a627b0c8797947c0e0e0ea7780a47a8a60582d57361a0f3bfa833dc65f4686f61cd33c04f591b1b562ecf8e091b60 SHA512 88e2669b1feb2b6bdeec630a9fa2fc4dfd62b907d0af3ac0b97a90608a4113593f704ce92d14fd542c8b9760d3a4a345dfdec251359d30075da1a500526182e0
EBUILD DBD-mysql-4.42.0.ebuild 1977 BLAKE2B f7e71ad84f2f9889e4b933b1bd9b1f41a01956ac112aff4184610193b3f413d5905e16ac32aed958739457c9b2dbd1ceec46fb1fa3cb56571d317ffbf75ffceb SHA512 ee15ba80bc64c0073a81f9883ceb0366e21aed63d3543eb75427166f01ffe0125087d4ea0aa196eed1c5c8596581664038bc9f41c2486c2ea5b8c4f68cf9c201
+EBUILD DBD-mysql-4.44.0.ebuild 1830 BLAKE2B 8180d79a531407bd75ec583c81026edab6d329b047d2532387a9e6c38576d0f47caa70632ac3cfebefe3a19b4bf8e18685d256ef1f20c6b354e604d1aaba96ea SHA512 5b3685a070df80abff48d96b935305b640b60d4f21f5a81118b5c286470b4ecca712131c6eefd07d74cf2630e29597c8ba0647d7b7254dedce0296b319f6c92f
MISC metadata.xml 876 BLAKE2B 72a484b9d7cef869858a3ac26315ca83317344de66a903072a93af8b80bdcd310d3a59084140181faaca40c1bf640e7b1f6baf9939254624acc166906f4da476 SHA512 05226b4f30741e8d77f5174491aee480a958e3cdf9b9484ff261b975805b82eee9ff865df97891c6107307c5cc19994764110f5461c3e80c9d8828b34e076968
diff --git a/dev-perl/DBD-mysql/files/DBD-mysql-4.044-amvis-type-conversions.patch b/dev-perl/DBD-mysql/files/DBD-mysql-4.044-amvis-type-conversions.patch
new file mode 100644
index 000000000000..9cf9ff91fc8a
--- /dev/null
+++ b/dev-perl/DBD-mysql/files/DBD-mysql-4.044-amvis-type-conversions.patch
@@ -0,0 +1,56 @@
+From eb7eddaa2341b853df045ad4a3690c60fc38c6c8 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Fri, 24 Feb 2017 19:51:36 +0100
+Subject: Fix type conversions
+
+Calling SvNV() for magical scalar is not enough for float type conversion.
+It caused problem for Amavis in tainted mode -- all float values were zero.
+On the other hand SvIV() and SvUV() seems to work fine. To be sure that
+correct value of float is in scalar use sv_setnv() with explicit NV float
+value. Similar code is changed also for integers IV/UV.
+
+This patch should fix reported Amavis bug:
+https://github.com/perl5-dbi/DBD-mysql/issues/78
+
+See also reported perl bug about SvNV():
+https://rt.perl.org/Public/Bug/Display.html?id=130801
+
+Bugs: https://github.com/perl5-dbi/DBD-mysql/issues/78
+Bugs-Debian: https://bugs.debian.org/856064
+---
+ dbdimp.c | 9 +++------
+ 1 file changed, 3 insertions(+), 6 deletions(-)
+
+diff --git a/dbdimp.c b/dbdimp.c
+index 9c33994..7fdfba1 100644
+--- a/dbdimp.c
++++ b/dbdimp.c
+@@ -4380,8 +4380,7 @@ process:
+ if (!(fields[i].flags & ZEROFILL_FLAG))
+ {
+ /* Coerce to dobule and set scalar as NV */
+- (void) SvNV(sv);
+- SvNOK_only(sv);
++ sv_setnv(sv, SvNV(sv));
+ }
+ break;
+
+@@ -4392,13 +4391,11 @@ process:
+ /* Coerce to integer and set scalar as UV resp. IV */
+ if (fields[i].flags & UNSIGNED_FLAG)
+ {
+- (void) SvUV(sv);
+- SvIOK_only_UV(sv);
++ sv_setuv(sv, SvUV(sv));
+ }
+ else
+ {
+- (void) SvIV(sv);
+- SvIOK_only(sv);
++ sv_setiv(sv, SvIV(sv));
+ }
+ }
+ break;
+--
+2.15.1
+
diff --git a/dev-perl/DBD-mysql/files/DBD-mysql-4.044-no-dot-inc.patch b/dev-perl/DBD-mysql/files/DBD-mysql-4.044-no-dot-inc.patch
new file mode 100644
index 000000000000..5e0829384be4
--- /dev/null
+++ b/dev-perl/DBD-mysql/files/DBD-mysql-4.044-no-dot-inc.patch
@@ -0,0 +1,151 @@
+From 35931a7465f19da53b97cd1bc5369a69aeac2ff6 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Mon, 17 Apr 2017 21:38:58 +0200
+Subject: Fix tests on Perl On 5.25.10 or greater with
+ -Ddefault_inc_excludes_dot
+
+Some tests do not include dot in %INC and fails with error:
+Can't locate t/lib.pl in @INC
+
+Fixes: https://rt.cpan.org/Public/Bug/Display.html?id=120709
+---
+ t/40server_prepare_crash.t | 3 ++-
+ t/lib.pl | 5 +++--
+ t/rt118977-zerofill.t | 2 +-
+ t/rt25389-bin-case.t | 3 ++-
+ t/rt50304-column_info_parentheses.t | 3 ++-
+ t/rt61849-bind-param-buffer-overflow.t | 3 ++-
+ t/rt75353-innodb-lock-timeout.t | 3 ++-
+ t/rt83494-quotes-comments.t | 3 ++-
+ 8 files changed, 16 insertions(+), 9 deletions(-)
+
+diff --git a/t/40server_prepare_crash.t b/t/40server_prepare_crash.t
+index df6e2b3..e2c8c9f 100644
+--- a/t/40server_prepare_crash.t
++++ b/t/40server_prepare_crash.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh = eval { DBI->connect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1, AutoCommit => 0, mysql_server_prepare => 1, mysql_server_prepare_disable_fallback => 1 }) };
+ plan skip_all => "no database connection" if $@ or not $dbh;
+diff --git a/t/lib.pl b/t/lib.pl
+index 2221c40..0c756a0 100644
+--- a/t/lib.pl
++++ b/t/lib.pl
+@@ -2,6 +2,7 @@ use strict;
+ use warnings;
+
+ use Test::More;
++use File::Spec ();
+ use DBI::Const::GetInfoType;
+ use vars qw($mdriver $dbdriver $childPid $test_dsn $test_user $test_password);
+
+@@ -31,7 +32,7 @@ if (-f ($file = "t/$dbdriver.dbtest") ||
+ -f ($file = "$dbdriver.dbtest") ||
+ -f ($file = "../tests/$dbdriver.dbtest") ||
+ -f ($file = "tests/$dbdriver.dbtest")) {
+- eval { require $file; };
++ eval { require File::Spec->rel2abs($file); };
+ if ($@) {
+ print STDERR "Cannot execute $file: $@.\n";
+ print "1..0\n";
+@@ -45,7 +46,7 @@ if (-f ($file = "t/$mdriver.mtest") ||
+ -f ($file = "$mdriver.mtest") ||
+ -f ($file = "../tests/$mdriver.mtest") ||
+ -f ($file = "tests/$mdriver.mtest")) {
+- eval { require $file; };
++ eval { require File::Spec->rel2abs($file); };
+ if ($@) {
+ print STDERR "Cannot execute $file: $@.\n";
+ print "1..0\n";
+diff --git a/t/rt118977-zerofill.t b/t/rt118977-zerofill.t
+index 27ba1b7..86edb8e 100644
+--- a/t/rt118977-zerofill.t
++++ b/t/rt118977-zerofill.t
+@@ -5,7 +5,7 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++require "./t/lib.pl";
+
+ my $dbh = eval { DBI->connect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1 }) };
+ plan skip_all => "no database connection" if $@ or not $dbh;
+diff --git a/t/rt25389-bin-case.t b/t/rt25389-bin-case.t
+index 37bffb9..9d091b3 100644
+--- a/t/rt25389-bin-case.t
++++ b/t/rt25389-bin-case.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt50304-column_info_parentheses.t b/t/rt50304-column_info_parentheses.t
+index 5b6d799..8c31bf6 100644
+--- a/t/rt50304-column_info_parentheses.t
++++ b/t/rt50304-column_info_parentheses.t
+@@ -4,7 +4,8 @@ use warnings;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ use Test::More;
+
+diff --git a/t/rt61849-bind-param-buffer-overflow.t b/t/rt61849-bind-param-buffer-overflow.t
+index 99a4ccc..494f985 100644
+--- a/t/rt61849-bind-param-buffer-overflow.t
++++ b/t/rt61849-bind-param-buffer-overflow.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $INSECURE_VALUE_FROM_USER = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
+
+diff --git a/t/rt75353-innodb-lock-timeout.t b/t/rt75353-innodb-lock-timeout.t
+index 69b740e..41d1b8f 100644
+--- a/t/rt75353-innodb-lock-timeout.t
++++ b/t/rt75353-innodb-lock-timeout.t
+@@ -5,7 +5,8 @@ use Test::More;
+ use DBI;
+
+ use vars qw($test_dsn $test_user $test_password);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh1 = eval { DBI->connect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 }) };
+ plan skip_all => "no database connection" if $@ or not $dbh1;
+diff --git a/t/rt83494-quotes-comments.t b/t/rt83494-quotes-comments.t
+index 9df0d90..c42afe4 100644
+--- a/t/rt83494-quotes-comments.t
++++ b/t/rt83494-quotes-comments.t
+@@ -9,7 +9,8 @@ use DBI;
+ use Test::More;
+
+ use vars qw($test_dsn $test_user $test_password $state);
+-require "t/lib.pl";
++use lib 't', '.';
++require "lib.pl";
+
+ my $dbh;
+ eval {$dbh= DBI->connect($test_dsn, $test_user, $test_password,
+--
+2.15.1
+