summaryrefslogtreecommitdiff
path: root/dev-perl/DBD-SQLite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/DBD-SQLite
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/DBD-SQLite')
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild46
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.540.0.ebuild53
-rw-r--r--dev-perl/DBD-SQLite/Manifest8
-rw-r--r--dev-perl/DBD-SQLite/metadata.xml22
4 files changed, 129 insertions, 0 deletions
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild
new file mode 100644
index 000000000000..2b3d59d735bf
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.500.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=1.50
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test system-sqlite"
+
+# NB: Get min sqlite version from sqlite3.c
+RDEPEND="
+ system-sqlite? (
+ >=dev-db/sqlite-3.10.2[extensions(+)]
+ )
+ >=dev-perl/DBI-1.570.0
+ !<dev-perl/DBD-SQLite-1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ if use system-sqlite; then
+ einfo "Removing bundled SQLite"
+ # Flip Makefile into system mode.
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+ fi
+}
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.540.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.540.0.ebuild
new file mode 100644
index 000000000000..dbea8c5ad789
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.540.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=1.54
+inherit perl-module
+
+PATCH_TAG="${DIST_VERSION}-patches-1"
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+SRC_URI="${SRC_URI}
+ https://github.com/kentnl-gentoo/DBD-SQLite/releases/download/${PATCH_TAG}/${PN}-${PATCH_TAG}.tar.xz
+ mirror://gentoo/${PN}-${PATCH_TAG}.tar.xz
+ https://dev.gentoo.org/~kentnl/distfiles/${PN}-${PATCH_TAG}.tar.xz
+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test system-sqlite"
+
+# NB: Get min sqlite version from sqlite3.c
+RDEPEND="
+ system-sqlite? (
+ >=dev-db/sqlite-3.10.2[extensions(+)]
+ )
+ >=dev-perl/DBI-1.570.0
+ !<dev-perl/DBD-SQLite-1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+
+src_prepare() {
+ eapply "${WORKDIR}/patches/"
+ perl-module_src_prepare
+ if use system-sqlite; then
+ einfo "Removing bundled SQLite"
+ # Flip Makefile into system mode.
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+ fi
+}
diff --git a/dev-perl/DBD-SQLite/Manifest b/dev-perl/DBD-SQLite/Manifest
new file mode 100644
index 000000000000..3811a68db095
--- /dev/null
+++ b/dev-perl/DBD-SQLite/Manifest
@@ -0,0 +1,8 @@
+DIST DBD-SQLite-1.50.tar.gz 2023829 SHA256 3ac513ab73944fd7d4b672e1fe885dc522b6369d38f46a68e67e0045bf159ce1 SHA512 6ef903ef5a08511caf962d255d1245d83398ca0c807d86463eae86d7408b8ec271e9d7176c120cf6843a12d3670114c1856c85bb737acad9ef79e630dd253c82 WHIRLPOOL ea39ae0eb6bc2202da7e64399e6b8a101944e31c33c2a872225cc28819c68017163a65ce548eff8547b7ad4ecf82b2692eaaf90a724cc0cd69d48a2de5d28f72
+DIST DBD-SQLite-1.54-patches-1.tar.xz 8376 SHA256 b3f936be3eb0f17dd8502e21d62f1deabcc7cf78c8a2ca1b451aabff70199ce2 SHA512 8dec02fb076b8169b6f204b6b1e0828c913e5b5bf445dbb1dbf7ed0f372a339db08531558ba4ece7adda4b08c583b1a0657df4abfdb489fc1e1c10afd9033474 WHIRLPOOL 6b4dcb6f0ce3e6a04d14cc8459163ea9f282565c4c9cbdf726d2d696983fec803ac9a64db984e9edb7c73fac09389d3e3b5e6b047781f8a600cb7fa0e9a48a6b
+DIST DBD-SQLite-1.54.tar.gz 2136219 SHA256 3929a6dbd8d71630f0cb57f85dcef9588cd7ac4c9fa12db79df77b9d3a4d7269 SHA512 a8daff59679973467dff80c013b6ff9d7229a505b62c0312bdf7f9288af64dcd2e99f889b66eb98103b0e6ac7a9b0fa7c9c517c5c2673ee7f84b3b6b5d26173e WHIRLPOOL 9a5b7aa37a3e6996eb9eeeb783f3660cfcc5e3af153f0d1a0d81c3d1c088efcb176fdcabea2fb0e3b430be1a657484192516497fc9bab482e015df9c4be590b9
+EBUILD DBD-SQLite-1.500.0.ebuild 1194 SHA256 abf05ad3645b5c9d0cd164fcbdf3aba6a04954c96bab528e1cb76a8f39720bb4 SHA512 19a2bf93c244af7eabe768629d2578e937e4531cdbee3b809eb16cc2ae70b6235ec1946bdb29a85b4fb2cae63def640e1146845da0d63131af5aedb01a6a74ff WHIRLPOOL 07ea12d7a8a7630a28e893cccb398716e4161f979435c5ccf1eabc40641b55e5a7aee7158ccaff9aad505bb7d11b34bf65505c56a2c96ca232baa0fe36ff75ef
+EBUILD DBD-SQLite-1.540.0.ebuild 1509 SHA256 46d80c05ca60d42e4de8c47622d65d82caa389f6af9db03804e7116819e6299d SHA512 dd73d4279ae0155e23fccbbc8275b3ab4687c5b26c61edcb4102acf16ed22c8b40a3f755fa8d81643a938dee6a360933187197e953aef83696188d98a00c44fc WHIRLPOOL 9552eb4b945aaf28f3eb3c75f876fa331644c61125095e7eb583e6f996c08ce77a4aff86b660844b3396a1714b45806fd3f8ebc9356e57ed1b53de7089d294c8
+MISC ChangeLog 6758 SHA256 34ff5577665e75a30ab9a18392cfa672d937701ce7dff8fc4ec6dc8bde404446 SHA512 6590e6a08d52f7733aa9d0e4433f5ec281584559552a18e8781d35397794047f6d7267b4a2a6540c5084bf1a852db7ccc1b190ebb860b727704d7b56f5754973 WHIRLPOOL 07889a3658f74df9ae83cf1128d40e44cea9967b9eab19e549040ce62dbe3a075a6cfcdfec0a8d60639bdcb912142af0b90f170452764753a44c9da35167e50f
+MISC ChangeLog-2015 15211 SHA256 1d24a9d553684dd8a9da6101301e49f40ea9b91df3bcb31c6bef8171c6a0b534 SHA512 9b791bf759088e86a8308157d3cd1dc6eaa85fad65ac0b340894b6d0e4df9d49093d68313a685464a629374cb12dedafe8286809702878102bf710647fb26f23 WHIRLPOOL 9e8df056e16cc75728d39dc3dc89bb76f7595c6f7ca22e5dcad2de5c84a459032d5fc4f1042b1104acc8119a72d44a27bb29ec6a3c85a0e9352ec3fa98cc10f4
+MISC metadata.xml 1076 SHA256 239bf703b6e6ddac703cd4e092dcef54d3a0fdadb3395a439a0ae40e000a14e1 SHA512 6dc34ac81f2eef0a16be36407d29a91f341f19706a9660d751b5d4b289b44d6595f31260a4987b2cff22c4b02440cd07dfbcef48b1422da5ca96a5dcfdea510e WHIRLPOOL acd94b53bc9a9c9fc9f9a04d9a634d509e17cfbda625d2861801e8c6611aae922f91313011dc6a0ced89603b0a811f8317b8ad51b367c6af0b9f00cbf9251243
diff --git a/dev-perl/DBD-SQLite/metadata.xml b/dev-perl/DBD-SQLite/metadata.xml
new file mode 100644
index 000000000000..81d70780bfe5
--- /dev/null
+++ b/dev-perl/DBD-SQLite/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <use>
+ <flag name="system-sqlite">Use the system-wide <pkg>dev-db/sqlite</pkg> installation</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">DBD-SQLite</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::Constants</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable::Cursor</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable::FileContent</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable::FileContent::Cursor</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable::PerlData</remote-id>
+ <remote-id type="cpan-module">DBD::SQLite::VirtualTable::PerlData::Cursor</remote-id>
+ </upstream>
+</pkgmetadata>