summaryrefslogtreecommitdiff
path: root/dev-perl/DBD-Pg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/DBD-Pg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild44
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild44
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild97
-rw-r--r--dev-perl/DBD-Pg/Manifest7
-rw-r--r--dev-perl/DBD-Pg/metadata.xml13
5 files changed, 205 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
new file mode 100644
index 000000000000..7b0d6a3e87de
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# testcases require a local database with an
+# open password for the postgres user.
+DIST_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
new file mode 100644
index 000000000000..da68ebc2ce4d
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# testcases require a local database with an
+# open password for the postgres user.
+DIST_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild
new file mode 100644
index 000000000000..5c25b81e75c1
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.7.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
+
+src_test() {
+ local MODULES=(
+ # Compile failure: https://rt.cpan.org/Ticket/Display.html?id=123218
+ # "Bundle::DBD::Pg v${PV}"
+ "DBD::Pg v${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1 #||
+ #die "Could not load ${dep}"
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+
+ local LIVEDB_TESTS=(
+ "t/01connect.t"
+ "t/02attribs.t"
+ "t/03dbmethod.t"
+ "t/03smethod.t"
+ "t/04misc.t"
+ "t/06bytea.t"
+ "t/07copy.t"
+ "t/08async.t"
+ "t/09arrays.t"
+ "t/12placeholders.t"
+ "t/20savepoints.t"
+ "t/30unicode.t"
+ )
+ local SKIP_TESTS=(
+ "t/00_signature.t"
+ );
+ if [[ ! -v DBI_DSN ]]; then
+ ewarn "Functional database tests disabled due to lack of configuration."
+ ewarn "Please set the following environment variables values pertaining to a"
+ ewarn "pre-configured Postgres installation in order for tests to work:"
+ ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
+ ewarn " ( eg: dbi:Pg:dbname=testdb )"
+ ewarn " DBI_USER - A Postgres Database Username"
+ ewarn " DBI_PASS - A Postgres Database Password"
+ ewarn ""
+ ewarn "For details, visit:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
+ SKIP_TESTS+=( "${LIVEDB_TESTS[@]}" )
+ fi
+ perl_rm_files "${SKIP_TESTS[@]}"
+ # Parallel testing breaks database access
+ DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
+
+}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
new file mode 100644
index 000000000000..cbaf88f581bd
--- /dev/null
+++ b/dev-perl/DBD-Pg/Manifest
@@ -0,0 +1,7 @@
+DIST DBD-Pg-3.5.3.tar.gz 256570 BLAKE2B f589fc4ed978d2215d66b4cfd72b00e166f15dbe2caf004fa52c09fc6fc9f9b81ed84bc04ec0c4d3fe15f4eabb5a8a3b24b08acabb66b993c3ce67576a4c1721 SHA512 7a564e5c86fa41719289f6e391f0cd39f01df7d088892fca11175c60fec8a3af884f9204ae834caac2024ff0d45dcc013e314ec0c09a07fe7ee76170ec3a634f
+DIST DBD-Pg-3.6.2.tar.gz 258640 BLAKE2B 76e25905b0336eae4ead14c28cf8338412fec023ea0540fc80f5c8d02b1c46de1b42ee8be2230fb3276aa3c8fa2bda9a97ddbd41fc81617a557359907c02d600 SHA512 1f55bd463d90cd0d9933acde0a79462a57f11e7ed9519943cc2cb4487b4b69edd7d16ffa3d666c50aca797f9756ff4e6a0d67b58bc100f4920da36169d73b7b4
+DIST DBD-Pg-3.7.0.tar.gz 260083 BLAKE2B 73ae253e8033dab58075f6dc3c639e5d21f2df09880f59cb00fcdc201c17db1573e4902c4bfd535916775c0ef61a020a70e8f542ce28e257a903d4aabb9f6730 SHA512 edd4d3448dac1b563899c5fd4a1bad6cb810afdbbbf57b558bbe6710aa3e58530a6cf0932e35c3316c7f4f59763764d75ce1049f13c8c13deeb2e8a7c60ff73e
+EBUILD DBD-Pg-3.5.3.ebuild 1144 BLAKE2B 20d1d5fc5b14c8e596a34f09f7be7e15c16f080c4ceeff143aa7bcc1c685a49de251c7fa823983c190e8d4819af6be64c113c992e39e8eab5dfa2bd75b6f7569 SHA512 5f237cf091c9aa5eee967b6e80d004a4e1ff3e99f344bd124f28160892c72931f1615fa3a5470edd02078dd1608e6ce4efd339ea1cfb9accdf63cdaf9ce6dc3c
+EBUILD DBD-Pg-3.6.2.ebuild 1153 BLAKE2B d2618de3bb78d8192e1d0bdb1710f0f04f45028dca8ddbc05c92457d3a1f3f97c4f58ceb555cee2936a0c7d9150564846fae7434c81db8cbb2b719708b0ce188 SHA512 67933187e9e9f05347b13cb3a91d178c8c9af03cc2c2efeaadeb2ad522d9758a3c1ab4d65460b529d61eca976d177c9b52aeba16ad3513959fa27bf5a6026ed5
+EBUILD DBD-Pg-3.7.0.ebuild 2677 BLAKE2B 7854e36cfd92ae3250eddcf6b1a68b817cd0008f67ae052e2921471a211e34556eb04c48efbbfd0957edf4f5b07d28d67b62a75d9b5528618a613b4d6212fb32 SHA512 7b53c532067cce4913910ff45fb4665215c2e5ac5ca3cabd1346cb977327b419b159cced38ceff53cd04c780aebb900eb5696352ff8144b54b137dff3d7551a6
+MISC metadata.xml 446 BLAKE2B 428b5b91a84ab6026f482e2e3404f7b43a1557d16f42340453d927b4ea676caa3ab422705ea99439fd6369a43af9f2dcd0d7d3ec6a42f82b9e8df17cd2642a1a SHA512 23e05469a61761595bc52b6798d152dfc82b42a4ce1ed8010cd17b6343557ef92433cd31c00102098ed698ed0fd0260e3d165c926b9ce3de91f52112c9b40684
diff --git a/dev-perl/DBD-Pg/metadata.xml b/dev-perl/DBD-Pg/metadata.xml
new file mode 100644
index 000000000000..6340aa6b6b4d
--- /dev/null
+++ b/dev-perl/DBD-Pg/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">DBD-Pg</remote-id>
+ <remote-id type="cpan-module">Bundle::DBD::Pg</remote-id>
+ <remote-id type="cpan-module">DBD::Pg</remote-id>
+ </upstream>
+</pkgmetadata>