summaryrefslogtreecommitdiff
path: root/dev-perl/DBD-Pg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/DBD-Pg
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild114
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.14.0.ebuild110
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild110
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild44
-rw-r--r--dev-perl/DBD-Pg/Manifest8
5 files changed, 340 insertions, 46 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild
new file mode 100644
index 000000000000..252be08d1029
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="
+ dev-db/postgresql:*
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Time-HiRes
+ )
+"
+PERL_RM_FILES=(
+ "t/00_signature.t"
+)
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ local MODULES=(
+ "Bundle::DBD::Pg v${PV}"
+ "DBD::Pg v${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1 #||
+ #die "Could not load ${dep}"
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+
+ local LIVEDB_TESTS=(
+ "t/01connect.t"
+ "t/02attribs.t"
+ "t/03dbmethod.t"
+ "t/03smethod.t"
+ "t/04misc.t"
+ "t/06bytea.t"
+ "t/07copy.t"
+ "t/08async.t"
+ "t/09arrays.t"
+ "t/12placeholders.t"
+ "t/20savepoints.t"
+ "t/30unicode.t"
+ )
+ if [[ ! -v DBI_DSN ]]; then
+ ewarn "Functional database tests disabled due to lack of configuration."
+ ewarn "Please set the following environment variables values pertaining to a"
+ ewarn "pre-configured Postgres installation in order for tests to work:"
+ ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
+ ewarn " ( eg: dbi:Pg:dbname=testdb )"
+ ewarn " DBI_USER - A Postgres Database Username"
+ ewarn " DBI_PASS - A Postgres Database Password"
+ ewarn ""
+ ewarn "For details, visit:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
+ perl_rm_files "${LIVEDB_TESTS[@]}"
+ else
+ # Super user required
+ # https://rt.cpan.org/Ticket/Display.html?id=132965
+ perl_rm_files "t/03dbmethod.t" "t/04misc.t"
+ fi
+ # Parallel testing breaks database access
+ DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
+
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.14.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.14.0.ebuild
new file mode 100644
index 000000000000..b87f46e3ebd6
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.14.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="
+ dev-db/postgresql:*
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Time-HiRes
+ )
+"
+PERL_RM_FILES=(
+ "t/00_signature.t"
+)
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ local MODULES=(
+ "Bundle::DBD::Pg v${PV}"
+ "DBD::Pg v${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1 #||
+ #die "Could not load ${dep}"
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+
+ local LIVEDB_TESTS=(
+ "t/01connect.t"
+ "t/02attribs.t"
+ "t/03dbmethod.t"
+ "t/03smethod.t"
+ "t/04misc.t"
+ "t/06bytea.t"
+ "t/07copy.t"
+ "t/08async.t"
+ "t/09arrays.t"
+ "t/12placeholders.t"
+ "t/20savepoints.t"
+ "t/30unicode.t"
+ )
+ if [[ ! -v DBI_DSN ]]; then
+ ewarn "Functional database tests disabled due to lack of configuration."
+ ewarn "Please set the following environment variables values pertaining to a"
+ ewarn "pre-configured Postgres installation in order for tests to work:"
+ ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
+ ewarn " ( eg: dbi:Pg:dbname=testdb )"
+ ewarn " DBI_USER - A Postgres Database Username"
+ ewarn " DBI_PASS - A Postgres Database Password"
+ ewarn ""
+ ewarn "For details, visit:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
+ perl_rm_files "${LIVEDB_TESTS[@]}"
+ fi
+ # Parallel testing breaks database access
+ DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
+
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild
new file mode 100644
index 000000000000..b87f46e3ebd6
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.14.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="
+ dev-db/postgresql:*
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Time-HiRes
+ )
+"
+PERL_RM_FILES=(
+ "t/00_signature.t"
+)
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ local MODULES=(
+ "Bundle::DBD::Pg v${PV}"
+ "DBD::Pg v${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1 #||
+ #die "Could not load ${dep}"
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+
+ local LIVEDB_TESTS=(
+ "t/01connect.t"
+ "t/02attribs.t"
+ "t/03dbmethod.t"
+ "t/03smethod.t"
+ "t/04misc.t"
+ "t/06bytea.t"
+ "t/07copy.t"
+ "t/08async.t"
+ "t/09arrays.t"
+ "t/12placeholders.t"
+ "t/20savepoints.t"
+ "t/30unicode.t"
+ )
+ if [[ ! -v DBI_DSN ]]; then
+ ewarn "Functional database tests disabled due to lack of configuration."
+ ewarn "Please set the following environment variables values pertaining to a"
+ ewarn "pre-configured Postgres installation in order for tests to work:"
+ ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
+ ewarn " ( eg: dbi:Pg:dbname=testdb )"
+ ewarn " DBI_USER - A Postgres Database Username"
+ ewarn " DBI_PASS - A Postgres Database Password"
+ ewarn ""
+ ewarn "For details, visit:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
+ perl_rm_files "${LIVEDB_TESTS[@]}"
+ fi
+ # Parallel testing breaks database access
+ DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
+
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
deleted file mode 100644
index de57811eaeaf..000000000000
--- a/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=TURNSTEP
-inherit perl-module
-
-DESCRIPTION="PostgreSQL database driver for the DBI module"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND="
- virtual/perl-version
- >=dev-perl/DBI-1.614.0
- dev-db/postgresql:*
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-
-# testcases require a local database with an
-# open password for the postgres user.
-DIST_TEST="skip"
-
-src_prepare() {
- postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
- postgres_lib="${postgres_include//include/lib}"
- # Fall-through case is the non-split postgresql
- # The active cases instead get us the matching libdir for the includedir.
- for i in lib lib64 ; do
- if [ -d "${postgres_lib}/${i}" ]; then
- postgres_lib="${postgres_lib}/${i}"
- break
- fi
- done
-
- # env variables for compilation:
- export POSTGRES_INCLUDE="${postgres_include}"
- export POSTGRES_LIB="${postgres_lib}"
- perl-module_src_prepare
-}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index 75b7f0cac291..1a0eaea904d5 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1,9 +1,13 @@
DIST DBD-Pg-3.10.0.tar.gz 268414 BLAKE2B da6ac65519632aa95ee2554607d5e26820527042873ab78a9e40e671902b1b8e2fe39f37e44b15cf3db8eda243e57c7fab9077d4a08ec7f3c312825609fbc805 SHA512 46c985bbdeeed4ef60d6fe06034fa0959df288f2b9bbd434e2716676a3cb7a1ded168a3cf87a6a82eb397eb8edcc023c0b85483e948ce31abcac64a1919580ba
+DIST DBD-Pg-3.13.0.tar.gz 278332 BLAKE2B cf405cd2afd5095fb7bc824b9fc4ca3c9aa86c3bf0bfe0a651ea21ec48921e97d20b8a4fffc3847d1ebe4c737d29671564b48fafea2f71f7fa0128733f47d0a9 SHA512 70fcf250f143d974fcb96fe597464bd5c91453fe00b36521afbf13e98c60f38ece4e79fa7e0076b273c4e30d67748c0c3be0879ba569a278fb1b1f2124da8913
+DIST DBD-Pg-3.14.0.tar.gz 281910 BLAKE2B 803ea4d153f3832df818dad675603a8610d314695a07c87e32eebc7f967ffb7b10ba413bba712ff710e0ebfbc7866e0be4a0fda36c8174e05d1f2c3efb05433a SHA512 d5eb8a5a8cc6fd6695fbdc8a6763552b3f289fac11b20d94211e3cb0edd2e0df246899369abcffdb10fc198b73fdc8fdbf12d57245c4f61974d265d687e314d6
+DIST DBD-Pg-3.14.2.tar.gz 282024 BLAKE2B a8121a2c97b1e095576c40b9b305f0ac21b3a8062efd3ac9684ef68346fc9fb0e4384780dc79b7bb5b6b188825dbd2f3da4765eeeb0208c3bef4db28543f9021 SHA512 341df267a7dc1e28f8c71c1b03cb485caf5c9c2ba95a801f7e855ef8c2fb2ed2df2f3cef804fd36072ee5570d30b399f6fba7516216f7d24186c5b6eeb5d5c52
DIST DBD-Pg-3.5.3.tar.gz 256570 BLAKE2B f589fc4ed978d2215d66b4cfd72b00e166f15dbe2caf004fa52c09fc6fc9f9b81ed84bc04ec0c4d3fe15f4eabb5a8a3b24b08acabb66b993c3ce67576a4c1721 SHA512 7a564e5c86fa41719289f6e391f0cd39f01df7d088892fca11175c60fec8a3af884f9204ae834caac2024ff0d45dcc013e314ec0c09a07fe7ee76170ec3a634f
-DIST DBD-Pg-3.6.2.tar.gz 258640 BLAKE2B 76e25905b0336eae4ead14c28cf8338412fec023ea0540fc80f5c8d02b1c46de1b42ee8be2230fb3276aa3c8fa2bda9a97ddbd41fc81617a557359907c02d600 SHA512 1f55bd463d90cd0d9933acde0a79462a57f11e7ed9519943cc2cb4487b4b69edd7d16ffa3d666c50aca797f9756ff4e6a0d67b58bc100f4920da36169d73b7b4
DIST DBD-Pg-3.7.0.tar.gz 260083 BLAKE2B 73ae253e8033dab58075f6dc3c639e5d21f2df09880f59cb00fcdc201c17db1573e4902c4bfd535916775c0ef61a020a70e8f542ce28e257a903d4aabb9f6730 SHA512 edd4d3448dac1b563899c5fd4a1bad6cb810afdbbbf57b558bbe6710aa3e58530a6cf0932e35c3316c7f4f59763764d75ce1049f13c8c13deeb2e8a7c60ff73e
EBUILD DBD-Pg-3.10.0.ebuild 2736 BLAKE2B 2fe57ad6c03eeed66520bac0fdf34c5a74216e69e9ad14c5bfed936bd31637d0e0960c6b603469567ed5102fb73580a2b326d7974b5aa55012e38959c7133ecf SHA512 958f0dd6b06007af181454b90d60ed32c60d3bfd946b62b45bdb73299674290e52f1f66a0b8328df42e641b49df959b7fddf70fc07fca171af29c2c7c3f5acbb
+EBUILD DBD-Pg-3.13.0.ebuild 2978 BLAKE2B d928e01980997ce0e840d97650a04190756fefac6d6eee52a1bb0297e2f8f76983849136d5308c964a83a2aa4698167c6068e6778684ab7d9bc69038aead8243 SHA512 ea700c33891541af488a79c3231d95db184c599543408f5d44644c33bb03cca20a4337c44e33b403d2ab0348fbd3aea600ea00e424a106a6df8de5140e4ea506
+EBUILD DBD-Pg-3.14.0.ebuild 2848 BLAKE2B 00603932189ac790974ea43981c49467d61dc68a436f0a9c004f8fb637f0b02c1b6078d72c1501ebb5b52270d85c686a84489248134f1bb7ac453c78e11f9e73 SHA512 e571167452b16e923eefab914769b74b55a08e4fd451669e5aad10867d299ff5dd94048b0200b43e9a752c840dedfa6e4a1648bfb331e0cb1fdc30d9410140ab
+EBUILD DBD-Pg-3.14.2.ebuild 2848 BLAKE2B 00603932189ac790974ea43981c49467d61dc68a436f0a9c004f8fb637f0b02c1b6078d72c1501ebb5b52270d85c686a84489248134f1bb7ac453c78e11f9e73 SHA512 e571167452b16e923eefab914769b74b55a08e4fd451669e5aad10867d299ff5dd94048b0200b43e9a752c840dedfa6e4a1648bfb331e0cb1fdc30d9410140ab
EBUILD DBD-Pg-3.5.3.ebuild 1129 BLAKE2B 56b0ce849cd5eb12d51b5bc5a37cc5d4bf1c7a23f246e2805ebef48ca8e639b47f900666e350d5bd68320bd95d4bd2b14f0a8719e8f8572f279d2796ebd18ab2 SHA512 622f427307d046160a7a8c5a7cafdfa00759dc7389fe2ef878c760f3b45a7e9f9dd6fb7beb5cc87c76836e2536aa7e42b68209d17a44c3a93ddad1b3034e5ce6
-EBUILD DBD-Pg-3.6.2.ebuild 1136 BLAKE2B 3f02aff38a01ca215b31eeed8440b12cdeba06a75c86badfd3c07ca521d4eda80fa24753fd4efad0031548c4baf1a0444d941d5ff1be5e68f8601d639ffe9331 SHA512 8d2e86c83fe589e801236b054239033920ec13ce583c7ac491cceb695d60c2241eee1272c27e3da9ea11fd686c0b83708012aa92cefb4ca7bf5c6de074ddf845
EBUILD DBD-Pg-3.7.0.ebuild 2736 BLAKE2B 2b7d7f260773cc2db8dcd68d704c8d8c3f0c9aa391467d4f2cdc1c8187707645dda511f55cc02a4dc9b68d8de1f8b2de65e0cd17aa583a8ecd6c170caf492fcd SHA512 e5250ee0d258d093a7f1ca9ead905d06f7db153286f847ddf815da6c4e6bd44f8715ae0fc4ad49d0503c6ed1f85af200defb6b7617ed98ebc544e85fd810a960
MISC metadata.xml 446 BLAKE2B 428b5b91a84ab6026f482e2e3404f7b43a1557d16f42340453d927b4ea676caa3ab422705ea99439fd6369a43af9f2dcd0d7d3ec6a42f82b9e8df17cd2642a1a SHA512 23e05469a61761595bc52b6798d152dfc82b42a4ce1ed8010cd17b6343557ef92433cd31c00102098ed698ed0fd0260e3d165c926b9ce3de91f52112c9b40684