summaryrefslogtreecommitdiff
path: root/dev-perl/CryptX/CryptX-0.64.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-perl/CryptX/CryptX-0.64.0.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-perl/CryptX/CryptX-0.64.0.ebuild')
-rw-r--r--dev-perl/CryptX/CryptX-0.64.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/CryptX/CryptX-0.64.0.ebuild b/dev-perl/CryptX/CryptX-0.64.0.ebuild
new file mode 100644
index 000000000000..b1a7e49d33fb
--- /dev/null
+++ b/dev-perl/CryptX/CryptX-0.64.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=MIK
+DIST_VERSION=0.064
+inherit perl-module
+
+DESCRIPTION="Self-contained crypto toolkit"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ || ( dev-perl/Cpanel-JSON-XS dev-perl/JSON-XS virtual/perl-JSON-PP )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ !minimal? (
+ >=virtual/perl-Math-BigInt-1.999.715
+ >=virtual/perl-Storable-2.0.0
+ )
+ )
+"
+
+src_test() {
+ perl_rm_files t/003_all_pm_pod.t
+ perl-module_src_test
+}