summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Twofish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Crypt-Twofish
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Crypt-Twofish')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild16
-rw-r--r--dev-perl/Crypt-Twofish/Manifest4
-rw-r--r--dev-perl/Crypt-Twofish/files/no-dot-inc.patch32
-rw-r--r--dev-perl/Crypt-Twofish/metadata.xml12
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild
new file mode 100644
index 000000000000..39165dbb2c93
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=AMS
+MODULE_VERSION=2.17
+inherit perl-module
+
+DESCRIPTION="The Twofish Encryption Algorithm"
+
+SLOT="0"
+KEYWORDS="amd64 ia64 ~ppc ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+SRC_TEST="do"
diff --git a/dev-perl/Crypt-Twofish/Manifest b/dev-perl/Crypt-Twofish/Manifest
new file mode 100644
index 000000000000..986b90f19f3b
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/Manifest
@@ -0,0 +1,4 @@
+AUX no-dot-inc.patch 790 BLAKE2B 71e83b789b58bb0aa3f92db78949f732e45b429b2d4a56b74461af719fa7ab7cd4eb47b5fe4c6150b1a215cb79624c6c56d3558bdd50c12d6d6303f1b13f40d8 SHA512 a5608179bdc33a98c6c070fda3281b7d5c6ceebca3798d26cfe5339e773e46a489dd2f8df02d059d7bea63c0e6d22098dd3f65a264b4e6e9e7575ebbdacb1203
+DIST Crypt-Twofish-2.17.tar.gz 13851 BLAKE2B 4ab615b6af0996bdc6e3c356f84cc65192cff68ed4f5e00b59efcb20d88374a29b2a44f2cd5c8bce0df6a31f8ec366624e6e429d0d72fdb4cf69bca42732d3aa SHA512 c61d07f2fd3d88bff1e41eaa3008c6717fc21e9acf2e45d45c3a39b15500f71b3bc425a3df988bbbd5b6865085866595240f1574424aa70448d6c8b3f38ee2e2
+EBUILD Crypt-Twofish-2.170.0-r1.ebuild 395 BLAKE2B 090d020ebea2023e9d12848672ff960fa1bff1c2889e28b4edf0bf8b8b769fedeb46ca154af68c53a579e13f21bfea9f5d065a373b14e3a167fa430ab7524bd4 SHA512 eed2f47dccf2f26848128d1fb93936b5ba365ed0a3326bc6ba7e24e7ded69294f219a9c147ce3a2d4f2e8df6f2eeb794f4518d94836fd7b38cbdd31b08b2ae12
+MISC metadata.xml 398 BLAKE2B fe19aec82d7a6c90b4521dea669d0246610fe2f61039abee47b8c76302d08e410cb0a02f4d88e6bc7b98d54f95ce81d4a7fa4fec828fae148baca9d3d4a53052 SHA512 d827c972e409391c7c822d0b8cc4a79f8a37f3d10a1460d90f00ab51aaed10b431cc36becd7750de74241bfc40d9043e1bdee34d41b535bb557efa0464eecba3
diff --git a/dev-perl/Crypt-Twofish/files/no-dot-inc.patch b/dev-perl/Crypt-Twofish/files/no-dot-inc.patch
new file mode 100644
index 000000000000..a3b26afe821c
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/files/no-dot-inc.patch
@@ -0,0 +1,32 @@
+From 0906d6c153b3bedad2a91a19e8441b9633070e10 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 15:29:53 +1200
+Subject: [PATCH] Fix tab/tables.pl for Perl 5.26
+
+Removal of "." from @INC means require $PATH no longer ever assumes
+a path relative to ".", and instead must be explicitly stated with a
+leading "./"
+
+Fixes RT#120087
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120087
+---
+ tab/tables.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tab/tables.pl b/tab/tables.pl
+index 2aa0c66..7bed411 100644
+--- a/tab/tables.pl
++++ b/tab/tables.pl
+@@ -3,7 +3,7 @@
+ # Copyright 2001 Abhijit Menon-Sen <ams@wiw.org>
+
+ use strict;
+-require 'tab/misc.pl';
++require './tab/misc.pl';
+
+ my ($qtab, $mtab) = ([], []);
+
+--
+2.13.1
+
diff --git a/dev-perl/Crypt-Twofish/metadata.xml b/dev-perl/Crypt-Twofish/metadata.xml
new file mode 100644
index 000000000000..e45d2072122d
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Crypt-Twofish</remote-id>
+ <remote-id type="cpan-module">Crypt::Twofish</remote-id>
+ </upstream>
+</pkgmetadata>