summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild')
-rw-r--r--dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild b/dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild
new file mode 100644
index 000000000000..4f85eaf5b306
--- /dev/null
+++ b/dev-perl/Crypt-PBKDF2/Crypt-PBKDF2-0.161.520.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ARODLAND
+DIST_VERSION=0.161520
+inherit perl-module
+
+DESCRIPTION="The PBKDF2 password hashing algorithm"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Digest-1.160.0
+ >=dev-perl/Digest-HMAC-1.10.0
+ virtual/perl-Digest-SHA
+ >=dev-perl/Digest-SHA3-0.220.0
+ virtual/perl-MIME-Base64
+ dev-perl/Module-Runtime
+ >=dev-perl/Moo-2.0.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Try-Tiny-0.40.0
+ >=dev-perl/Type-Tiny-1.0.5
+ dev-perl/namespace-autoclean
+ >=dev-perl/strictures-2.0.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"