summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild')
-rw-r--r--dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild b/dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild
new file mode 100644
index 000000000000..c7bac8394d29
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-RSA/Crypt-OpenSSL-RSA-0.310.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="RSA encoding and decoding using the OpenSSL libraries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="libressl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Crypt-OpenSSL-Bignum
+ dev-perl/Crypt-OpenSSL-Random
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+"
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Crypt-OpenSSL-Guess-0.110.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test
+ )
+"
+PERL_RM_FILES=(
+ t/z_kwalitee.t
+ t/z_perl_minimum_version.t
+ t/z_meta.t
+ t/z_pod-coverage.t
+ t/z_pod.t
+)
+mydoc="rfc*.txt"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}