summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild')
-rw-r--r--dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild b/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild
new file mode 100644
index 000000000000..b863f3134866
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=KMX
+DIST_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="Digital Signature Algorithm using OpenSSL"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+DIST_TEST=do
+# otherwise random fails occur
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}