summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-Blowfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/Crypt-Blowfish
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/Crypt-Blowfish')
-rw-r--r--dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild29
-rw-r--r--dev-perl/Crypt-Blowfish/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
new file mode 100644
index 000000000000..abdc8041bf6b
--- /dev/null
+++ b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.14
+inherit perl-module
+
+DESCRIPTION="Perl Blowfish encryption module"
+
+LICENSE="Crypt-IDEA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Crypt-CBC
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Crypt-Blowfish/Manifest b/dev-perl/Crypt-Blowfish/Manifest
index d3cfc3d57257..364bdbcf7ef7 100644
--- a/dev-perl/Crypt-Blowfish/Manifest
+++ b/dev-perl/Crypt-Blowfish/Manifest
@@ -1,3 +1,4 @@
DIST Crypt-Blowfish-2.14.tar.gz 18006 BLAKE2B 45689eb76512e311278278cc724dba5ca7ad9161a7fa2cbb9d05b3fc5ae39d7d1338bfacbad2750d9a418bb8c004ab1334dba4475cdb21eccfc87c489f59fc2c SHA512 be2cdae50bff68858334ad57b124396ebcbfbf9002af4693850e881b9b857a4fa22672b8295b52a5e661381c8f910f3061290bc697770fc7f14c6b64d65496c8
EBUILD Crypt-Blowfish-2.140.0-r1.ebuild 523 BLAKE2B abb10eadb12fe1033874c29c9221c330449d846bfe86196662077d78fd28286aa5f62fac01dbc1f8c023ef055e1b577c0a5d525269af9b8584e6b8d819cfbb78 SHA512 44f8d736294bc2ce4be9957acb0b4b0a1d611185f6363740efe704f6d52cb34d80e2a696902166ea3efb11f5835cd03012d6d2b21bc553ba5b0fccc563a98d88
+EBUILD Crypt-Blowfish-2.140.0-r2.ebuild 659 BLAKE2B 0911ed42f0bbfa55835ef6ca9ed0fc60c0cd5cce879adffe693181ecdbcfe0e2032b08c78170b2a1bbc79827d7d674b5c5a14af57cc0189eb142c5f373e45e78 SHA512 acc9163e76f5fe1c7f75908ca231bccba2636e077b54191912f87138a590ae2a63789522bcfd3919cb95cd2a9708fabc4b06a6cd49955d60e0acaf344cc7d66b
MISC metadata.xml 400 BLAKE2B 300e17a10f3a057f4945642b801fa28d3468e6bdeef83a517af35cef1d2fc32ad6b24b06aeec67d31ff84eedc176e3436d4a35e017cdc4cd8aacf4a246bb4694 SHA512 bdd46bd03582bc00b53d2a700ee6c196fc4670773dc5eb3dd1278d22f12cc5635e0174c6f03eeaf1814c1a950e6c4fb7bfed5d44c26c2b3dd20d985df2e8752e