summaryrefslogtreecommitdiff
path: root/dev-perl/Cpanel-JSON-XS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/Cpanel-JSON-XS
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/Cpanel-JSON-XS')
-rw-r--r--dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild2
-rw-r--r--dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.210.0.ebuild49
-rw-r--r--dev-perl/Cpanel-JSON-XS/Manifest4
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild
index 63619498e387..faa37c8f3a85 100644
--- a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild
+++ b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild
@@ -10,7 +10,7 @@ inherit perl-module
DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.210.0.ebuild b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.210.0.ebuild
new file mode 100644
index 000000000000..a5f85eedc53b
--- /dev/null
+++ b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.210.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=4.21
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.160.0
+ virtual/perl-Carp
+ >=virtual/perl-Encode-1.980.100
+ virtual/perl-XSLoader
+ >=virtual/perl-podlators-2.80.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ virtual/perl-Time-Piece
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+src_test() {
+ ewarn "Comprehensive testing may require manual installation of dependencies"
+ ewarn " See: https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Tests"
+ perl-module_src_test
+}
+pkg_postinst() {
+ ewarn "This package provides 'cpanel_json_xs' in PATH, which includes optional features"
+ ewarn "otherwise not automatically made available yet. If you desire to use these,"
+ ewarn "please consult:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Optional_Features"
+}
diff --git a/dev-perl/Cpanel-JSON-XS/Manifest b/dev-perl/Cpanel-JSON-XS/Manifest
index ceb8534e6de8..c537374d2998 100644
--- a/dev-perl/Cpanel-JSON-XS/Manifest
+++ b/dev-perl/Cpanel-JSON-XS/Manifest
@@ -1,5 +1,7 @@
DIST Cpanel-JSON-XS-3.0239.tar.gz 219371 BLAKE2B b03ad479cc1171d0aba84f0ba221caca14a0ac560712400632d90505e4fb74c50927cd9ad6453e91687e0b4c4f1fd2b50fa32d6355c7d46518bd63adda82734c SHA512 fee7b52f2bb48a4dc6314da4c274bb3456b6af2a0d891c1125425e5a0898e3115ea486a7dc057c25aaf7fc141bfebb5ea4341b17d00373b68a7388eb75f5bdb0
DIST Cpanel-JSON-XS-4.19.tar.gz 251461 BLAKE2B fa22192d017fc41327e71b84f47e3939765b0c48586cc31876f744c2a51a93b36f6d41b8c9f92bba04875123604efe3fed6a486839dbfb39623cb2a4a4064087 SHA512 c67b62e8f95900cb3626357cfa9976f1553f84ffd10a977d47839ca3b317014473c3a6e48f6680478b89bbdc2ac177b22441ad5e49e7e8eb0344ef14a3c52b10
+DIST Cpanel-JSON-XS-4.21.tar.gz 253372 BLAKE2B ad090f758d4b7b1f81ee01cb7860a952ca25c028c8043e33898593eb4818e5746d56eed0101656d95b68be54d68589ee7bb174e09e990d4a139448b422e8c542 SHA512 1408fed400e3e792af156695a5437e479a30cafb7d0597afc80c04de9b46882b67f75920f5f32047ed498bf088c9430108cea6863cfd2e6314765688f2c610e0
EBUILD Cpanel-JSON-XS-3.23.900.ebuild 699 BLAKE2B 8777b7cdb256f40b7909b2d5448dba1ccf545cc561c1fc6618f896907f8a1f33bf48ea6aa2476f9c731a63b767b290a0b1e25014f364ad1f73dce6c6893024ac SHA512 2f9ba2206c92eae1a3bc9f30058c1e1770ac97544ed0bcb545cead984edcdf81d27e71af4f0c70c5d31df9bd19bbdadeecc572f3a50a78842a4f0c0d6132ef11
-EBUILD Cpanel-JSON-XS-4.190.0.ebuild 1474 BLAKE2B a35252a773e43da50db13281cc0fbab927e3a45c5f65e099d689e8c6f7023e27a3a2601837e81baf6a139de686bc90a6879cb95edd30117892aad55362b86050 SHA512 8588c1f5145a2d710ce5da8d120f0471e6430a62008d7451244a1e08c02e96d519cbd00be78aaf9aba6d5cfe39d127dd39f7893b6fb87206811f3cd3a946480e
+EBUILD Cpanel-JSON-XS-4.190.0.ebuild 1470 BLAKE2B b8f22fc520e715f14b51e08d9d02b6241082c5c32f64a4f06774b32db2aa39d4e043763d0503fad87f252d1f4c55da219acc441d870e2c79f9a088a43fd73d8a SHA512 e157e5d426098dc3062089ad3020e4fa01c4e313ffd97e7ebb4a3dbde223c9123d3fad01eb70fc6c736c4a12503202bfc8b20ae9e3fdfac7cf6cda6abaa1c9f2
+EBUILD Cpanel-JSON-XS-4.210.0.ebuild 1474 BLAKE2B eb2324582cd980dd2ae0cb0c43fbe4e9e8639251c7306c2e33f0e5f3cc0eaf1e130fbf8691dd3f00ee7d5a54a542090f44f7a0546011caabfa86a290e5cab235 SHA512 c4aaaf2dfc58783ef2276f83d691f48a0a3ade283d83359af86a7adbceafcefc1d9108cdc7df165890d135bc602788c3db97e6a5ac8df48ad7c801d9f0fab2e1
MISC metadata.xml 470 BLAKE2B bc977764b6c5673d270e895b5e923a87f917096620f1092fdad2049df0173ff321ec0be9f2b9ab926b02ce030d4d3fd7504024ff5167605c05edb04d20b4081e SHA512 4f3013da420d4c1d51df09efe590bd8bde9de5751cd1f35fb0935941cc1c541f6dadbf45b155849c70fefdb612d069357380e4b85d01e16454ba035d82d2c05f