summaryrefslogtreecommitdiff
path: root/dev-perl/Coro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Coro
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Coro')
-rw-r--r--dev-perl/Coro/Coro-6.514.0.ebuild38
-rw-r--r--dev-perl/Coro/Manifest4
-rw-r--r--dev-perl/Coro/files/6.514.0-ev-config.patch74
-rw-r--r--dev-perl/Coro/metadata.xml40
4 files changed, 156 insertions, 0 deletions
diff --git a/dev-perl/Coro/Coro-6.514.0.ebuild b/dev-perl/Coro/Coro-6.514.0.ebuild
new file mode 100644
index 000000000000..5cbecd4664f6
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.514.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=6.514
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ev event"
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ ev? ( >=dev-perl/EV-4.0.0 )
+ event? ( >=dev-perl/Event-0.890.0 )
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+PATCHES=(
+ "${FILESDIR}/${PV}-ev-config.patch"
+)
+src_configure() {
+ local myopts=()
+ use ev && myopts+=("EV")
+ use event && myopts+=( "Event" )
+ GENTOO_OPTS="${myopts[@]}" perl-module_src_configure
+}
diff --git a/dev-perl/Coro/Manifest b/dev-perl/Coro/Manifest
new file mode 100644
index 000000000000..40a1eeb7652c
--- /dev/null
+++ b/dev-perl/Coro/Manifest
@@ -0,0 +1,4 @@
+AUX 6.514.0-ev-config.patch 1910 BLAKE2B ff12ad9b3728434bf44c8052b6eb9eeafc92ed3b1473b7bf81c2fb93eb1b5be3839e129fccc6bea422446bdeb84b630aa955deef86bf7b2e608dca02411408e5 SHA512 8738d753d174bc1de81d8d21a59de4ca738e2f9b5810b3a5d0b66c06b724aaa5b4a98b229ef0eaaf0ce2f435b8566fb89b5de24a7156f0c4a3504a7954b81e92
+DIST Coro-6.514.tar.gz 195122 BLAKE2B d512a990f54e22af20ea91165817d00bab20dcbe0e9111988f704799556cf246f96a40a8b59b56977edefbabf8830453662001ceb35eb4d0f1761ce7c3da3fb7 SHA512 340eea9bc2a33c40813f4852d3a12ff947426fd329a4867a36262a9ece936c9e43d36ba5e4355d1f8f91cb40690de3bb1637ab0b0651518c22fb17a34ee90b37
+EBUILD Coro-6.514.0.ebuild 803 BLAKE2B e4be43f176d5144d4b30c31e2a43a661c07d3952c0670ccca5d804bfc10434b310082a2ea4e1cf2fb13d42e80015fc41dd9e500a626cd7d1e6dbcb333b512deb SHA512 97547c44b581163130bb8b9974678669208708f85e3390fef1051054a0bd5c394a2bc0d3466ed6e792e1897bb02a60a63a57b3c163e2a413c997b2ec98ce3a8d
+MISC metadata.xml 2046 BLAKE2B 80254d1423924a1ee751e0da22d765bcf1502da51812179fc2859bc7ee099649525f0792c07d05985247d89e9f91285d927f6c1c6dc9fbedcb82b80673abcfdd SHA512 669379a76eae094150d989d956b66dcfbd6f519c8f2f2c55045f5e9a61ba5bdbcf5a066aac85d6e48e48979c6d966ae42fa398554236c6143c8885a6b76666e5
diff --git a/dev-perl/Coro/files/6.514.0-ev-config.patch b/dev-perl/Coro/files/6.514.0-ev-config.patch
new file mode 100644
index 000000000000..7b775b557eda
--- /dev/null
+++ b/dev-perl/Coro/files/6.514.0-ev-config.patch
@@ -0,0 +1,74 @@
+From bada194851e0a6839f78e811bfc63c2d5e8877dc Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 5 Oct 2017 22:02:38 +1300
+Subject: Make EV/Event not auto-compiled, but rely on configuration
+
+---
+ Makefile.PL | 51 ++++++++++-----------------------------------------
+ 1 file changed, 10 insertions(+), 41 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index e58e210..25243ff 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -17,47 +17,16 @@ EOF
+
+ print "*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***\n\n";
+
+-if (eval { require Event }) {
+- if ($Event::VERSION < 0.86 or $Event::VERSION == 0.88) {
+- print <<EOF
+-
+-***
+-*** WARNING: Event version $Event::VERSION found, NOT building Event support.
+-***
+-*** This version of Event is broken. The only currently known non-broken
+-*** versions of Event are 0.87 and 0.89+. Please install one of those
+-*** versions.
+-***
+-
+-EOF
+- } else {
+- $EVENT = 1;
+- $DEFINE .= " -DHAVE_EVENT=1";
+- print "\nEvent version $Event::VERSION found, building Event support.\n\n";
+- }
+-} else {
+- print "\n*** Event not found, not building Event support.\n\n";
+-}
+-
+-if (eval { require EV }) {
+- if ($EV::VERSION < 4.0) {
+- print <<EOF
+-
+-***
+-*** WARNING: EV version $EV::VERSION found, NOT building EV support.
+-***
+-*** This version is ABI-incompatible with Coro, please upgrade to at least 4.0.
+-***
+-
+-EOF
+- } else {
+- $EV = 1;
+- $DEFINE .= " -DHAVE_EV=1";
+- print "\nEV version $EV::VERSION found, building EV support.\n\n";
+- }
+-} else {
+- print "\n*** EV not found, not building EV support.\n\n";
+-}
++$EVENT = ( $ENV{GENTOO_OPTS} =~ /\bEvent\b/ );
++$EV = ( $ENV{GENTOO_OPTS} =~ /\bEV\b/ );
++$EVENT and do {
++ require Event;
++ Event->VERSION(0.89);
++};
++$EV and do {
++ require EV;
++ EV->VERSION(4.0);
++};
+
+ WriteMakefile(
+ dist => {
+--
+2.14.1
+
diff --git a/dev-perl/Coro/metadata.xml b/dev-perl/Coro/metadata.xml
new file mode 100644
index 000000000000..b9f208cf2546
--- /dev/null
+++ b/dev-perl/Coro/metadata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <use>
+ <flag name="ev">Build support for using <pkg>dev-perl/EV</pkg> as an event-loop via Coro::EV</flag>
+ <flag name="event">Build support for using <pkg>dev-perl/Event</pkg> as an event-loop via Coro::Event</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">Coro</remote-id>
+ <remote-id type="cpan-module">Coro</remote-id>
+ <remote-id type="cpan-module">Coro::AIO</remote-id>
+ <remote-id type="cpan-module">Coro::AnyEvent</remote-id>
+ <remote-id type="cpan-module">Coro::BDB</remote-id>
+ <remote-id type="cpan-module">Coro::Channel</remote-id>
+ <remote-id type="cpan-module">Coro::Debug</remote-id>
+ <remote-id type="cpan-module">Coro::EV</remote-id>
+ <remote-id type="cpan-module">Coro::Event</remote-id>
+ <remote-id type="cpan-module">Coro::Handle</remote-id>
+ <remote-id type="cpan-module">Coro::Handle::FH</remote-id>
+ <remote-id type="cpan-module">Coro::LWP</remote-id>
+ <remote-id type="cpan-module">Coro::LWP::Socket</remote-id>
+ <remote-id type="cpan-module">Coro::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Coro::RWLock</remote-id>
+ <remote-id type="cpan-module">Coro::Select</remote-id>
+ <remote-id type="cpan-module">Coro::Semaphore</remote-id>
+ <remote-id type="cpan-module">Coro::SemaphoreSet</remote-id>
+ <remote-id type="cpan-module">Coro::Signal</remote-id>
+ <remote-id type="cpan-module">Coro::Socket</remote-id>
+ <remote-id type="cpan-module">Coro::Specific</remote-id>
+ <remote-id type="cpan-module">Coro::State</remote-id>
+ <remote-id type="cpan-module">Coro::Storable</remote-id>
+ <remote-id type="cpan-module">Coro::Timer</remote-id>
+ <remote-id type="cpan-module">Coro::Timer::Timeout</remote-id>
+ <remote-id type="cpan-module">Coro::Util</remote-id>
+ </upstream>
+</pkgmetadata>