summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-PEM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Convert-PEM
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Convert-PEM')
-rw-r--r--dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild30
-rw-r--r--dev-perl/Convert-PEM/Manifest6
-rw-r--r--dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-526.patch23
-rw-r--r--dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-decryptiontest.patch70
-rw-r--r--dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-testbuilder.patch29
-rw-r--r--dev-perl/Convert-PEM/metadata.xml13
6 files changed, 171 insertions, 0 deletions
diff --git a/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
new file mode 100644
index 000000000000..469ab38663d1
--- /dev/null
+++ b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=BTROTT
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Read/write encrypted ASN.1 PEM files"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Class-ErrorHandler
+ dev-perl/Convert-ASN1
+ dev-perl/Crypt-DES_EDE3
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-526.patch"
+ "${FILESDIR}/${P}-decryptiontest.patch"
+ "${FILESDIR}/${P}-testbuilder.patch"
+)
+
+SRC_TEST=do
diff --git a/dev-perl/Convert-PEM/Manifest b/dev-perl/Convert-PEM/Manifest
new file mode 100644
index 000000000000..bc8938a53493
--- /dev/null
+++ b/dev-perl/Convert-PEM/Manifest
@@ -0,0 +1,6 @@
+AUX Convert-PEM-0.80.0-526.patch 578 BLAKE2B 4a2f391fdd035758d9b5c51b2499cee1c7871fb2ed3390ee8d1926a41fbd8f0ad36124cdd71f0dfc97eb4fa9ab5824cac24a770764a87bef8793c3adad5a3c71 SHA512 edea9eced91467074b6142a287832d15a801d9772313a338cf271f02a999546f273264a8cf9430f6a05d9d5686581684e6ee712b16f64ce36e0618264b7fdf72
+AUX Convert-PEM-0.80.0-decryptiontest.patch 2509 BLAKE2B bf0da476d2ccdb72d55b88ab114d3deacf32d457535464bcf84b3c9d082f2ae5d1bd65557c66c21f5374950bbba2cc02e88f61e0788152f305e442b077e8085b SHA512 554e98c100a47d396b00529e7b77afad26d491eb04b0e58dc45c94b699440133abdc9c30be4ccf8e6b692fb386a1867a49d2e5243f6a42e3423f67aed50d0ae7
+AUX Convert-PEM-0.80.0-testbuilder.patch 802 BLAKE2B 267c7e62334e50039fb3db105e31d0ba799265e83b26f996f1c27b3a1f4954eb768131437cd95f07b4c78d96511b2252881e43cdabab97e9f77efdc0eaf98a95 SHA512 cb41dd95c3f5556e98a102bd3b776b8ad284407fbdc4eb669d9de6d5b5e78bf69ab90067d0d512a4527a3f82952b5405aa42bb17198a64d29a7cb196b981d09e
+DIST Convert-PEM-0.08.tar.gz 54089 BLAKE2B f550295b225539ac5ab91e05cf1b0fa8fdfb8d0f1e718d69c7c86a318173cabe4967efd4abba4e0a1f3ff86811a87ceb27b306cf1026b39652e4d1c7e402139e SHA512 d5e4342b40d01d534ec5f81ab009af185f795267c1bce792d26739ab07078a618093c720230ac2b6cf10c4b5ae1c282c94afa5b9db2eef6fd66e684d2080c273
+EBUILD Convert-PEM-0.80.0-r1.ebuild 650 BLAKE2B ef974ac1eb5d1cbaa3c097e7d24812503f40d41fee307f05022b64bca2f330912aa90cf97057d9b0504c4cce807970599d802d14350447f0a3b6e694b6eaf45f SHA512 ab9f2c1e6c4c68949d6a88cb9c5acd32050482efec4337f82f6328545092676bf4b80d2a9823015ca39fe2e115370d6cb0a40ea9cc551643dc9f7fa8e7b4aa4c
+MISC metadata.xml 458 BLAKE2B 2ffb3c8e186ac6e6ccbab3281c9d0579f8705833bdc44c365bc0e8b076bb06f064c55ba4f2c7cf0e98bf322f89601e89bf780ace63653880dfd6b5c43ce1a6d2 SHA512 d53a244bc6d082ead7e3cc3baddb5233cb2b208541453e812fc41556c291a786978c56ce66d22962a602ca19d0e746cd22f915c32a7c60f4e392445eb9b00bc8
diff --git a/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-526.patch b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-526.patch
new file mode 100644
index 000000000000..49c74e5e688f
--- /dev/null
+++ b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-526.patch
@@ -0,0 +1,23 @@
+From 22b4a18d00c7080972341db2052041448391fbfe Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 11 Jun 2017 14:42:41 +1200
+Subject: Fix Makefile.PL for Perl 5.26 w/o "." in @INC
+
+Bug: https://bugs.gentoo.org/613632
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120714
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 8d4d686..3e87348 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+ name 'Convert-PEM';
+ all_from 'lib/Convert/PEM.pm';
+--
+2.14.1
+
diff --git a/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-decryptiontest.patch b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-decryptiontest.patch
new file mode 100644
index 000000000000..3fac17d111dd
--- /dev/null
+++ b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-decryptiontest.patch
@@ -0,0 +1,70 @@
+From 9b8f76ece49348cfdc50c5e3b4098694e07184d6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Fri, 5 Sep 2014 11:04:30 +0200
+Subject: Do not test the reason for decryption failure on bad key
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Tests checking error message after using bad decryption key fails
+randomly.
+
+Some bad keys can fool the "Bad key/passphrase" heuristic in the
+Convert::PEM::CBC::decode() because it's a feature a stream cipher to
+spit out bad output on bad key. So the heuristic is just a kind
+service to point to the cause of the decoding failure (i.e. bad key).
+By probabilistic nature of the heuristic, we cannot rely on the
+/^Decryption failed/ error message.
+
+This patch removes these tests.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=27574
+Bug: https://bugs.gentoo.org/625652
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+---
+ t/01-readwrite.t | 3 +--
+ t/02-encode.t | 3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/t/01-readwrite.t b/t/01-readwrite.t
+index 42a4416..208eba1 100644
+--- a/t/01-readwrite.t
++++ b/t/01-readwrite.t
+@@ -1,5 +1,5 @@
+ use strict;
+-use Test::More tests => 16;
++use Test::More tests => 15;
+ use Test::Exception;
+
+ use Convert::PEM;
+@@ -29,7 +29,6 @@ lives_ok { $pem->write( Filename => $objfile, Content => $obj, Password => 'xx'
+ ok -e $objfile, 'output file exists';
+ lives_ok { $obj2 = $pem->read( Filename => $objfile ) } 'can read';
+ ok !defined $obj2, 'cannot read encrypted file';
+-like $pem->errstr, qr/^Decryption failed/, 'errstr matches decryption failed';
+ lives_ok { $obj2 = $pem->read( Filename => $objfile, Password => 'xx') } 'can read';
+ is $obj->{TestObject}{int}, $obj2->{TestObject}{int}, 'input matches output';
+ unlink $objfile;
+diff --git a/t/02-encode.t b/t/02-encode.t
+index 37aa987..9c6ab4c 100644
+--- a/t/02-encode.t
++++ b/t/02-encode.t
+@@ -1,5 +1,5 @@
+ use strict;
+-use Test::More tests => 9;
++use Test::More tests => 8;
+
+ use Convert::PEM;
+ use Math::BigInt;
+@@ -25,7 +25,6 @@ $blob = $pem->encode( Content => $obj, Password => 'xx' );
+ ok $blob, 'encode gave us something';
+ $obj2 = $pem->decode( Content => $blob );
+ ok !defined $obj2, 'decode fails on encrypted input';
+-like $pem->errstr, qr/^Decryption failed/, 'errstr matches decrypt failed';
+ $obj2 = $pem->decode( Content => $blob, Password => 'xx' );
+ is $obj->{TestObject}{int}, $obj2->{TestObject}{int}, 'input matches output';
+
+--
+2.14.1
+
diff --git a/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-testbuilder.patch b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-testbuilder.patch
new file mode 100644
index 000000000000..f12b64d5c5f4
--- /dev/null
+++ b/dev-perl/Convert-PEM/files/Convert-PEM-0.80.0-testbuilder.patch
@@ -0,0 +1,29 @@
+From 831b57ff2167e1192964c190271767e469dac48a Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 3 Oct 2017 05:01:21 +1300
+Subject: Fix Test::Builder warning
+
+Ideally upstream should just stop bundling Test::Builder, but this
+is the smallest change that avoids the issue
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=111009
+---
+ inc/Test/Builder.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/inc/Test/Builder.pm b/inc/Test/Builder.pm
+index 795361f..6b0c8c3 100644
+--- a/inc/Test/Builder.pm
++++ b/inc/Test/Builder.pm
+@@ -589,7 +589,7 @@ sub _is_dualvar {
+
+ no warnings 'numeric';
+ my $numval = $val + 0;
+- return $numval != 0 and $numval ne $val ? 1 : 0;
++ return ($numval != 0 and $numval ne $val ? 1 : 0);
+ }
+
+ #line 876
+--
+2.14.1
+
diff --git a/dev-perl/Convert-PEM/metadata.xml b/dev-perl/Convert-PEM/metadata.xml
new file mode 100644
index 000000000000..48bd3328e218
--- /dev/null
+++ b/dev-perl/Convert-PEM/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Convert-PEM</remote-id>
+ <remote-id type="cpan-module">Convert::PEM</remote-id>
+ <remote-id type="cpan-module">Convert::PEM::CBC</remote-id>
+ </upstream>
+</pkgmetadata>