summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-Binary-C
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Convert-Binary-C
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Convert-Binary-C')
-rw-r--r--dev-perl/Convert-Binary-C/Convert-Binary-C-0.770.0.ebuild19
-rw-r--r--dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild26
-rw-r--r--dev-perl/Convert-Binary-C/Manifest8
-rw-r--r--dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch181
-rw-r--r--dev-perl/Convert-Binary-C/metadata.xml13
5 files changed, 247 insertions, 0 deletions
diff --git a/dev-perl/Convert-Binary-C/Convert-Binary-C-0.770.0.ebuild b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.770.0.ebuild
new file mode 100644
index 000000000000..718fe174a5f9
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.770.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MHX
+MODULE_VERSION=0.77
+inherit perl-module
+
+DESCRIPTION="Binary Data Conversion using C Types"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+MAKEOPTS+=" -j1"
+SRC_TEST="do"
diff --git a/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild
new file mode 100644
index 000000000000..5e0870a99a50
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MHX
+DIST_VERSION=0.78
+# NB: Examples are generated
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Binary Data Conversion using C Types"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# bison >= 1.31?
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+MAKEOPTS+=" -j1"
+PATCHES=( "${FILESDIR}/${P}-perl-526.patch" )
+src_test() {
+ perl_rm_files tests/802_pod.t tests/803_pod_coverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Convert-Binary-C/Manifest b/dev-perl/Convert-Binary-C/Manifest
new file mode 100644
index 000000000000..8f3f233cdb26
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Manifest
@@ -0,0 +1,8 @@
+AUX Convert-Binary-C-0.780.0-perl-526.patch 5389 SHA256 d2d734dbc5ffbbe172bea1bb386df6204624ca42e508df220acf6b7dd11b22c8 SHA512 c6bffca0fe3bdf47d32821f6fff033828f03c4a26e23c4097556f0134a40e01bc47cae5672707cd875f11b9f63a1877b096eec76349e35e99ba4a1c4284aad4a WHIRLPOOL bb841e3e80b69e97627ed01fe9bf9e4f32150ebd11113e67483c74ed3926ed076253d4b9eb5e81a55e34e98bc48da8d92fc8b1bac1c29672e56a4c1c041eadad
+DIST Convert-Binary-C-0.77.tar.gz 1562435 SHA256 fe33824fbdd20920658b36e0cd50bcb0d2924c83ab3240b861340d558dd7fc91 SHA512 662f1dc2080f3e432727553067826f09d20f30f0dbe09154eea4cbbdd5020d32f6839806365741e4aa54e8cb85eb948787904204cb2e029b9ec7eae605599d45 WHIRLPOOL 35227fcf1d1833c92ad9ea6a9e28a122307868285f0a7709c7392c6d626477b6e1a9c35a399590303c18f08dc48f35a7e17b6384a5ddb84d39b566dda148c9b8
+DIST Convert-Binary-C-0.78.tar.gz 1564698 SHA256 24008c3f89117005d308bb2fd2317db6d086a265be6e98855109bbc12a52f2ea SHA512 d9b85ce2ae870c2de6c2fa0838a6b20000ec8d33f19a989f8ebe1b026f2796ae7e924391a0fe387310a3217c75dcd797ea819ff964a9c3e448d007c16d41040c WHIRLPOOL b8511643c2bdc5912a68db90136678d6854a47d4f2061e1835cf1da9d6324dfe9f2650dc032f6ba159ad295ec9bb2e652a9485c7e3357abc8b5f0f853f68395e
+EBUILD Convert-Binary-C-0.770.0.ebuild 339 SHA256 a79985d305e2758d7db9c4ec241ba91474f98e0c65f0db3a699ac1dceb5f79c6 SHA512 1e825508ebce3bc19df93e75b48a95cc6bd3f56a316cf278cb34e198346137471432db67e5fee0f89d91333923bde7712615a651819adaf703b7ebcfa328342f WHIRLPOOL bf8675a36cafa03fb5ce5f4fbbec6f9dd3204e86c04fd726976a51d661a2c10d534f2e7f96525daed32aa00701539e941c15e89056739b3eb2751d3a5153f9d6
+EBUILD Convert-Binary-C-0.780.0-r1.ebuild 537 SHA256 92826e9ee8a9d4d6e77a1c22ef6a393c7162289b970f5bdcedf6e663111d357e SHA512 c828268031aafaf69e73bdda36d7600a3d0d5c457da5c70458b9d14ca1d299014984723ada067e412925c403acbb34c4b71e5d7dfb6458c5d8b46ff7c34596a6 WHIRLPOOL 4d34001152e3560ccf4db27c557e764f497ea9c00476327d0abf8c512df664bcaab33dd39f084c48cfeda442bb92cb3bf5374027499ff2aadec97072275ccaf1
+MISC ChangeLog 3805 SHA256 442bd681ba6abf4cb5f71218876f9049770816e9190a6be50112aeea3890ede5 SHA512 890f52d076f6501ff5e8e8a4c3b6af7603a5b33d46663a5cabc9a8ef9998a6d790152bb5240019ed4fe120f5669196069afc14c3f3a73155bb7c64c0c589f41c WHIRLPOOL a83b9cfe078e4080d8abe36bec5d53c671af5fcb1f2f7374332d86fc2fcc2064c5b653bec07b61a584025eb0b5020d3b6f1b166fb5e0adb0225ed71019da8167
+MISC ChangeLog-2015 2223 SHA256 5f4a48e1903f425a0b8431b66d16c59ab1ba7f6b5e4423f95aead5557d1e29e9 SHA512 3a1411d771b54f4f34942b588307cd4aa61b2b0f4505f48e16b5dd889619ab4b29c86001cabc93ad6b77b565cf3a80407e90e8667414027f99e22100ab3091da WHIRLPOOL 5cef1a74eeedd40055d137d7ec3427db8aea0ca1cf44f25a806d47cba77915ddc99f97d68eba0796e88d4d21b428c47b83588f0b0d0bf66fa1871cd8595b47d5
+MISC metadata.xml 478 SHA256 d631f121a192c419ef5e20870784a54cef87cfbda8bebd559c69e1a179ccd8a9 SHA512 589fee143714f35bf258db7a23b2d7539dd311b891f1c5132a8018f911296aa38fa45237a72be8fcbe38b890fb401d60bcb380cd1793eccfbc4287c114c0cda5 WHIRLPOOL 7f160cade4fdf887088155b174afd0e216404e8798be5d50ec001549a7d738f29b8deb415e0759e0fadf7aa8fcc98d45962ad310b80f3236b0856512da09392f
diff --git a/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch b/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
new file mode 100644
index 000000000000..2c61d6178bc5
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
@@ -0,0 +1,181 @@
+From 26c2c60f11cf649f348a5af2c15f83525f02bf30 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Wed, 20 Sep 2017 08:00:50 +1200
+Subject: Fix tests for Perl 5.26
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=121039
+Bug: https://bugs.gentoo.org/615106
+Bug: https://github.com/mhx/Convert-Binary-C/pull/6
+---
+ bin/perltypes.PL | 3 ++-
+ tests/206_parse.t | 4 ++--
+ tests/209_sourcify.t | 2 +-
+ tests/210_depend.t | 2 +-
+ tests/211_clone.t | 2 +-
+ tests/215_local.t | 2 +-
+ tests/218_member.t | 2 +-
+ tests/223_initializer.t | 2 +-
+ tests/230_compiler.t | 2 +-
+ tests/601_speed.t | 2 +-
+ tests/602_threads.t | 2 +-
+ 11 files changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/bin/perltypes.PL b/bin/perltypes.PL
+index 09ca5d2..be63ffd 100755
+--- a/bin/perltypes.PL
++++ b/bin/perltypes.PL
+@@ -21,10 +21,11 @@ print OUT <<'!NO!SUBS!';
+
+ use Convert::Binary::C;
+ use Data::Dumper;
++use File::Spec::Functions qw(rel2abs);
+ use strict;
+
+ my $base;
+--d "$_/include" and $base = "$_/include" and last for qw( tests ../tests );
++-d "$_/include" and $base = rel2abs("$_/include") and last for qw( tests ../tests );
+ defined $base or die <<MSG;
+ Please run this script from either the 'examples' directory
+ or the distribution base directory.
+diff --git a/tests/206_parse.t b/tests/206_parse.t
+index 6e34d63..a4c403f 100644
+--- a/tests/206_parse.t
++++ b/tests/206_parse.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 116 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ #===================================================================
+ # create object (1 tests)
+@@ -140,7 +140,7 @@ ok($s1,329,"incorrect number of typedef identifiers");
+ # check if all sizes are correct (1 big test)
+ #===================================================================
+
+-do 'tests/include/sizeof.pl';
++do './tests/include/sizeof.pl';
+ $max_size = 0;
+ @fail = ();
+ @success = ();
+diff --git a/tests/209_sourcify.t b/tests/209_sourcify.t
+index 3fbdae6..0f34e83 100644
+--- a/tests/209_sourcify.t
++++ b/tests/209_sourcify.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 98 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $orig = new Convert::Binary::C %$CCCFG;
+diff --git a/tests/210_depend.t b/tests/210_depend.t
+index b46fdf7..e2705fd 100644
+--- a/tests/210_depend.t
++++ b/tests/210_depend.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 483 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $c1 = new Convert::Binary::C Include => ['tests/include/files'];
+diff --git a/tests/211_clone.t b/tests/211_clone.t
+index 252554f..144de70 100644
+--- a/tests/211_clone.t
++++ b/tests/211_clone.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 35 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $orig = new Convert::Binary::C %$CCCFG;
+diff --git a/tests/215_local.t b/tests/215_local.t
+index dabf7fc..2f2dffe 100644
+--- a/tests/215_local.t
++++ b/tests/215_local.t
+@@ -15,7 +15,7 @@ BEGIN {
+ plan tests => 10;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $c = new Convert::Binary::C;
+diff --git a/tests/218_member.t b/tests/218_member.t
+index e212160..7966e44 100644
+--- a/tests/218_member.t
++++ b/tests/218_member.t
+@@ -15,7 +15,7 @@ BEGIN {
+ plan tests => 1907;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ %basic = ( char => 1, short => 1, int => 1,
+ long => 1, signed => 1, unsigned => 1,
+diff --git a/tests/223_initializer.t b/tests/223_initializer.t
+index a80d741..f1d6b26 100644
+--- a/tests/223_initializer.t
++++ b/tests/223_initializer.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 27 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ $c = eval { new Convert::Binary::C %$CCCFG };
+ ok($@,'',"failed to create Convert::Binary::C objects");
+diff --git a/tests/230_compiler.t b/tests/230_compiler.t
+index 1cc67f1..276275a 100644
+--- a/tests/230_compiler.t
++++ b/tests/230_compiler.t
+@@ -37,7 +37,7 @@ for my $cur (sort keys %cc) {
+ $bin =~ s/\s+//gms;
+ $bin = pack "H*", $bin;
+
+- do $cc{$cur}{cfg};
++ do "./$cc{$cur}{cfg}";
+
+ my $c = new Convert::Binary::C %config;
+ $c->parse_file('tests/compiler/test.h');
+diff --git a/tests/601_speed.t b/tests/601_speed.t
+index 27f1fc9..d399e38 100644
+--- a/tests/601_speed.t
++++ b/tests/601_speed.t
+@@ -16,7 +16,7 @@ BEGIN {
+ plan tests => 11;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval { require Data::Dumper }; $Data_Dumper = $@;
+ eval { require IO::File }; $IO_File = $@;
+diff --git a/tests/602_threads.t b/tests/602_threads.t
+index 8e45b0d..968939b 100644
+--- a/tests/602_threads.t
++++ b/tests/602_threads.t
+@@ -17,7 +17,7 @@ BEGIN {
+ plan tests => NUM_THREADS
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ #===================================================================
+ # load appropriate threads module and start a couple of threads
+--
+2.14.1
+
diff --git a/dev-perl/Convert-Binary-C/metadata.xml b/dev-perl/Convert-Binary-C/metadata.xml
new file mode 100644
index 000000000000..56b56d9d9eb5
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Convert-Binary-C</remote-id>
+ <remote-id type="cpan-module">Convert::Binary::C</remote-id>
+ <remote-id type="cpan-module">Convert::Binary::C::Cached</remote-id>
+ </upstream>
+</pkgmetadata>