summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-ASN1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Convert-ASN1
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Convert-ASN1')
-rw-r--r--dev-perl/Convert-ASN1/Convert-ASN1-0.270.0.ebuild28
-rw-r--r--dev-perl/Convert-ASN1/Manifest4
-rw-r--r--dev-perl/Convert-ASN1/files/Convert-ASN1-0.270.0-perl-526.patch307
-rw-r--r--dev-perl/Convert-ASN1/metadata.xml12
4 files changed, 351 insertions, 0 deletions
diff --git a/dev-perl/Convert-ASN1/Convert-ASN1-0.270.0.ebuild b/dev-perl/Convert-ASN1/Convert-ASN1-0.270.0.ebuild
new file mode 100644
index 000000000000..4b5d1444cee4
--- /dev/null
+++ b/dev-perl/Convert-ASN1/Convert-ASN1-0.270.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=GBARR
+MODULE_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Standard en/decode of ASN.1 structures"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Math-BigInt-1.997.0
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${P}-perl-526.patch"
+)
+
+SRC_TEST=do
diff --git a/dev-perl/Convert-ASN1/Manifest b/dev-perl/Convert-ASN1/Manifest
new file mode 100644
index 000000000000..672497d75310
--- /dev/null
+++ b/dev-perl/Convert-ASN1/Manifest
@@ -0,0 +1,4 @@
+AUX Convert-ASN1-0.270.0-perl-526.patch 6189 BLAKE2B 93614ec863a4a90e195fb7e99e4e4a6b729fa1d154a85d9d9f72232ff9cdca50868d5ba320653853ae6da5d612533d57cb9470c56ad2e01e979613cf628509bb SHA512 a6805154a0b7da8af86c101521b74d88562e34f95890ab62221bd7d0d03a41a1dcc82b26eb79383d84274abbb9ed4c683f627e75434062b7cf0984b340f5192c
+DIST Convert-ASN1-0.27.tar.gz 74081 BLAKE2B 14929ec5f25ac85465204fb8f584384c5c65e73cb3ee5bfd9510a9bb2580e7c1a86f485af99ab7cd83813914ae6e277020720d26af8d2bda54acdd06fff7e984 SHA512 253bc0c1b2919841497a95bcbd05825217a3013c7f789fd9f3d389808fb015daca91f5c149797574bf32d38e94efb7f1d8df62e9e4c13928ec3b978cc9fd6fe8
+EBUILD Convert-ASN1-0.270.0.ebuild 636 BLAKE2B 8f9f100f9c72b347c347f5893317711cad4c71eaec4a03fde8a5d73f0e611f246d6d9a95754477e39ed4e9bc7a3d8853ab4da25169aad8c88d2ed2d2af24a2ad SHA512 472b7a4b127f29bcbea9bfc272fe6e59257229730f70846057d9c59fd488123448aa1ce8d042e74a9c1cb0f6db973a77e290cee34e50ffcbce4f803ef4dd765e
+MISC metadata.xml 396 BLAKE2B 835109f7d055b2dad36326d3f8cff1c08596d68b70a2688a7800c5c7baaea3e3282d491e1b2a321aa2ea1d510a4f9cc69448ca3193317d08abff39717ca3c25d SHA512 8e9334d912a55b1da2071790da0a113a4f841babee48bcecbee7943c5a242548d7d4ae9cfbc8840bf29712444ea28090e784713929a0437c9086648c774357bf
diff --git a/dev-perl/Convert-ASN1/files/Convert-ASN1-0.270.0-perl-526.patch b/dev-perl/Convert-ASN1/files/Convert-ASN1-0.270.0-perl-526.patch
new file mode 100644
index 000000000000..da6a54b35f54
--- /dev/null
+++ b/dev-perl/Convert-ASN1/files/Convert-ASN1-0.270.0-perl-526.patch
@@ -0,0 +1,307 @@
+From a174f9ced333da8dda20255bd97c075d690da2f8 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 1 Oct 2017 03:17:03 +1300
+Subject: Fix test failures under Perl 5.26+ without '.' in @INC
+
+Bug: https://github.com/gbarr/perl-Convert-ASN1/issues/33
+Bug: https://bugs.gentoo.org/613638
+Bug: https://github.com/gbarr/perl-Convert-ASN1/pull/36
+---
+ t/00prim.t | 2 +-
+ t/01tag.t | 2 +-
+ t/02seq.t | 2 +-
+ t/03seqof.t | 2 +-
+ t/04opt.t | 2 +-
+ t/05time.t | 2 +-
+ t/06bigint.t | 2 +-
+ t/08set.t | 2 +-
+ t/09contr.t | 2 +-
+ t/10choice.t | 2 +-
+ t/11explicit.t | 2 +-
+ t/11indef.t | 2 +-
+ t/12der.t | 2 +-
+ t/13utf8.t | 2 +-
+ t/14any.t | 2 +-
+ t/15extseq.t | 2 +-
+ t/16extset.t | 2 +-
+ t/17extchoice.t | 2 +-
+ t/18tagdefault.t | 2 +-
+ t/99misc.t | 2 +-
+ t/x509.t | 2 +-
+ 21 files changed, 21 insertions(+), 21 deletions(-)
+
+diff --git a/t/00prim.t b/t/00prim.t
+index 904c9c6..e5468f7 100644
+--- a/t/00prim.t
++++ b/t/00prim.t
+@@ -8,7 +8,7 @@ use Convert::ASN1 qw(:all);
+
+ print "1..186\n";
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ ntest 1, 129, asn_tag(ASN_CONTEXT, 1);
+ ntest 2, 0x201f, asn_tag(ASN_UNIVERSAL, 32);
+diff --git a/t/01tag.t b/t/01tag.t
+index 40e28a0..0a44729 100644
+--- a/t/01tag.t
++++ b/t/01tag.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..21\n";
+
+diff --git a/t/02seq.t b/t/02seq.t
+index bc21712..4585195 100644
+--- a/t/02seq.t
++++ b/t/02seq.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..18\n";
+
+diff --git a/t/03seqof.t b/t/03seqof.t
+index 66683b6..9f85c48 100644
+--- a/t/03seqof.t
++++ b/t/03seqof.t
+@@ -4,7 +4,7 @@
+ # Test that the primitive operators are working
+ #
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ use Convert::ASN1;
+
+diff --git a/t/04opt.t b/t/04opt.t
+index 7f23fca..ba2f958 100644
+--- a/t/04opt.t
++++ b/t/04opt.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..16\n"; # This testcase needs more tests
+
+diff --git a/t/05time.t b/t/05time.t
+index f444e7f..082b4e7 100644
+--- a/t/05time.t
++++ b/t/05time.t
+@@ -10,7 +10,7 @@ use Convert::ASN1 qw(:all);
+
+ print "1..24\n";
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ my $t = 1;
+
+diff --git a/t/06bigint.t b/t/06bigint.t
+index f9aeba3..bde99f6 100644
+--- a/t/06bigint.t
++++ b/t/06bigint.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ $^W=0 if $] < 5.005; # BigInt in 5.004 has undef issues
+
+diff --git a/t/08set.t b/t/08set.t
+index b35a7ba..ee6af6e 100644
+--- a/t/08set.t
++++ b/t/08set.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..13\n";
+
+diff --git a/t/09contr.t b/t/09contr.t
+index 2213c7e..47cb280 100644
+--- a/t/09contr.t
++++ b/t/09contr.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..4\n";
+
+diff --git a/t/10choice.t b/t/10choice.t
+index 6ceeb6d..5e0a050 100644
+--- a/t/10choice.t
++++ b/t/10choice.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..10\n";
+
+diff --git a/t/11explicit.t b/t/11explicit.t
+index 7e24506..8c60493 100644
+--- a/t/11explicit.t
++++ b/t/11explicit.t
+@@ -1,6 +1,6 @@
+ #!/usr/local/bin/perl
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ use Convert::ASN1;
+
+diff --git a/t/11indef.t b/t/11indef.t
+index 7c3886d..4a33eec 100644
+--- a/t/11indef.t
++++ b/t/11indef.t
+@@ -4,7 +4,7 @@
+ # Test that indefinite length encodings can be decoded
+ #
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ use Convert::ASN1;
+ my @zz = ( 0, 0 );
+diff --git a/t/12der.t b/t/12der.t
+index b7d1b79..f2f9716 100644
+--- a/t/12der.t
++++ b/t/12der.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..18\n";
+
+diff --git a/t/13utf8.t b/t/13utf8.t
+index 1f62042..6fdb596 100644
+--- a/t/13utf8.t
++++ b/t/13utf8.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ if ($] < 5.007) {
+ print "1..0\n";
+diff --git a/t/14any.t b/t/14any.t
+index 4147764..05370ba 100644
+--- a/t/14any.t
++++ b/t/14any.t
+@@ -4,7 +4,7 @@
+ # Check whether the ANY DEFINED BY syntax is working
+ #
+
+-BEGIN { require 't/funcs.pl'}
++BEGIN { require './t/funcs.pl'}
+
+ use Convert::ASN1;
+
+diff --git a/t/15extseq.t b/t/15extseq.t
+index 6060793..2b98854 100644
+--- a/t/15extseq.t
++++ b/t/15extseq.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..27\n";
+
+diff --git a/t/16extset.t b/t/16extset.t
+index c57ac0c..cd2caa2 100644
+--- a/t/16extset.t
++++ b/t/16extset.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..27\n";
+
+diff --git a/t/17extchoice.t b/t/17extchoice.t
+index 66bd9c5..7528d72 100644
+--- a/t/17extchoice.t
++++ b/t/17extchoice.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..19\n";
+
+diff --git a/t/18tagdefault.t b/t/18tagdefault.t
+index 6a1fa3b..a589920 100644
+--- a/t/18tagdefault.t
++++ b/t/18tagdefault.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..25\n";
+
+diff --git a/t/99misc.t b/t/99misc.t
+index 4b67aba..c06bd8e 100644
+--- a/t/99misc.t
++++ b/t/99misc.t
+@@ -5,7 +5,7 @@
+ #
+
+ use Convert::ASN1;
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ print "1..2\n";
+
+diff --git a/t/x509.t b/t/x509.t
+index 3fd5ba0..0b9bfeb 100644
+--- a/t/x509.t
++++ b/t/x509.t
+@@ -2,7 +2,7 @@
+
+ print "1..26\n";
+
+-BEGIN { require 't/funcs.pl' }
++BEGIN { require './t/funcs.pl' }
+
+ use Convert::ASN1;
+
+--
+2.14.1
+
diff --git a/dev-perl/Convert-ASN1/metadata.xml b/dev-perl/Convert-ASN1/metadata.xml
new file mode 100644
index 000000000000..6e32a6554abd
--- /dev/null
+++ b/dev-perl/Convert-ASN1/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Convert-ASN1</remote-id>
+ <remote-id type="cpan-module">Convert::ASN1</remote-id>
+ </upstream>
+</pkgmetadata>