summaryrefslogtreecommitdiff
path: root/dev-perl/Class-Spiffy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-perl/Class-Spiffy
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-perl/Class-Spiffy')
-rw-r--r--dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild23
-rw-r--r--dev-perl/Class-Spiffy/Manifest4
-rw-r--r--dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch21
-rw-r--r--dev-perl/Class-Spiffy/metadata.xml1
4 files changed, 47 insertions, 2 deletions
diff --git a/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild b/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild
new file mode 100644
index 000000000000..901907ed1eac
--- /dev/null
+++ b/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=INGY
+DIST_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="Spiffy Perl Interface Framework For You"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15-no-dot-inc.patch"
+)
diff --git a/dev-perl/Class-Spiffy/Manifest b/dev-perl/Class-Spiffy/Manifest
index 92cf73542ecb..78a48b511c70 100644
--- a/dev-perl/Class-Spiffy/Manifest
+++ b/dev-perl/Class-Spiffy/Manifest
@@ -1,3 +1,5 @@
+AUX Class-Spiffy-0.15-no-dot-inc.patch 453 BLAKE2B 49a19b3af33c36012e729d71e3f0a6e8cf7380a8db277d2f4f67f31a14472fd7c01948ea2993d6e2bd6da2ef5cfbc0e95c05cc36a38132864b3e6a0c4b659797 SHA512 4a4f18aab9893ef4819ab72f0cdd2eb1127fe775807e10a9538e6ceac255d4881e15108e7b68642244ea0561bf56affee8826c1b763d907906e434cf7153d308
DIST Class-Spiffy-0.15.tar.gz 24683 BLAKE2B c2ec8568c9c16857790127757f781d060ebbae4cd8ca2712836e641e2fde3bdcf0a6dafe23ede3ba38e6021d643e2929fd4d75f463dc4e63e13feb7625ca6a57 SHA512 abd8c99fa401b3c472b35111174d525cf9b489a38117345ea06a89ea3788619425a9851c32e848a2d696aaf5e89eaa2fdf715807d587f654e187dbb6a6c1e770
EBUILD Class-Spiffy-0.150.0-r1.ebuild 507 BLAKE2B 0579081bd2092262b600d3eb3fe5fa64b54363a3cbede2dd9d24adb7db191d0f6f06639170cfef33a72bee549a1d4f82d3df22b9216c76dd1ae7811819e43b74 SHA512 5fc4caff72f3a20487a9b216828bccc7406bbfc2851d73996b1c4d5af71fa398f255d302f34083d2c6a99c1d722653f058577a0a699b76461facfb130d080216
-MISC metadata.xml 512 BLAKE2B c1c94e75a349091ac8d3b05c4e25b66b098d45ba8f7bfa8a24fc904716cdac916f85a63b9013520ed3b1eeaf819e12062d02b36960335f5fddd452f1a0c94921 SHA512 b3ea2c227edb28effce5b5e34b64bcb1e58ac519857a9411ca67c53f43af9628a18daa7ab2b531acbfe8398472158bc2c86a409ade3574ae5b0aab6afea914e2
+EBUILD Class-Spiffy-0.150.0-r2.ebuild 411 BLAKE2B a5bf8231f1db5f2cca40902cd767828674931ff165d70ffa84a6f56660b4a3c3dcd56d3198e0eb4e66bfae499b417076990cb2b34027a82356031e359acf22b3 SHA512 bb7414671af6270aa98fe49109c69178986737f7964645ed982fbadbe609efb1f2ea3b6ebefe9c98f74c40aefa1a6566d11e088583f3ab63304339c1e4130494
+MISC metadata.xml 463 BLAKE2B 44d648cbeb0f313affc34b4f75ae98e38ed034ca6fb81a9d6df4a1dfe347e1613c4b5f107b590c31f225cbc5176a9d6e4970b94462cf783d4c3b677234cb5103 SHA512 c1970b1014b908340c155efb6e42f4a5e30333c3df01ed65cd7d4575ac00192e8cae72583ea59c6817a3f79bec998020a7b0aaba96e1551e2b13233c672550f2
diff --git a/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch b/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch
new file mode 100644
index 000000000000..f94168fc24a7
--- /dev/null
+++ b/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 1c979a0223112986d4eb75578dc8c8eb24296c0f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 20 Jun 2020 10:51:32 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index a9195f4..db2bff9 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Class-Spiffy';
+--
+2.27.0
+
diff --git a/dev-perl/Class-Spiffy/metadata.xml b/dev-perl/Class-Spiffy/metadata.xml
index 327a43cdad08..5028c2227201 100644
--- a/dev-perl/Class-Spiffy/metadata.xml
+++ b/dev-perl/Class-Spiffy/metadata.xml
@@ -9,6 +9,5 @@
<remote-id type="cpan">Class-Spiffy</remote-id>
<remote-id type="cpan-module">Class::Spiffy</remote-id>
<remote-id type="cpan-module">Class::Spiffy::mixin</remote-id>
- <remote-id type="cpan-module">DB</remote-id>
</upstream>
</pkgmetadata>