summaryrefslogtreecommitdiff
path: root/dev-perl/Class-Singleton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Class-Singleton
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Class-Singleton')
-rw-r--r--dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild20
-rw-r--r--dev-perl/Class-Singleton/Manifest3
-rw-r--r--dev-perl/Class-Singleton/metadata.xml12
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild b/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild
new file mode 100644
index 000000000000..0a2cf1259596
--- /dev/null
+++ b/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.5
+inherit perl-module
+
+DESCRIPTION="Implementation of a Singleton class"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Class-Singleton/Manifest b/dev-perl/Class-Singleton/Manifest
new file mode 100644
index 000000000000..0b5cc2cb53f1
--- /dev/null
+++ b/dev-perl/Class-Singleton/Manifest
@@ -0,0 +1,3 @@
+DIST Class-Singleton-1.5.tar.gz 7785 BLAKE2B 98bc10c6fda65abe6958360c780826bd76597cc597f8d1910cddf309c04eb3228d4ce8f5f03029a3a99a464eb158de69e167e5e9efc0c0f6d4f3c60938be2444 SHA512 f061a8b92d5f65e4fbcd14ef36ff1216f84443f487de34c98f7d08d6d18148f156c0cbd6249e75ac448c17547d1172dbda8b670a8e7573d3581c9c1196eb4804
+EBUILD Class-Singleton-1.500.0.ebuild 476 BLAKE2B 95a8ed76c6b4ae3930410674f7eb9e6410021b04f5b2a5554f04c8f88f2ac41a18953ecc511bae4a7fef5074600b5428938936d89171103e75b753b8d905460d SHA512 51d8aabc19c9ee290fff3c0dcb7262927ae0045f53ee673e963fc988fb0342eca509d042bc53851aaa8b9d8bb8eb671cd4a9cf263db8226c12e6c3f6587f1006
+MISC metadata.xml 402 BLAKE2B 448b53179712f0a6f1ca4eab049c9f531b22f178e8a9ae2d9d9ce94cf7c5dc467b51a71a5f1234f0bd7fdd0d6bc480512d5a9e4291c98f7cd82ae395b4143ff9 SHA512 b2baa8b23ef41d09974517a93429563892d0c9b1fa0295253c936066f5256b9ee3fd4abc8a2458e20a2011c05ede9643899a8c9ae876c679f50ead08db33ac54
diff --git a/dev-perl/Class-Singleton/metadata.xml b/dev-perl/Class-Singleton/metadata.xml
new file mode 100644
index 000000000000..3a564b1ad78f
--- /dev/null
+++ b/dev-perl/Class-Singleton/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Class-Singleton</remote-id>
+ <remote-id type="cpan-module">Class::Singleton</remote-id>
+ </upstream>
+</pkgmetadata>