summaryrefslogtreecommitdiff
path: root/dev-perl/Cairo/Cairo-1.109.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-perl/Cairo/Cairo-1.109.0.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-perl/Cairo/Cairo-1.109.0.ebuild')
-rw-r--r--dev-perl/Cairo/Cairo-1.109.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.109.0.ebuild b/dev-perl/Cairo/Cairo-1.109.0.ebuild
new file mode 100644
index 000000000000..d8aff7bd7da4
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.109.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.109
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.107-fatal-exit.patch"
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}