summaryrefslogtreecommitdiff
path: root/dev-perl/Cache-Simple-TimedExpiry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-perl/Cache-Simple-TimedExpiry
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-perl/Cache-Simple-TimedExpiry')
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild18
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/Manifest2
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch21
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild
new file mode 100644
index 000000000000..0a7d7fff724f
--- /dev/null
+++ b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JESSE
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="A lightweight cache with timed expiration"
+# License note: no formal upstream license declaration
+# only an assumed one from 'license => perl' in Makefile.PL
+# Bug: https://bugs.gentoo.org/722854
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.27-no-dot-inc.patch"
+)
diff --git a/dev-perl/Cache-Simple-TimedExpiry/Manifest b/dev-perl/Cache-Simple-TimedExpiry/Manifest
index fcfe4bb5de50..b4870b9fa03c 100644
--- a/dev-perl/Cache-Simple-TimedExpiry/Manifest
+++ b/dev-perl/Cache-Simple-TimedExpiry/Manifest
@@ -1,3 +1,5 @@
+AUX Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch 493 BLAKE2B 6ca4bd69bb9f27bc42316b5730d320858ced4d5d76a2f4c04dedaf96bf73ab36042f985079624e70f18c1874cb23a7bc0284b5645bbc3ef7fa4400e71451f2b1 SHA512 bb0b9794a50198d6020458d051d70199b491fa65f5d4d939d9b5fc12fd16388e7ff744b82ea190a4e9f422361378b2f458e2d8d4da877f3f71785b8be9e3577a
DIST Cache-Simple-TimedExpiry-0.27.tar.gz 13110 BLAKE2B 7ddaf8354f376c2a5744921114dd86653bed1c26f69797c49c309d3bbe6b928658084c421ef259dd6ca6acb62e30b13a9eb80e4931922b4ee5137afb02af7d33 SHA512 80317eab341d307ad9d0fd76a92726a2d963deb9a5397ceb1a1383f0f8c5ca07e8553307d15f5a23f0c1b0a2765c1bba83bf1cdfc963e9e3271399c2d12cd79f
EBUILD Cache-Simple-TimedExpiry-0.270.0-r1.ebuild 505 BLAKE2B 86bfa41f042c506384beb8119205c595c5402e4dae79ce2e9f862961ba4c77cd5d28aec1e523169f5cb6cb5801cc0844dbc090c250c19788b2702273c3a9af07 SHA512 a15caffe19f305e0077de6f6b6bcd92370ce85a2c4015c93da01999d776d316b26f78347270af79a478fa5d9b4a7b715c549be8d427dcfd88fde148ef19ad27b
+EBUILD Cache-Simple-TimedExpiry-0.270.0-r2.ebuild 497 BLAKE2B 26cda3f12e660970dff0a52c469bf8797046a12f9323c61992ed7403c397acec05a3cfbe73a2147fe254431f3d0784d914eb2024a8c9bd113249c52b59b4690c SHA512 042f00bd27d9ed0058c3f1b2aa36e6c5245c6f175626df219144977b0141ee049d352946bfc257c83afb0f9134f91bc4fb53dfd8aebd8e27b72f1cc8f2e961ab
MISC metadata.xml 421 BLAKE2B a7fb161362e58be5eac83917134b5415ab85bb78121071b90f1443385e7205aff3f35ea2e09d9460ac39d07229e432d7726ce4e627389de4082a5d35ac6b32f3 SHA512 509a51bceae181f1eb565538ffe653a32c348e95e39bf567116b66c2ad1ee83432f8b2419e8275343abda6182c7a8b907e7457151a707aca5eaba314c65e1ae3
diff --git a/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch b/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch
new file mode 100644
index 000000000000..ba1d06d93229
--- /dev/null
+++ b/dev-perl/Cache-Simple-TimedExpiry/files/Cache-Simple-TimedExpiry-0.27-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 5b80a167c8241dd309f7532072deda6c4d8ae6ef Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 14 May 2020 01:31:25 +1200
+Subject: Include '.' in @INC on Perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 2290ec1..53c96c2 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name ('Cache-Simple-TimedExpiry');
+--
+2.26.2
+