summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Compile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
commitb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (patch)
tree7d427f015930068f8d06e8f5aa622635ac3b61ca /dev-perl/CGI-Compile
parent4b61f038fc5ecca26609a997fcc662c7cf9e0498 (diff)
gentoo auto-resync : 14:08:2023 - 12:12:48
Diffstat (limited to 'dev-perl/CGI-Compile')
-rw-r--r--dev-perl/CGI-Compile/CGI-Compile-0.260.0.ebuild36
-rw-r--r--dev-perl/CGI-Compile/Manifest2
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/CGI-Compile/CGI-Compile-0.260.0.ebuild b/dev-perl/CGI-Compile/CGI-Compile-0.260.0.ebuild
new file mode 100644
index 000000000000..96d62dd02132
--- /dev/null
+++ b/dev-perl/CGI-Compile/CGI-Compile-0.260.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RKITOVER
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Compile .cgi scripts to a code reference like ModPerl::Registry"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-perl/File-pushd
+ dev-perl/Sub-Name
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/CGI
+ dev-perl/Capture-Tiny
+ dev-perl/Filter
+ dev-perl/Sub-Identify
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ dev-perl/Try-Tiny
+ )
+"
+
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+)
diff --git a/dev-perl/CGI-Compile/Manifest b/dev-perl/CGI-Compile/Manifest
index fa04e64b6462..a35dfc639af9 100644
--- a/dev-perl/CGI-Compile/Manifest
+++ b/dev-perl/CGI-Compile/Manifest
@@ -1,3 +1,5 @@
DIST CGI-Compile-0.25.tar.gz 22479 BLAKE2B e321ec4d0ecee66f0efb8c89f322a036b135449938840aa0cfe0bf714bb2e8a0ad2d8d8f4397b00aa9e86d03190cb9429aaa8e0420528f233ddc9c066f768859 SHA512 760481c3868592d7dbeab10125ee76c608ea6a705926597c4219dc128c3ffb642ff39e6ddf72aa916c183fb6baf3671e687ea9a41b86987a60fc076d304d6fe6
+DIST CGI-Compile-0.26.tar.gz 23151 BLAKE2B c343b32e31815888f4e11bf4f00370ebf1ed36076ace5d8266a18b16c4c31e088c7ba2d639ae3b1e71b85a60190a56c0e668a153b8874129c598eae8ca04aea3 SHA512 d4fe9f6a0a68e231e3cb4de2d1626084d1e9c1e8df6a9025393c5623a85604374ede97d6deee520141759e438105fcfabbd24c5559b97695f5eda32cb29f9da9
EBUILD CGI-Compile-0.250.0.ebuild 758 BLAKE2B ef6582bf15dc97ae81530082a87cb4e325afdd0f9dd451125af3a869add41077bf75a49756fe6c6d99d5d2b0c2665cb2ac0b00408cc29cc414d8fd157a598dd9 SHA512 60b652c3ac0f0276e2c54633ac9c59ffd0f0a503e2fd210946581d768d5295153519fa6b147d44b8d3179ee6a4675eeffb7f896a7cc445bae7f01b4f03825c51
+EBUILD CGI-Compile-0.260.0.ebuild 691 BLAKE2B 01e26e824dbbc7c64981ef1bbd6960539db762641b9c0a3cfa6053b10ff13123ef0e1ea8b79d21e8c6f56adafc505d429a5d30a47ba2d1a74076f25004821215 SHA512 2257095daa57f654252c4cba03a19d04e295ebd64109fa5f39c88a39b63d3c7726428c9c7b0ab7a73dfa3cd7f9ce8827bc6881f2682332d2e1f2a90adaa26863
MISC metadata.xml 395 BLAKE2B c13ed4c51fccab9ee326f71b530c3a680e02f599c46e33eb65bb5a1dab388dd7af60e1997df741002cd969a35a353ff73db7e1f720e50e7ca261521e162cb557 SHA512 94e8e07e80ef77ca6da533576ddcd3b0a53189b9692094c0d728d7fb7bdd1f8ae15ace9631f78c98afd314e590f521e4434f1395cdd4fcd1e07acdb5c40eef24