summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Application-Server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/CGI-Application-Server
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/CGI-Application-Server')
-rw-r--r--dev-perl/CGI-Application-Server/CGI-Application-Server-0.63.0.ebuild36
-rw-r--r--dev-perl/CGI-Application-Server/Manifest3
-rw-r--r--dev-perl/CGI-Application-Server/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/CGI-Application-Server/CGI-Application-Server-0.63.0.ebuild b/dev-perl/CGI-Application-Server/CGI-Application-Server-0.63.0.ebuild
new file mode 100644
index 000000000000..3fa47eb1cc15
--- /dev/null
+++ b/dev-perl/CGI-Application-Server/CGI-Application-Server-0.63.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.063
+inherit perl-module
+
+DESCRIPTION="a simple HTTP server for developing with CGI::Application"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/CGI
+ >=dev-perl/CGI-Application-4.210.0
+ >=virtual/perl-Carp-0.10.0
+ dev-perl/HTTP-Message
+ >=dev-perl/HTTP-Server-Simple-0.180.0
+ >=dev-perl/HTTP-Server-Simple-Static-0.20.0
+ >=virtual/perl-Scalar-List-Utils-1.180.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/CGI-Application-Dispatch
+ dev-perl/CGI-Application-Plugin-Redirect
+ virtual/perl-File-Temp
+ dev-perl/Test-Exception
+ dev-perl/Test-HTTP-Server-Simple
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-WWW-Mechanize
+ )
+"
diff --git a/dev-perl/CGI-Application-Server/Manifest b/dev-perl/CGI-Application-Server/Manifest
new file mode 100644
index 000000000000..40eccdc6f576
--- /dev/null
+++ b/dev-perl/CGI-Application-Server/Manifest
@@ -0,0 +1,3 @@
+DIST CGI-Application-Server-0.063.tar.gz 18861 BLAKE2B fb05157557c861fb18f73530dad79d428a24168cb916b88cf5f6d3da875bf8b2e7ac290c9d633b993127cfd4489505af8eee58c36a970bd80f99121f5431f6fa SHA512 811577981ea5025ff7e32661b89fee1277a4ed821014114cb9359a628943302fd1654965852634f6aa29c8f4a333d015ef4276e66c9fb1be7512edc927a3c14f
+EBUILD CGI-Application-Server-0.63.0.ebuild 857 BLAKE2B f883fc5f6ab996f1e8ec006226d212b66b7866c55bfa94215338cd90f49005b7d6d97cfcfa29d1737795ffd99f654803fd91f6f3828e35d1d35c1c2dc5b73c13 SHA512 980660e451307377fbfa1819a809825cf7e5b95e9d1c049e14e69fb83b1820e37ecf60ebc4defc359c32407f2ed3fee9d5bb2e5f31b288e25b0f3aebba31df44
+MISC metadata.xml 417 BLAKE2B 011e82f1654e54e4a774937c4720d807ea747899921f0428d7aad45ed59a3164ccf3c53060c284784d402d8887276a11dec231166ffe5be29baaea1b87436f6e SHA512 6ec2b4d53afda70e6b541e8afedcfcdff7ae261e7d954cfad31d3a0fb9c03c570aa4a175e45346d97cc66de585a90b9ed3a43df537efa4fafde8e63ae45b43e7
diff --git a/dev-perl/CGI-Application-Server/metadata.xml b/dev-perl/CGI-Application-Server/metadata.xml
new file mode 100644
index 000000000000..ad647b84df64
--- /dev/null
+++ b/dev-perl/CGI-Application-Server/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Application-Server</remote-id>
+ <remote-id type="cpan-module">CGI::Application::Server</remote-id>
+ </upstream>
+</pkgmetadata>