summaryrefslogtreecommitdiff
path: root/dev-perl/Bio-SamTools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Bio-SamTools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Bio-SamTools')
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild33
-rw-r--r--dev-perl/Bio-SamTools/Manifest4
-rw-r--r--dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch88
-rw-r--r--dev-perl/Bio-SamTools/metadata.xml32
4 files changed, 157 insertions, 0 deletions
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
new file mode 100644
index 000000000000..1147cec5a486
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=1.43
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Read SAM/BAM database files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="|| ( Apache-2.0 Artistic-2 GPL-1+ )"
+
+RDEPEND="
+ >=sci-biology/bioperl-1.6.9
+ sci-biology/samtools:0.1-legacy=
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.420.0
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.430.0-legacy.patch
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
diff --git a/dev-perl/Bio-SamTools/Manifest b/dev-perl/Bio-SamTools/Manifest
new file mode 100644
index 000000000000..9130d1cf0d4e
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Manifest
@@ -0,0 +1,4 @@
+AUX Bio-SamTools-1.430.0-legacy.patch 2466 BLAKE2B ab4a384031f4f2b333700e9ddf62d7a8293f88c0390b8f151a6b0657f4f59613f1e33d259f9b575fb8348593dfdc408e4d6168ecba3c3863a856f3ef6abefa9f SHA512 3e886216a966144aa69aa86d3ffa28ee8f9aadec84f760259aad9fcdc09ca69499655e8c3d81a5b39d79fd503f14e0159bdf2422d66458f1e9095b2fb05da26a
+DIST Bio-SamTools-1.43.tar.gz 340833 BLAKE2B 2b488667b86ef1bedb7cf74dfdcb3abc0302d9f309c1fc3077682bb400c8307f3b7d8fb1a9015a26f9a17f9e9955845d160512aa3273c368b720fe51b4392458 SHA512 cd5bc6213c093f5105399c95278803afcc537bb3d191686cda0193b82fda2580749bf7533791899939a78963fcc0d6b36eabe9c309c9c6816a9849e3c892c41b
+EBUILD Bio-SamTools-1.430.0.ebuild 591 BLAKE2B d92daf9d86f1d8a4b60257fd810d012794d41e7082555a89b1fa66f2f2bb65b2585a27d68684d2dd1820dda214905868c752bbcbf3083e32d1797848cfaae4cc SHA512 fe282e0404be9a758e1f42ec9d12ae1dd935aa0f9fca8d07e07f55ae6453b2c615868de859b4e5af9f2195c18b988f0ac8132db0c8c0a880843178bce041b221
+MISC metadata.xml 1642 BLAKE2B 8e00b2305f870d0007a22f366376d77d359df2ab54d279da2c7b791da320f72e7d110956251c3adcddaf8b4b318110b5ff4b6cde4a6cd359cbb403f666c7de93 SHA512 d518abd6c3f99c370ce401f7fce792b2d55d29fc2baccb54f8a32f2e2c385acf3dd7f31f3c3fc0764fb3b754e4bd3378eef0002a0e4d48b2ae2a116c85379c50
diff --git a/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch
new file mode 100644
index 000000000000..8464f06a2f01
--- /dev/null
+++ b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch
@@ -0,0 +1,88 @@
+From 74b38ded97f7a1940c3a37b9aec9b3287a3a78bd Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 10 Sep 2017 13:33:32 +1200
+Subject: Fix linking/compiling for bam-0.1-legacy
+
+---
+ Build.PL | 6 +++---
+ c_bin/bam2bedgraph.c | 2 +-
+ c_bin/makefile | 6 +++---
+ lib/Bio/DB/Sam.xs | 6 +++---
+ 4 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 685815f..2611759 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -4,8 +4,8 @@ use strict;
+ use Module::Build;
+ use Module::Load::Conditional qw(can_load);
+
+-my $HeaderFile = "bam.h";
+-my $LibFile = "libbam.a";
++my $HeaderFile = "bam-0.1-legacy/bam.h";
++my $LibFile = "libbam-0.1-legacy.so";
+ my $ReadLine;
+
+ my ($sam_include,$sam_lib) = find_sam(); # may exit with error here
+@@ -39,7 +39,7 @@ my $build = $class->new(
+ dist_abstract => 'Perl interface to SamTools library for DNA sequencing',
+ license => 'perl',
+ include_dirs => [$sam_include],
+- extra_linker_flags => ["-L$sam_lib",'-lbam','-lpthread','-lz'],
++ extra_linker_flags => ["-L$sam_lib",'-lbam-0.1-legacy','-lpthread','-lz'],
+
+ extra_compiler_flags=>[
+
+diff --git a/c_bin/bam2bedgraph.c b/c_bin/bam2bedgraph.c
+index 298e9a8..91218fa 100644
+--- a/c_bin/bam2bedgraph.c
++++ b/c_bin/bam2bedgraph.c
+@@ -1,5 +1,5 @@
+ #include <stdio.h>
+-#include "sam.h"
++#include "bam-0.1-legacy/sam.h"
+
+ typedef struct {
+ uint32_t ltid;
+diff --git a/c_bin/makefile b/c_bin/makefile
+index 9aef917..0abbb4c 100644
+--- a/c_bin/makefile
++++ b/c_bin/makefile
+@@ -1,5 +1,5 @@
+-CC= gcc
+-CFLAGS= -g -Wall -O2 -fPIC
++CC?= gcc
++CFLAGS?= -g -Wall -O2 -fPIC
+ DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1
+ INCLUDES=
+ LIBPATH=
+@@ -14,7 +14,7 @@ PROG= bam2bedgraph
+ all:$(PROG)
+
+ bam2bedgraph: bam2bedgraph.o
+- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam -lpthread -lm -lz
++ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam-0.1-legacy -lpthread -lm -lz
+
+ clean:
+ rm -f *.o $(PROG)
+diff --git a/lib/Bio/DB/Sam.xs b/lib/Bio/DB/Sam.xs
+index 023f655..86410fb 100644
+--- a/lib/Bio/DB/Sam.xs
++++ b/lib/Bio/DB/Sam.xs
+@@ -25,9 +25,9 @@
+
+ #include <unistd.h>
+ #include <math.h>
+-#include "bam.h"
+-#include "khash.h"
+-#include "faidx.h"
++#include "bam-0.1-legacy/bam.h"
++#include "bam-0.1-legacy/khash.h"
++#include "bam-0.1-legacy/faidx.h"
+
+ /* stolen from bam_aux.c */
+ #define MAX_REGION 1<<29
+--
+2.14.1
+
diff --git a/dev-perl/Bio-SamTools/metadata.xml b/dev-perl/Bio-SamTools/metadata.xml
new file mode 100644
index 000000000000..268cc35b8f8c
--- /dev/null
+++ b/dev-perl/Bio-SamTools/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Bio-SamTools</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::AlignWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Alignment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::FetchIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Pileup</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::PileupWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Query</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::ReadIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::SplitAlignmentPart</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Target</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Constants</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Fai</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::SamToGBrowse</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Segment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Segment::Iterator</remote-id>
+ <remote-id type="cpan-module">Bio::SeqFeature::Coverage</remote-id>
+ </upstream>
+</pkgmetadata>