summaryrefslogtreecommitdiff
path: root/dev-perl/Bio-Das
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Bio-Das
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Bio-Das')
-rw-r--r--dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild93
-rw-r--r--dev-perl/Bio-Das/Manifest3
-rw-r--r--dev-perl/Bio-Das/metadata.xml41
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild b/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
new file mode 100644
index 000000000000..fbd25fa1e003
--- /dev/null
+++ b/dev-perl/Bio-Das/Bio-Das-1.170.0-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=1.17
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Interface to Distributed Annotation System"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/perl-IO-Compress-1.0
+ sci-biology/bioperl
+ >=dev-perl/HTML-Parser-3
+ >=dev-perl/libwww-perl-5
+ >=virtual/perl-MIME-Base64-2.12"
+RDEPEND="${DEPEND}"
+
+optdep_notice() {
+ local i
+ elog "This package has several modules which may require additional dependencies"
+ elog "to use. However, it is up to you to install them separately if you need this"
+ elog "optional functionality:"
+ elog
+ i="$(if has_version 'dev-perl/CGI'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/CGI"
+ elog " - Running a reference DAS server driven by an AGP File via"
+ elog " Bio::Das::AGPServer::Daemon"
+
+ if use test; then
+ elog
+ elog "This module will perform additional tests if these dependencies are"
+ elog "pre-installed"
+ fi
+}
+src_test() {
+ local MODULES=(
+ "Bio::Das ${DIST_VERSION}"
+ "Bio::Das::AGPServer::Config 1.0"
+ "Bio::Das::AGPServer::Parser"
+ "Bio::Das::AGPServer::SQLStorage"
+ "Bio::Das::AGPServer::SQLStorage::CSV::DB"
+ "Bio::Das::AGPServer::SQLStorage::MySQL::DB"
+ "Bio::Das::DSN"
+ "Bio::Das::Feature 0.91"
+ "Bio::Das::FeatureIterator 0.01"
+ "Bio::Das::HTTP::Fetch 1.11"
+ "Bio::Das::Map 1.01"
+ "Bio::Das::Request"
+ "Bio::Das::Request::Dnas"
+ "Bio::Das::Request::Dsn"
+ "Bio::Das::Request::Entry_points"
+ "Bio::Das::Request::Feature2Segments"
+ "Bio::Das::Request::Features"
+ "Bio::Das::Request::Sequences"
+ "Bio::Das::Request::Stylesheet"
+ "Bio::Das::Request::Types"
+ "Bio::Das::Segment 0.91"
+ "Bio::Das::Stylesheet 1.00"
+ "Bio::Das::Type"
+ "Bio::Das::TypeHandler"
+ "Bio::Das::Util 0.01"
+ )
+ has_version dev-perl/CGI && MODULES+=(
+ "Bio::Das::AGPServer::Daemon"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if has "network" ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ perl-module_src_test
+ else
+ ewarn "Functional parts of these tests require network access"
+ ewarn "For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Bio-Das"
+ fi
+}
diff --git a/dev-perl/Bio-Das/Manifest b/dev-perl/Bio-Das/Manifest
new file mode 100644
index 000000000000..94388e0a2336
--- /dev/null
+++ b/dev-perl/Bio-Das/Manifest
@@ -0,0 +1,3 @@
+DIST Bio-Das-1.17.tar.gz 105270 BLAKE2B 0203891fe6f4a0847040f43817d9e0a2eb12dd76eebbab4616f2d9a16c35aa6fa3632071e66a135a49e2a308c30ec971eefabb11371e0abfbe6293fffb4a7b55 SHA512 c44d3571f4f4c777d8315db19cf704cc5ff4d48a8edae8b9a43f7d47df709bee476d810ce1e96bec5ccf44b7cf3373f79b892c0a1d17715f19ffdff81558292e
+EBUILD Bio-Das-1.170.0-r2.ebuild 2557 BLAKE2B 0348a208fea7df69883a3e701e67026c397e60bd88f817cbc5aca01ddd6e96f69a9689b4a4b0ee925437e607c8ce99535840869ffcd2ab43de89a90ab4926bae SHA512 93a97d39620eb67fa9cb1d1f86a65c52a86640440ac0d4de3d397f225e9af243d2b60b4a313c4252a280d3ca54e893225bbae835461fb70c41e3fb894b6bcdae
+MISC metadata.xml 2286 BLAKE2B b3ac90af3f6f506ea2753eae897ca91f3a826455f4959d506e6594e67dd5e42f2ff8db207d058a51659ff717ce4cd55fd2f5b775337e5bf9a8339021a59d127f SHA512 0806e77015426b7bf32f9021e00dfc7f2b04f255382e7973f5283072d9bb92d81cb6611c438c5398b77d0b0fc128fc50e9b5a2e165d0e09ed0b056b3dc172e12
diff --git a/dev-perl/Bio-Das/metadata.xml b/dev-perl/Bio-Das/metadata.xml
new file mode 100644
index 000000000000..0fe7c98c9974
--- /dev/null
+++ b/dev-perl/Bio-Das/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Bio-Das</remote-id>
+ <remote-id type="cpan-module">Bio::Das</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::Config</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::Daemon</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::Parser</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::SQLStorage</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::SQLStorage::CSV::DB</remote-id>
+ <remote-id type="cpan-module">Bio::Das::AGPServer::SQLStorage::MySQL::DB</remote-id>
+ <remote-id type="cpan-module">Bio::Das::DSN</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Feature</remote-id>
+ <remote-id type="cpan-module">Bio::Das::FeatureIterator</remote-id>
+ <remote-id type="cpan-module">Bio::Das::HTTP::Fetch</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Map</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Dnas</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Dsn</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Entry_points</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Feature2Segments</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Features</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Sequences</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Stylesheet</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Request::Types</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Segment</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Stylesheet</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Type</remote-id>
+ <remote-id type="cpan-module">Bio::Das::TypeHandler</remote-id>
+ <remote-id type="cpan-module">Bio::Das::Util</remote-id>
+ </upstream>
+</pkgmetadata>