summaryrefslogtreecommitdiff
path: root/dev-perl/Bio-DB-HTS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-perl/Bio-DB-HTS
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-perl/Bio-DB-HTS')
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild30
-rw-r--r--dev-perl/Bio-DB-HTS/Manifest4
-rw-r--r--dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch29
-rw-r--r--dev-perl/Bio-DB-HTS/metadata.xml17
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild
new file mode 100644
index 000000000000..02c38cd34f33
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=2.10
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.10-build_search_for_so.patch"
+)
+
+src_configure() {
+ local myconf="--htslib=${EPREFIX}/usr"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Bio-DB-HTS/Manifest b/dev-perl/Bio-DB-HTS/Manifest
new file mode 100644
index 000000000000..850f18da3d89
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Manifest
@@ -0,0 +1,4 @@
+AUX 2.10-build_search_for_so.patch 1169 BLAKE2B 53e0eaf90d50cc3571a55083db1e48a908c9d05fda46d3e3fb1c61f0c426ea1dc8a263512adcf7ab58eed8b7f217e50db961e96483b3599afc4077c22e64d81c SHA512 39ee373385be49f143c20d0cb6794debd008affe1101f991cc924a163853e2884508753c811f506bcd97d7545599edb735efff64dfc36269d0964c15a70389b7
+DIST Bio-DB-HTS-2.10.tar.gz 5245650 BLAKE2B a52d9b1e19d5920d61dd365eacfd1a40726500e25a3ab516df5a1d59a7a9d79ce02db7a2145801b6af5df2c41c95e80b49a39db83d27fd7ff3cf88ba0e6a328d SHA512 4e7c01022d9edf48a0e0dcffcbccf34812f236d1b581760ac115c323de5779fb6212eb4ad7d1953811930a6137cc8f5f59028c73d645d1ca5fb6118dd846ad57
+EBUILD Bio-DB-HTS-2.10.ebuild 543 BLAKE2B 95d0cdb4cff8ead7a2427ea3663d61ba7a18582eb925effc84e0072f5a35b87d5082e30a386fa0d1c3d5a8bb2ef4584296ffa19b867c59c8b5f8f0da92666727 SHA512 5c22659c738f9e529a77723eb8f458c5a0bb1ca45be3ba107acee973faec10af1e32a0aa1a1402cf589d7cd8acc827e414429f3ba6315801d814f3c881139a3b
+MISC metadata.xml 555 BLAKE2B fe8d2547a6d959f24231c15b5803e8e71dd94ac0d865dd0a53dff97c62b39db8ff40f845f7d4a48cd4dc19d31c044e06ca8394d745a79c532fc61e96a66dab3f SHA512 9e03a79d88ca855783562bd5d3b9a4f71698c2caae43c009bbcf312bd5810d362842cb4e834291b08a5231785f59fc5598edca6868716d5a7487716d10acac39
diff --git a/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch b/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch
new file mode 100644
index 000000000000..b3d11bbbe7aa
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch
@@ -0,0 +1,29 @@
+--- a/Build.PL
++++ b/Build.PL
+@@ -125,7 +125,7 @@
+
+ my $hts_lib = "$root";
+ my $hts_include = "$root/htslib";
+- if (-f "$hts_lib/libhts.a" && -f "$hts_include/hts.h") {
++ if ((-f "$hts_lib/libhts.so" || -f "$hts_lib/libhts.a") && -f "$hts_include/hts.h") {
+ $self->config_data('hts_lib' => $hts_lib);
+ $self->config_data('hts_include' => $hts_include);
+ return 1;
+@@ -145,7 +145,7 @@
+
+ my $hts_lib = "$root/lib";
+ my $hts_include = "$root/include/htslib";
+- if (-f "$hts_lib/libhts.a" && -f "$hts_include/hts.h") {
++ if ((-f "$hts_lib/libhts.so" || -f "$hts_lib/libhts.a") && -f "$hts_include/hts.h") {
+ $self->config_data('hts_lib' => $hts_lib);
+ $self->config_data('hts_include' => $hts_include);
+ return 1;
+@@ -164,7 +164,7 @@
+ This module requires htslib (http://htslib/org)
+ Install it if you have not done so already.
+
+-This script will attempt to locate htslib by looking for hts.h and libhts.a in:
++This script will attempt to locate htslib by looking for hts.h and libhts.so/libhts.a in:
+
+ 1. --htslib command line argument
+ 2. HTSLIB_DIR environment variable
diff --git a/dev-perl/Bio-DB-HTS/metadata.xml b/dev-perl/Bio-DB-HTS/metadata.xml
new file mode 100644
index 000000000000..95abbb699ad4
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ensembl/Bio-DB-HTS</remote-id>
+ <remote-id type="cpan">Bio-DB-HTS</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS</remote-id>
+ </upstream>
+</pkgmetadata>