summaryrefslogtreecommitdiff
path: root/dev-perl/Bio-DB-HTS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Bio-DB-HTS
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Bio-DB-HTS')
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild31
-rw-r--r--dev-perl/Bio-DB-HTS/Manifest4
-rw-r--r--dev-perl/Bio-DB-HTS/files/2.11-build_split_htslib_opts.patch65
-rw-r--r--dev-perl/Bio-DB-HTS/metadata.xml17
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild
new file mode 100644
index 000000000000..e5c23d67da05
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=2.11
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sci-biology/bioperl
+ sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.11-build_split_htslib_opts.patch"
+)
+
+src_configure() {
+ local myconf="--htslib-includedir=${EPREFIX}/usr/include/htslib --htslib-libdir=${EPREFIX}/usr/$(get_libdir)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Bio-DB-HTS/Manifest b/dev-perl/Bio-DB-HTS/Manifest
new file mode 100644
index 000000000000..c82f5a3486d0
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Manifest
@@ -0,0 +1,4 @@
+AUX 2.11-build_split_htslib_opts.patch 2453 BLAKE2B 19f99d0a56db7c4778bc478cd952062e8095997fe9028b6c7e251e2391f9f074774bdaec6db7c610488a921a73abf83edeee2b5f5a5185d4bb422c5dff6a8634 SHA512 4770ebb1bf8fdc3e51f4a020db1c45befa64478bd2cf2d77397e5e7ac09d34d17457ecd2be2fd53062ada48f579621cb959c245493906b9c04367142b27a2fa8
+DIST Bio-DB-HTS-2.11.tar.gz 5250814 BLAKE2B d77ccacebf339a33ab106b997139cdbf79f6c28269a832305e660b28370aca82b4c9824773acdbf8f59b18dd61f40346a9870578dba7b5b989b0f3bc9ad14b35 SHA512 114d90fe92b684250183b45b4d23d2dd45ecdcb2fa54f7b1c311ed668d8e87953adb861f709a0a48ff2b873ce777b21bc3b557bafa0df216b9a71b59facff6fd
+EBUILD Bio-DB-HTS-2.11.ebuild 639 BLAKE2B 9761dddc9216bc11e3a167d067b6d33fc4a8f7b7aeaf690a02c3816620bc10fd9a6d306def470dd056de0958538433a784a62328f48aa4447b7c437460881c44 SHA512 789ad5439ac7014585b61ac11790fff6c6786fb5c249a7e895fcc6c7a988e4f61e097d98883cb36203e0ab030fc874f38dfbd969e0a3b6c9c6a61a33b90f3e9e
+MISC metadata.xml 555 BLAKE2B fe8d2547a6d959f24231c15b5803e8e71dd94ac0d865dd0a53dff97c62b39db8ff40f845f7d4a48cd4dc19d31c044e06ca8394d745a79c532fc61e96a66dab3f SHA512 9e03a79d88ca855783562bd5d3b9a4f71698c2caae43c009bbcf312bd5810d362842cb4e834291b08a5231785f59fc5598edca6868716d5a7487716d10acac39
diff --git a/dev-perl/Bio-DB-HTS/files/2.11-build_split_htslib_opts.patch b/dev-perl/Bio-DB-HTS/files/2.11-build_split_htslib_opts.patch
new file mode 100644
index 000000000000..727c500360d1
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/files/2.11-build_split_htslib_opts.patch
@@ -0,0 +1,65 @@
+diff --git a/Build.PL b/Build.PL
+index 0d684b7..87a223b 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -68,7 +68,15 @@ sub find_hts {
+ # If either of these are set, we expect to find the htslib files there:
+ # (They're explicitly set by the user, so we shouldn't fall back to
+ # finding another copy somewhere else.)
+- if (my $dir = $self->args('htslib')) {
++ my $incdir = $self->args('htslib-includedir');
++ my $libdir = $self->args('htslib-libdir');
++ if ($incdir && $libdir) {
++ return 1 if $self->find_hts_in_split_install_dirs($incdir, $libdir);
++ $self->die_hts_not_found(
++ "--htslib-includedir '$incdir' or --htslib-libdir '$libdir' command line parameters do not contain expected files\n"
++ );
++ }
++ elsif (my $dir = $self->args('htslib')) {
+ return 1 if $self->find_hts_in_build_dir($dir);
+ return 1 if $self->find_hts_in_install_dir($dir);
+ $self->die_hts_not_found(
+@@ -158,6 +166,23 @@ sub find_hts_in_install_dir {
+ }
+ }
+
++sub find_hts_in_split_install_dirs {
++ my ($self, $hts_include, $hts_lib) = @_;
++
++ chomp($hts_lib);
++ chomp($hts_include);
++ $hts_include =~ s{include/htslib$}{include};
++
++ if (hts_dev_files_exist($hts_lib, $hts_include)) {
++ $self->config_data('hts_lib' => $hts_lib);
++ $self->config_data('hts_include' => $hts_include);
++ return 1;
++ }
++ else {
++ return 0;
++ }
++}
++
+ sub die_hts_not_found {
+ my ($self, $msg) = @_;
+
+@@ -170,12 +195,13 @@ Install it if you have not done so already.
+ This script will attempt to locate HTSlib by looking for htslib/hts.h
+ and libhts.a / libhts.so in:
+
+- 1. --htslib command line argument
+- 2. HTSLIB_DIR environment variable
+- 3. --prefix command line argument (which also sets installation location)
+- 4. Alien::HTSlib dependency resolver
+- 5. pkg-config (extra directories can be set in PKG_CONFIG_PATH environment variable)
+- 6. common library locations: /usr /usr/local, /usr/share, /opt/local
++ 1. --htslib-includedir and --htslib-libdir command line arguments
++ 2. --htslib command line argument
++ 3. HTSLIB_DIR environment variable
++ 4. --prefix command line argument (which also sets installation location)
++ 5. Alien::HTSlib dependency resolver
++ 6. pkg-config (extra directories can be set in PKG_CONFIG_PATH environment variable)
++ 7. common library locations: /usr /usr/local, /usr/share, /opt/local
+
+ END
+
diff --git a/dev-perl/Bio-DB-HTS/metadata.xml b/dev-perl/Bio-DB-HTS/metadata.xml
new file mode 100644
index 000000000000..95abbb699ad4
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ensembl/Bio-DB-HTS</remote-id>
+ <remote-id type="cpan">Bio-DB-HTS</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS</remote-id>
+ </upstream>
+</pkgmetadata>