summaryrefslogtreecommitdiff
path: root/dev-perl/Bio-DB-HTS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/Bio-DB-HTS
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/Bio-DB-HTS')
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild47
-rw-r--r--dev-perl/Bio-DB-HTS/Manifest3
-rw-r--r--dev-perl/Bio-DB-HTS/metadata.xml27
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild
new file mode 100644
index 000000000000..dcae1156e881
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=3.01
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-biology/bioperl
+ sci-libs/htslib:=
+"
+DEPEND="
+ dev-perl/Module-Build
+ sci-libs/htslib:=
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.11-build_env_ldflags.patch"
+ "${FILESDIR}/2.11-build_split_htslib_opts.patch"
+)
+
+src_configure() {
+ local myconf="--htslib-includedir=${EPREFIX}/usr/include/htslib --htslib-libdir=${EPREFIX}/usr/$(get_libdir)"
+ unset LD
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}
diff --git a/dev-perl/Bio-DB-HTS/Manifest b/dev-perl/Bio-DB-HTS/Manifest
index b07629e9be8a..b862454390fc 100644
--- a/dev-perl/Bio-DB-HTS/Manifest
+++ b/dev-perl/Bio-DB-HTS/Manifest
@@ -3,5 +3,6 @@ AUX 2.11-build_split_htslib_opts.patch 2453 BLAKE2B 19f99d0a56db7c4778bc478cd952
DIST Bio-DB-HTS-2.11.tar.gz 5250814 BLAKE2B d77ccacebf339a33ab106b997139cdbf79f6c28269a832305e660b28370aca82b4c9824773acdbf8f59b18dd61f40346a9870578dba7b5b989b0f3bc9ad14b35 SHA512 114d90fe92b684250183b45b4d23d2dd45ecdcb2fa54f7b1c311ed668d8e87953adb861f709a0a48ff2b873ce777b21bc3b557bafa0df216b9a71b59facff6fd
DIST Bio-DB-HTS-3.01.tar.gz 5250834 BLAKE2B ca7d3dfb6886460e7beee495eaa6857c912dc6bff24c1c8b888e7ada5ca736035af7ee48adeb5dd3b10204f99be4d0e2cb8d6350fa3e7bfe3fb1299e935ddc4e SHA512 4a464ffb300edf8ed8839c4d788a7c53d2a2cdc5abd675b8648d42e0b60f78b905dfb81cf1396daddbf2e279db2819df250117ecebdc3de5fdcb94a812182255
EBUILD Bio-DB-HTS-2.110.0.ebuild 708 BLAKE2B 0e10e42a145505e7445687411f809c8810f3b052e2695ed93b44aa4ae603692a4431038ed385bcd4bd90b85f8c9bd6938643ebd79a4cbc20eaf2f50877849ff2 SHA512 a9930cf078bb84e03b5281774ef3b98c712cb1c8d62e865487978af568659fcaa445263c40fba2bc01cf7a3ee25e5e2f302238e29acee6826b6f1ae4a4d467ea
+EBUILD Bio-DB-HTS-3.10.0-r1.ebuild 900 BLAKE2B b3c0b4ff419f88a4dce8e9c67e07fb616ad93ce3b0481358f2c069e134189467ec26b04af618859411da2c5c5e65da55a29fa7544163f424ad1b7c86d48131f9 SHA512 5369f81951a6e4542a7aceff170659a883ca387988ba0587e5fbfe84c02fe15bc1c078809731f0184616f7350b65bacf737bcfe3f130400844ed975c6cf901c8
EBUILD Bio-DB-HTS-3.10.0.ebuild 706 BLAKE2B dd60fd553fc822310aa4a75f43fd76748544c58edd6e1d89ea8f8426e5625738db71978d6a7d84f269f2a5dda2ee8c83487f61b5e56f0721f1886313b4fef953 SHA512 daf5fa2771c1d85f52ac9d6ec5b4453360701793ae479876cbe4792e6ef84f3f7290229e4d83cd62cfb24b1af81f11d461fc1f4d3828b8e1a9ab9710638b86b9
-MISC metadata.xml 555 BLAKE2B fe8d2547a6d959f24231c15b5803e8e71dd94ac0d865dd0a53dff97c62b39db8ff40f845f7d4a48cd4dc19d31c044e06ca8394d745a79c532fc61e96a66dab3f SHA512 9e03a79d88ca855783562bd5d3b9a4f71698c2caae43c009bbcf312bd5810d362842cb4e834291b08a5231785f59fc5598edca6868716d5a7487716d10acac39
+MISC metadata.xml 2405 BLAKE2B b07a2b190e6b44a773106706dcb639fbbf943aa524751db79bb82c88180d00ea820f858d7285196b1bdd22f2f2d9f71e746dfa0366575394d47aaf38e25d1ee7 SHA512 a4a174524fc1a77ee5957d172a02caf68f7aff24e25c322b1c0109d6f2da5065cfb5e9dec43f1d12e4e887442cf0eb391f60fdf0273fa03eee2017f274b58ad8
diff --git a/dev-perl/Bio-DB-HTS/metadata.xml b/dev-perl/Bio-DB-HTS/metadata.xml
index 95abbb699ad4..126683a7c28f 100644
--- a/dev-perl/Bio-DB-HTS/metadata.xml
+++ b/dev-perl/Bio-DB-HTS/metadata.xml
@@ -13,5 +13,32 @@
<remote-id type="github">Ensembl/Bio-DB-HTS</remote-id>
<remote-id type="cpan">Bio-DB-HTS</remote-id>
<remote-id type="cpan-module">Bio::DB::HTS</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::AlignWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Alignment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Constants</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Fai</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Faidx</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::FetchIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Kseq</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Kseq::Record</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Pileup</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::PileupWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Query</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::ReadIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Segment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Segment::Iterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::SplitAlignmentPart</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Tabix</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Tabix::Iterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::Target</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::Header</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::HeaderPtr</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::Iterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::Row</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::RowPtr</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS::VCF::Sweep</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTSfile</remote-id>
+ <remote-id type="cpan-module">Bio::SeqFeature::HTSCoverage</remote-id>
</upstream>
</pkgmetadata>