summaryrefslogtreecommitdiff
path: root/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
new file mode 100644
index 000000000000..2c2e6ab8c967
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.80.0
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Scope-Guard
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}