summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-PAM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Authen-PAM
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Authen-PAM')
-rw-r--r--dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild19
-rw-r--r--dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild43
-rw-r--r--dev-perl/Authen-PAM/Manifest5
-rw-r--r--dev-perl/Authen-PAM/files/no-dot-inc.patch32
-rw-r--r--dev-perl/Authen-PAM/metadata.xml12
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild
new file mode 100644
index 000000000000..910cb91d7991
--- /dev/null
+++ b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=NIKIP
+MODULE_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Interface to PAM library"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+export OPTIMIZE="$CFLAGS"
diff --git a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild
new file mode 100644
index 000000000000..f304841a1647
--- /dev/null
+++ b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NIKIP
+DIST_VERSION=0.16
+DIST_EXAMPLES=("test.pl")
+inherit perl-module
+
+DESCRIPTION="Interface to PAM library"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="examples"
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+export OPTIMIZE="$CFLAGS"
+
+src_test() {
+ local MODULES=(
+ "Authen::PAM ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ ewarn "To comprehensively test this module, interactive testing is necessary"
+ ewarn "For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Authen-PAM"
+}
diff --git a/dev-perl/Authen-PAM/Manifest b/dev-perl/Authen-PAM/Manifest
new file mode 100644
index 000000000000..637c5a007204
--- /dev/null
+++ b/dev-perl/Authen-PAM/Manifest
@@ -0,0 +1,5 @@
+AUX no-dot-inc.patch 1024 BLAKE2B ba54cae4654e003da18f1c733a95cbc9fe474981e3cc90a9e957812da306b2be89721e82f34f7bd3df14acbb254e41587786d0ecb9db35a3aff47db1c186fbaf SHA512 1701f4b03709f46b7c84a1ed4c38f75f064149306dcf5e99d8f2e40256600b6a1003dae99287ae4a6f1ce9ba9d330d21c99ad9a33982486f1b2f474d1df00120
+DIST Authen-PAM-0.16.tar.gz 45922 BLAKE2B 87f0097e1ca608e5b86410a0ddf7fd0343ef9cf7ea2f3051e9ff5daeaed21569bdf9735402402cfb66744c945f02b13594893146270b95fd91bc7d11988b4ccf SHA512 2419698193697cb8c9ac3a1527a25abefffd9f15f4b492006081b2c8e7fe9e01e00f33e8fed6a07611b725b38ed92d9feb51b8ba61e4c23313cc5ff9ea1c05fd
+EBUILD Authen-PAM-0.160.0-r1.ebuild 409 BLAKE2B 8868a9501b1870ce181190379ca6562bd4ba7999e9205a89ad1670026a9ff0e4590ea300ba6cd7b28ae51eaeca8b6ab58adc68094dae9888be7af65366d3d5f1 SHA512 8d2d109683cbd06332050da733242ff3b9e83dcbb3947161396d3920fcdacd2991d3ed3d135ae798e88ee5c002fbdac98ded5a0a8b32aae73ac1a56944e40602
+EBUILD Authen-PAM-0.160.0-r2.ebuild 1057 BLAKE2B 97e34732c51a23ef3f959255fed62a9547fcb397046d1feae01fde21d693917784f80dff87bd8fc9a7f9d3c2134276b8d3e9a4600db914b2bc2d826c38d6ebdc SHA512 e2094b2126c4f5617d431feca68e1ad919f9c06c2e1b8961aa436286b03c23d4236237b2652b6b63184082bc9feda8edd8e38be90dbdce57a0ad9ccc0d90a366
+MISC metadata.xml 392 BLAKE2B cc59e0b968461f101b4403721f80dc27f6356c349032d539583ae900e486856f54a6e9cc46c414fcf5cbc11c551bac023a34f33d59cf640c90514074a550ee55 SHA512 bf28ee065f5033975b0d31647b15dd73d879b03c2c30a40433f8a67b6cc3b34ce483f985adfd29ab135b73d6f2f9f6d62e40beed947ef4eaec970902762114fc
diff --git a/dev-perl/Authen-PAM/files/no-dot-inc.patch b/dev-perl/Authen-PAM/files/no-dot-inc.patch
new file mode 100644
index 000000000000..fa1d5492da98
--- /dev/null
+++ b/dev-perl/Authen-PAM/files/no-dot-inc.patch
@@ -0,0 +1,32 @@
+From cad0178cc0bdacd33f7faf2f86afa6d2a118f730 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Wed, 14 Jun 2017 20:39:17 +1200
+Subject: [PATCH] Fix for '.' removal from @INC in Perl 5.26
+
+ require "foo.ext"
+
+Never really implied it would load files from ./ , it only did so
+as a side effect of '.' being in @INC.
+
+The only way which works after 5.26 is to use an explicit ./ prefix,
+which is special-cased for this purpose.
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f6e2d49..c7ffd45 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -10,7 +10,7 @@ sub configure {
+
+ # returns a reference to anonymous hash which is then interpreted as
+ # additional options to the WriteMakeFile
+- $options = require "pam.cfg";
++ $options = require "./pam.cfg";
+
+ if ( $Config{'osname'} eq 'solaris' && $Config{'osvers'} eq '2.6') {
+ print "Adding a workaround for a bug in the Solaris 2.6 pam library\n";
+--
+2.13.1
+
diff --git a/dev-perl/Authen-PAM/metadata.xml b/dev-perl/Authen-PAM/metadata.xml
new file mode 100644
index 000000000000..b2a60a6e4458
--- /dev/null
+++ b/dev-perl/Authen-PAM/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Authen-PAM</remote-id>
+ <remote-id type="cpan-module">Authen::PAM</remote-id>
+ </upstream>
+</pkgmetadata>