summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-Libwrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/Authen-Libwrap
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/Authen-Libwrap')
-rw-r--r--dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r2.ebuild46
-rw-r--r--dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0.ebuild30
-rw-r--r--dev-perl/Authen-Libwrap/Manifest3
-rw-r--r--dev-perl/Authen-Libwrap/files/Authen-Libwrap-0.23-inc-paths.patch98
4 files changed, 146 insertions, 31 deletions
diff --git a/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r2.ebuild b/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r2.ebuild
new file mode 100644
index 000000000000..79aaf42ae9be
--- /dev/null
+++ b/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DMUEY
+DIST_VERSION=0.23
+DIST_EXAMPLES=("example.pl")
+inherit perl-module multilib
+
+DESCRIPTION="A Perl access to the TCP Wrappers interface"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/tcp-wrappers"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ virtual/perl-ExtUtils-CBuilder
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Exception
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.23-inc-paths.patch"
+)
+PERL_RM_FILES=(
+ t/03_pod.t
+ t/02_maintainer.t
+)
+src_configure() {
+ unset LD
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ GENTOO_INCDIR="${EPREFIX}/usr/include" \
+ GENTOO_LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}
diff --git a/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0.ebuild b/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0.ebuild
deleted file mode 100644
index d501b465e685..000000000000
--- a/dev-perl/Authen-Libwrap/Authen-Libwrap-0.230.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=DMUEY
-DIST_VERSION=0.23
-DIST_EXAMPLES=("example.pl")
-inherit perl-module
-
-DESCRIPTION="A Perl access to the TCP Wrappers interface"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-apps/tcp-wrappers"
-DEPEND="${RDEPEND}
- >=dev-perl/Module-Build-0.420.0
- virtual/perl-ExtUtils-CBuilder
- test? (
- virtual/perl-Test-Simple
- dev-perl/Test-Exception
- )
-"
-src_test() {
- perl_rm_files t/03_pod.t t/02_maintainer.t
- perl-module_src_test
-}
diff --git a/dev-perl/Authen-Libwrap/Manifest b/dev-perl/Authen-Libwrap/Manifest
index 2ac1d3fa92d6..e3024dfacde5 100644
--- a/dev-perl/Authen-Libwrap/Manifest
+++ b/dev-perl/Authen-Libwrap/Manifest
@@ -1,4 +1,5 @@
+AUX Authen-Libwrap-0.23-inc-paths.patch 2969 BLAKE2B ebd4a327997e6ed3de0d837cf839298765e6d489bdebb1bcffd3360c1fe0e277c555276fbfbb1208313ee23da757b546b37c5879f23603d42dd2aee1bcd65d34 SHA512 8c9c4f47fea0528db3b74048a075489dfeb6d7337bdad6e550c922e977482c5cb40a2ac7c9b57054ee6a50c13b5ddc08858596b7537381aa2554abe87a8b9f5c
DIST Authen-Libwrap-0.23.tar.gz 20031 BLAKE2B 01db2215508e7503d69393fb8c72152884972de8ade147c356f5a5736edf0504cb31607ef2d3737824e1ec788d47fa6d16d8c459284fd014fe94739d629fe33c SHA512 aa16e783c3819e5c2969032e8e9fd966579fc6862eccd078b3968fcb69c2bff11746afaaf8271bd6d6e9ea137b90937d554cf422208b78c4c628d100bb5f744e
EBUILD Authen-Libwrap-0.230.0-r1.ebuild 776 BLAKE2B def28492bfee055170e64b770779d36655496bef647691175b1b3399d525dedde98e75e1f668c7920843045681ad6c0b9a5a9ec1860451c953f16ed0b225c8b3 SHA512 5ff08d72dd1267232591dcb36e1028fa1b70107711d26ebeceb1294c14d60491e253ac6ce9972ba5495683a7a5480f97193f6bddb73c6f7a59575cd26096a215
-EBUILD Authen-Libwrap-0.230.0.ebuild 594 BLAKE2B c8ad1a42ea38e59df9f3dfabb16b76a524d8d5b9e6d06d1aa36e9014634b4592b351b98310a668da071cfef0af3b67b7e97eb1c50c17ec78a1851f2094124f45 SHA512 9edca1132381786e0ed570d61e6e8defb75709cdbfb2c23e07b4e3eebfa12e522a864e606d558a6a9107ee4fa44cfef79e27839608fa5bafc14674f1911176a7
+EBUILD Authen-Libwrap-0.230.0-r2.ebuild 931 BLAKE2B 532bb8f78e34cadc50fd742dcdf2d67fef77059dc0b684c44ec164004bdf4c3206089572ad1a77b78e2605eb7d5afde4dbee94456c8a495f247a4dcfc45f7068 SHA512 e38e55f4fcd2519c5e77f559381d98561224c83fcd1616f24a7bb7e6c1c989c3953ba8fe94aa356f7ba1278486168c7fbb870af9f9ce843670b64886af9705c2
MISC metadata.xml 400 BLAKE2B 33402b72399ebc4435e5cefe5feaa8f10197a64dba5ce67d7ec45ba3af4fc34a1080edcd9a7652f52c5861d54db6811168d05e45d6036eec30cdf529c04fb483 SHA512 ee11324c2a6e06384ab8632e80e408029cc40bb3b2b7613581bc49c01206b6f8c265c6e838a6e1918959f6c7110934272e4c10a8f64d6e412adabef1905e1e03
diff --git a/dev-perl/Authen-Libwrap/files/Authen-Libwrap-0.23-inc-paths.patch b/dev-perl/Authen-Libwrap/files/Authen-Libwrap-0.23-inc-paths.patch
new file mode 100644
index 000000000000..e6b2998b5eb6
--- /dev/null
+++ b/dev-perl/Authen-Libwrap/files/Authen-Libwrap-0.23-inc-paths.patch
@@ -0,0 +1,98 @@
+From 012d607fa5ca2dd8d7b48110a9639841cd3db704 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 16 Aug 2020 12:59:38 +1200
+Subject: Remove libdir/incdir autodetection magic
+
+Instead, in favour of gentoo controled paths and hard-erroring when
+they're wrong.
+
+Bug: https://bugs.gentoo.org/737212
+---
+ Build.PL | 70 +++++++++++---------------------------------------------
+ 1 file changed, 13 insertions(+), 57 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index c76c1d8..d2179de 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -9,64 +9,20 @@ use Module::Build;
+
+ use File::Spec;
+
+-my $inc_dir;
+-my $lib_dir;
+-
+-# possible prefixes where we might find libwrap.a
+-# if you know of other common ones please let me know
+-my @prefixes = (
+- File::Spec->catdir( File::Spec->rootdir, 'usr' ),
+- File::Spec->catdir( File::Spec->rootdir, 'usr', 'local' ),
+- File::Spec->catdir( File::Spec->rootdir, 'opt' ),
+- File::Spec->catdir( File::Spec->rootdir, 'opt', 'local' ),
+- File::Spec->catdir( File::Spec->rootdir, 'opt', 'libwrap' ),
+- File::Spec->catdir( File::Spec->rootdir, 'opt', 'tcpwrappers' ),
+-);
+-
+-# try to figure out where libwrap.a is
+-for my $prefix( @prefixes ) {
+- for my $libname( qw|libwrap.so libwrap.a| ) {
+- my $candidate = File::Spec->catfile( $prefix, 'lib', $libname );
+- if( -e $candidate && -f _ && -r _ ) {
+- my $y_n = Module::Build->y_n(
+- "do you want to link against $candidate?", "y"
+- );
+- if( $y_n ) {
+- $lib_dir = File::Spec->catdir( $prefix, 'lib' );
+- last;
+- }
+- }
+- }
+-}
+-
+-# try to figure out where tcpd.h is
+-for my $prefix( @prefixes ) {
+- my $candidate = File::Spec->catfile( $prefix, 'include', 'tcpd.h' );
+- if( -e $candidate && -f _ && -r _ ) {
+- my $y_n = Module::Build->y_n(
+- "do you want to use $candidate as your header?", "y"
+- );
+- if( $y_n ) {
+- $inc_dir = File::Spec->catdir( $prefix, 'include' );
+- last;
+- }
+- }
+-}
+-
+-# if we can't find it, prompt
+-unless( $inc_dir ) {
+- $inc_dir = Module::Build->prompt(
+- "enter include directory to use:",
+- File::Spec->catdir($prefixes[0], 'include')
+- );
+-}
+-unless( $lib_dir ) {
+- $lib_dir = Module::Build->prompt(
+- "enter library directory to use:",
+- File::Spec->catdir($prefixes[0], 'lib')
+- );
+-}
++my $inc_dir = $ENV{GENTOO_INCDIR};
++my $lib_dir = $ENV{GENTOO_LIBDIR};
+
++die "GENTOO_LIBDIR not set" unless $lib_dir;
++die "GENTOO_INCDIR not set" unless $inc_dir;
++
++die "No usable libwrap.so in $lib_dir" unless -e File::Spec->catfile( $lib_dir, 'libwrap.so' )
++ and -f _ and -r _;
++
++die "No usable tcpd.h in $inc_dir" unless -e File::Spec->catfile( $inc_dir, 'tcpd.h' )
++ and -f _ and -r _;
++
++warn "$0 libdir: $lib_dir\n";
++warn "$0 incdir: $inc_dir\n";
+ # create the Buildfile
+ Module::Build->new(
+
+--
+2.28.0
+