summaryrefslogtreecommitdiff
path: root/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild')
-rw-r--r--dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..a0ef36b985a1
--- /dev/null
+++ b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AGRUNDMA
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Fast C metadata and tag reader for all common audio file formats"
+# License note: ambiguity: https://rt.cpan.org/Ticket/Display.html?id=132450
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Warn
+ )
+"
+PERL_RM_FILES=(
+ "t/02pod.t"
+ "t/03podcoverage.t"
+ "t/04critic.t"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}