summaryrefslogtreecommitdiff
path: root/dev-perl/AtExit/AtExit-2.30.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-perl/AtExit/AtExit-2.30.0-r2.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-perl/AtExit/AtExit-2.30.0-r2.ebuild')
-rw-r--r--dev-perl/AtExit/AtExit-2.30.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/AtExit/AtExit-2.30.0-r2.ebuild b/dev-perl/AtExit/AtExit-2.30.0-r2.ebuild
new file mode 100644
index 000000000000..abd8be34c07e
--- /dev/null
+++ b/dev-perl/AtExit/AtExit-2.30.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=2.03
+inherit perl-module
+
+DESCRIPTION="atexit() function to register exit-callbacks"
+
+# smallest common denominator, see
+# https://bugs.gentoo.org/721204
+# https://rt.cpan.org/Public/Bug/Display.html?id=132447
+LICENSE="Artistic"
+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc sparc x86"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Capture-Tiny
+ virtual/perl-Test-Simple
+ )
+"