summaryrefslogtreecommitdiff
path: root/dev-perl/AtExit/AtExit-2.30.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-perl/AtExit/AtExit-2.30.0-r1.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-perl/AtExit/AtExit-2.30.0-r1.ebuild')
-rw-r--r--dev-perl/AtExit/AtExit-2.30.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/AtExit/AtExit-2.30.0-r1.ebuild b/dev-perl/AtExit/AtExit-2.30.0-r1.ebuild
new file mode 100644
index 000000000000..0e554dfd7e56
--- /dev/null
+++ b/dev-perl/AtExit/AtExit-2.30.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=2.03
+inherit perl-module
+
+DESCRIPTION="atexit() function to register exit-callbacks"
+
+# smallest common denominator, see
+# https://bugs.gentoo.org/721204
+# https://rt.cpan.org/Public/Bug/Display.html?id=132447
+LICENSE="Artistic"
+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Capture-Tiny
+ virtual/perl-Test-Simple
+ )
+"