summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-Test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Apache-Test
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Apache-Test')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.400.0-r2.ebuild119
-rw-r--r--dev-perl/Apache-Test/Manifest6
-rw-r--r--dev-perl/Apache-Test/files/Apache-Test-1.400.0-catfile-import.patch26
-rw-r--r--dev-perl/Apache-Test/files/Apache-Test-1.400.0-fix-missing-semicolon.patch26
-rw-r--r--dev-perl/Apache-Test/files/Apache-Test-1.400.0-phpclient.patch29
-rw-r--r--dev-perl/Apache-Test/metadata.xml50
6 files changed, 256 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.400.0-r2.ebuild b/dev-perl/Apache-Test/Apache-Test-1.400.0-r2.ebuild
new file mode 100644
index 000000000000..85b4e4bf2b15
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.400.0-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHAY
+DIST_VERSION=1.40
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ~mips ppc ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+need_apache
+
+PATCHES=(
+ "${FILESDIR}/${P}-catfile-import.patch"
+ "${FILESDIR}/${P}-fix-missing-semicolon.patch"
+ "${FILESDIR}/${P}-phpclient.patch"
+)
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
+# Parallel tests seem to be bad.
+DIST_TEST="do"
+
+optdep_notice() {
+ local i
+ elog "This package has several modules which may require additional dependencies"
+ elog "to use. However, it is up to you to install them separately if you need this"
+ elog "optional functionality:"
+ elog
+ i="$(if has_version 'www-apache/mod_perl'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i www-apache/mod_perl"
+ elog " - Running Perl code natively in Apache via"
+ elog " Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl"
+
+ if use test; then
+ elog
+ elog "This module will perform additional tests if these dependencies are"
+ elog "pre-installed"
+ fi
+}
+src_test() {
+ optdep_notice
+ echo
+ local MODULES=(
+ "Apache::Test ${DIST_VERSION}"
+ "Apache::Test5005compat 0.01"
+ "Apache::TestBuild"
+ "Apache::TestClient"
+ "Apache::TestCommon"
+ "Apache::TestCommonPost"
+ "Apache::TestConfig"
+ "Apache::TestConfigC"
+ "Apache::TestConfigPHP"
+ "Apache::TestConfigParrot"
+ "Apache::TestConfigParse"
+ "Apache::TestConfigPerl"
+ "Apache::TestHarness"
+ "Apache::TestHarnessPHP"
+ "Apache::TestMB"
+ "Apache::TestMM"
+ "Apache::TestPerlDB"
+ "Apache::TestReport"
+ "Apache::TestRequest"
+ "Apache::TestRun"
+ "Apache::TestRunPHP 1.00"
+ "Apache::TestRunParrot 1.00"
+ "Apache::TestRunPerl 1.00"
+ "Apache::TestSSLCA"
+ "Apache::TestServer"
+ "Apache::TestSmoke"
+ "Apache::TestSort"
+ "Apache::TestTrace 0.01"
+ "Apache::TestUtil 0.02"
+ "Bundle::ApacheTest ${DISTVERSION}"
+ )
+ has_version "www-apache/mod_perl" && MODULES+=(
+ "Apache::TestHandler"
+ "Apache::TestReportPerl"
+ "Apache::TestSmokePerl"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl_rm_files t/more/02testmore.t t/more/04testmore.t
+ perl-module_src_test
+}
+pkg_postinst() {
+ use test || optdep_notice
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
new file mode 100644
index 000000000000..795420cd5a8f
--- /dev/null
+++ b/dev-perl/Apache-Test/Manifest
@@ -0,0 +1,6 @@
+AUX Apache-Test-1.400.0-catfile-import.patch 813 BLAKE2B eda9f0dcfae5025d94f3c126e61258a920e8b0a475fb147bd61a96676aa8211c0d70e3aa5a37976603bb67c3d5a93e27feb0735456523bdf7c8706dbb254b730 SHA512 2c7807a0e69652b58f8d5297ac5e24f90ae3e453a3025dc441afef0134eed7dd0d78728dfce47a15c93c498f6e70404b1a79df07de55b376ae267453ba0b990b
+AUX Apache-Test-1.400.0-fix-missing-semicolon.patch 761 BLAKE2B 9dada5195ba8312078fa8d83cd808ea770e573b963c4b43f577efa61e3bf52f8961ed5e2ddc7772c267c639d8b74324c6a145cd21606f59344516973adc8c06b SHA512 eb5a66ce55fb4186cf6b5145872cbddc166882568da0cb397315d69b0ff3c986dd59daf8f6ba8cad831fe4b471efa64ec81515e59f6bb28f9d5bfcb26b80999e
+AUX Apache-Test-1.400.0-phpclient.patch 909 BLAKE2B f109642536a1253245e55332e084b9c82fe4b72368cc34b4097889cd31358de4b29374d1c930de543ca5515f49ec69f950472923425064b30e677b1a3ff04b9b SHA512 45eb984222177a2d63402378db9641d1abebcd7c1a1207687330e71c6f0717278bd3a15e35c988c4846f19ae0eaf1c88cdaf0b74a9f78a35f6826b396420a101
+DIST Apache-Test-1.40.tar.gz 151801 BLAKE2B 0ec57b0a8a0fafc8d10409a3cd02308da67bd6766caa71bfb525ef49832545c811281a987a5237be236a3a581fcf8311785d0bff8d283db2c52f08d11cd2bda1 SHA512 f48a1b93c4d61181670ec59bb8bb2231122b22ec9725d8899a3b2f82d2918fdc48a09494c2f45b0e6a603546481892a948eac3494e06c8eb219a9213e1faadb8
+EBUILD Apache-Test-1.400.0-r2.ebuild 2904 BLAKE2B 15733675ab3edce3a35acdc23024761d6388a2ff5afe29c083bc2b8a43b30c7db4cf12401d7a240bfd4c60b46d0a1ab6b1b3a425530942fb2f3b5a6602a308f1 SHA512 0bf676aa15964dc7d49de44bcd0ba6d140fc3e6b1498db9ef18ee1260c496dae2b4afc4d54ecdd110f74814c6cad5ce027041a134ad98c0a06eb6034c60154aa
+MISC metadata.xml 2858 BLAKE2B 11f5085f6e904752d042347bdb966364c063c33d1e3b1cfb0f9c47db6e5020f3cd113c24d118cdc75bd0d3c70f82ec1e906b148d9119fce815ed6e0703efeba6 SHA512 1db84f146dd887e3719328aba99809ac3ba8462226b9109310675b1722b2874cddd54b82900852082160bd47bf157611ba9f324d1f2964ee6912d4bff3690517
diff --git a/dev-perl/Apache-Test/files/Apache-Test-1.400.0-catfile-import.patch b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-catfile-import.patch
new file mode 100644
index 000000000000..8bd6dbfddf62
--- /dev/null
+++ b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-catfile-import.patch
@@ -0,0 +1,26 @@
+From f06bb625c7feb44bf9b5c13617522ce57cdad84e Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 15 Oct 2017 06:16:45 +1300
+Subject: Fix missing import of "catfile"
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123283
+---
+ lib/Apache/TestConfigParse.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Apache/TestConfigParse.pm b/lib/Apache/TestConfigParse.pm
+index 88a19af..8fe0fe4 100644
+--- a/lib/Apache/TestConfigParse.pm
++++ b/lib/Apache/TestConfigParse.pm
+@@ -23,7 +23,7 @@ use warnings FATAL => 'all';
+
+ use Apache::TestTrace;
+
+-use File::Spec::Functions qw(rel2abs splitdir file_name_is_absolute);
++use File::Spec::Functions qw(rel2abs splitdir file_name_is_absolute catfile);
+ use File::Basename qw(dirname basename);
+
+ sub strip_quotes {
+--
+2.14.2
+
diff --git a/dev-perl/Apache-Test/files/Apache-Test-1.400.0-fix-missing-semicolon.patch b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-fix-missing-semicolon.patch
new file mode 100644
index 000000000000..f09cd53348fc
--- /dev/null
+++ b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-fix-missing-semicolon.patch
@@ -0,0 +1,26 @@
+From b2a2cdc1e9a3121ea8848ab4a2410c5dcc68d620 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 15 Oct 2017 06:15:47 +1300
+Subject: Fix missing ";"
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123282
+---
+ lib/Apache/TestConfigPHP.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Apache/TestConfigPHP.pm b/lib/Apache/TestConfigPHP.pm
+index 0ddea0b..1c79865 100644
+--- a/lib/Apache/TestConfigPHP.pm
++++ b/lib/Apache/TestConfigPHP.pm
+@@ -170,7 +170,7 @@ sub configure_php_ini {
+ my $dir = catfile $self->{vars}->{serverroot}, 'conf';
+ my $file = catfile $dir, 'php.ini';
+
+- return if -e $file
++ return if -e $file;
+
+ my $log = catfile $self->{vars}->{t_logs}, 'error_log';
+
+--
+2.14.2
+
diff --git a/dev-perl/Apache-Test/files/Apache-Test-1.400.0-phpclient.patch b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-phpclient.patch
new file mode 100644
index 000000000000..cecf7de10850
--- /dev/null
+++ b/dev-perl/Apache-Test/files/Apache-Test-1.400.0-phpclient.patch
@@ -0,0 +1,29 @@
+From 2dbb0fcab02ea60c0ca5e6ab4150691ffcfb8d7c Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 15 Oct 2017 06:47:45 +1300
+Subject: Don't die at load time due to undeclared '$phpclient'
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123284
+---
+ lib/Apache/TestHarnessPHP.pm | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/lib/Apache/TestHarnessPHP.pm b/lib/Apache/TestHarnessPHP.pm
+index 90fdedc..806ba6f 100644
+--- a/lib/Apache/TestHarnessPHP.pm
++++ b/lib/Apache/TestHarnessPHP.pm
+@@ -90,11 +90,6 @@ sub get_tests {
+ 'make sure php is in your PATH');
+ @tests = grep { not /\.php$/ } @tests;
+ }
+- elsif (! $phpclient) {
+- warning(join ' - ', 'skipping *.php tests',
+- 'Test::Harness 2.38 not available');
+- @tests = grep { not /\.php$/ } @tests;
+- }
+
+ return @tests;
+ }
+--
+2.14.2
+
diff --git a/dev-perl/Apache-Test/metadata.xml b/dev-perl/Apache-Test/metadata.xml
new file mode 100644
index 000000000000..9a11d8f604ef
--- /dev/null
+++ b/dev-perl/Apache-Test/metadata.xml
@@ -0,0 +1,50 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>The Apache::Test framework was designed for creating test
+ suites for products running on the Apache httpd webserver (not
+ necessarily mod_perl). Originally designed for the mod_perl Apache
+ module, it was extended to be used for any Apache
+ module.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Apache-Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test5005compat</remote-id>
+ <remote-id type="cpan-module">Apache::TestBuild</remote-id>
+ <remote-id type="cpan-module">Apache::TestClient</remote-id>
+ <remote-id type="cpan-module">Apache::TestClientResponse</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommon</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommonPost</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfig</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigC</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestHandler</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarness</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarnessPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestMB</remote-id>
+ <remote-id type="cpan-module">Apache::TestMM</remote-id>
+ <remote-id type="cpan-module">Apache::TestReport</remote-id>
+ <remote-id type="cpan-module">Apache::TestReportPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestRequest</remote-id>
+ <remote-id type="cpan-module">Apache::TestRun</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSSLCA</remote-id>
+ <remote-id type="cpan-module">Apache::TestServer</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmoke</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmokePerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSort</remote-id>
+ <remote-id type="cpan-module">Apache::TestToString</remote-id>
+ <remote-id type="cpan-module">Apache::TestTrace</remote-id>
+ <remote-id type="cpan-module">Apache::TestUtil</remote-id>
+ <remote-id type="cpan-module">Bundle::ApacheTest</remote-id>
+ <remote-id type="cpan-module">HTTP::Request::Common</remote-id>
+ <remote-id type="cpan-module">warnings</remote-id>
+ </upstream>
+</pkgmetadata>